Issues with Wacom Tablets?

Discussion in 'Windows Virtual Machine' started by RZetlin, Aug 28, 2007.

  1. RZetlin

    RZetlin Bit poster

    I have a Macbook with XP Pro installed through Parallels.

    The lastest Wacom drivers are installed.

    Parallels detects the Wacom Graphire 3 Tablet, but the wacom cursor disappears when Parallels has focus on the tablet.

    Without a cursor, it is impossible to know where to draw.

    Is there a fix for this issue?
  2. spectre

    spectre Parallels Team

    Please specify your Parallels Desktop version build number.
  3. RZetlin

    RZetlin Bit poster

    Parallels 3.0 Build 4560 July 2007
  4. orija

    orija Bit poster

    i have the same problem with the MacBook Pro and parallels. same build of Parallels. this problem has been there all along however. it has been mentioned several times on the forum but never any answer to the issue.
  5. gold5201

    gold5201 Bit poster

    Wacom Tablet in XP using Parallels

    The problem is that even though the Wacom tablet driver is installed on XP, XP does not recognize the tablet. I spoke to Wacom and they said that this is a known issue that Parallels needs to address. While it is still possible to ink in XP using the tablet, the ink is not as smooth and you cannot use the the other features of the pen such as the eraser because the XP driver does not recognize the Wacom tablet. (Note: I downloaded the trial version of Parallels earlier this week.) By comparison, the Wacom Tablet performs much better in the Mac OS because the Mac driver recognizes the Wacom Tablet.
  6. primitivehuman

    primitivehuman Bit poster

    I have the same issues with build 5160 with Windows XP Pro on my intel Macbook core duo (black) 2 gigs RAM. The worst part is that I'm trying to use it with Sketchbook Pro because the Mac version hasn't been updated to a universal binary. So I'm actually able to use SKP, yet there is no pressure sensitivity. It really sucks because I'm basically stuck with a $200 program that I cannot fully utilize. I'm probably going to try again with Fusion. If that doesn't work I'll see about ordering a replacement XP Pro disk to use with Bootcamp. My VM is a converted Virtual PC 7.0 (came packaged with XP Pro) so the whole ordeal is a real pain in the a$$.
  7. stephtran

    stephtran Bit poster

    same issue > working half the time

    I'm using Zbrush for PC and need pressure support, I installed the latest build of Parallels (5160) and new wacom drivers (6.05 -7). Here's a rundown of what happens:

    1. By default, the tablet (intuos 2) is not recognized. If I go to the wacom Control Panel, it tells me no tablet is recognized.
    2. I click on the parallels USB icon (bottom-left) and select the wacom (which appears as XD-....-U)
    3. Parallels prompts me if I want to connect this USB HID to the virtual Machine > YES!
    4. Little windows sound of new device installed goes off in the background
    5. No windows cursor visible, but the tablet is recognized with pressure sensitivity...You can confirm it works by opening the wacom driver screen and selecting About>diagnose
    6. Of course now the wacom is disabled in os X until you close the virtual machine!

    I'm not sure that helps, but it's a start eh?
  8. stephtran

    stephtran Bit poster

    Make the wacom cursor visible in Parallels

    A little hack: go to control panel > mouse properties and enable mouse trails! Slide the trail lenght all the way to short.

    Now you can see your cursor again!

    mmm, now my cursor (wacom+mouse) is a prisoner of the virtual machine : help!

    Actually, the mouse behaves normally after restarting the VM
  9. marcolago

    marcolago Bit poster


    I woult to add another "compatibility bug" of the combo Parallels - Wacom Tablet.

    I run Parallels 5 with a Windows 7 VM and a Wacom Intuos 3 tablet.
    I also have the pointer problem but for now I fix this with the mouse trail hack.
    The most annoying thing is that multiple selection with Shift Key now doesn'y works.

    How to reproduce:
    - open a folder that contains 3 files or more;
    - click with the pen on the first file;
    - hit and hold down the shift key;
    - click on the third file, or fourth, fifth, etc...

    Only the last file clicked will be selected, just like the shift key was not pressed.
    Any idea?

    thank you
  10. LazloH

    LazloH Bit poster

    I have to second the bug found by marcolago

    I am running Parallels 6 with a Windows 7 VM and the problem that marcolago mentioned persists: shift-clicking simply does not work when you are in Windows 7 VM with a Wacom Intuous 3.

    I do want to add, that I fixed the problem with the cursor by using the solution found in this thread, and so I want to thank stephtran for the suggestion. I am still looking for a solution for the shift clicking. It's obviously a bug with the Wacom driver, because when I use my Apple Magic Trackpad shift+clicking works great! Arghhh. . .

    I posted a message to Wacom's community forums about the issue, but wanted to drop a message on this thread as well for anybody with the same issue. Any information you have about this would be greatly appreciated!

  11. KonstantinO

    KonstantinO Parallels Developers

    Hello, try to set checkbox "Optimize Modifiers for Games" in advanced VM configuration. This should help with issues like shift + tablet click.
  12. LazloH

    LazloH Bit poster

    I will give that a try. Thank you for responding.
  13. Rickygolucky

    Rickygolucky Banned

    I'll try this one, hope this is working as well.[​IMG]
  14. BLEWS2PD

    BLEWS2PD Bit poster

    Wacom pen pressure

    Just curious re this pen pressure issue ... is there some technical barrier that prevents this problem from being solved? I would think that between MS, Parallels, & Wacom someone would be able to figure this out. I know about the mouse trail hack and boot camp, etc., but for me, these do not address the real problem ... why can't someone develop a driver that works with PD? I use (for a few projects) Corel Draw in boot camp, but am seriously limited in PD. Also, I haven't upgraded to Window 7 because of this issue. BTW, Parallels Desktop is GREAT ... have been using it from day 1 and will continue to use it.

    mac os 10.6.8
    pd build 6.0.12094
    windows xp sp3
  15. BaoH

    BaoH Bit poster


    I have a wacom Digitizer II (very old model and driver only support XP-32bit). So what I have been able to do is successful installing the driver in parallel running xp. When I hook the tablet to the computer the pen will only work for 3 seconds and stop working afterward, xp still recognize the tablet but it just doesn't work. I tried restarting parallel several times and the same thing happen. So, I can see that the tablet can work but something stop it after 3 sec but I cant figure it out.

    Any help would be appreciated.
  16. adanguspf

    adanguspf Member

    Wacom supported in PD7, it seems

    I have a Wacom Intuos 4. With PD6, I had to turn on the cursor trails trick in order to get it to function for Corel Painter in my Win7 host machine. Of course, you also had to commit the Wacom to the host in order to get it to work. I lately installed PD7 and the tablet just works. I generally have a Bluetooth magic mouse and the Wacom both connected; and both just work now in the Win7 host.

  17. Daisuke2005

    Daisuke2005 Member

    I posted a tablet support post in the installation thread I think, paralells woudl be awesome for artists if you could use a trablekt that is mounted in Mac OS with pressure sensitivity in windows also. I am sure many many people would buy paralells just for this feature! I personally think mounting the tablet just in the Guest os is not a good option because drawing that way give sa very veyr strange feeling and is also hard cause of the curser problems and for me it also was extremly laggy. I hope in future updates of version 7 this feature might be added!
  18. adanguspf

    adanguspf Member

    Wacom supported in PD7, it seems

    I've attached a screen shot to show the pressure sensitivity function working in Win7 for my Intuos 4. One does have to assign the USB device to PD7 in order to get pressure sensitivity and other Wacom functions to work within the Windows guest VM. However, it's an easy matter to turn this assignment on and off and use the Wacom in either Windows or the Mac, though I admit that's a bit of an annoyance.

    In order to be able to do this, you have to have another mouse that is recognized in both the guest and the host OS. I use a bluetooth magic mouse. When the Intuos is committed to the guest OS, its cursor will not move outside the guest OS window. When it is committed to the Mac OS, it can be used just like a mouse within Windows and a Wacom in the Mac, but the Wacom functionality will not work within the Windows guest OS.

    This is pretty straightforward though, IMHO.

    Attached Files:

  19. VivianH

    VivianH Bit poster

    To stephtran I just wanted to say this worked for me! I spent a whole day installing and reinstalling drivers, I even called the wacom company for help and was told I had to run boot camp, naturally I was very discouraged as I had already bought parallel (which is not cheap) under the impression that it would work. But then I found your post and it worked great (very ecstatic right now)! So thank you very much!
  20. Jeremy Gugenheim

    Jeremy Gugenheim Junior Member

    PD 8, Windows 7 64b, Intuos 4 but no control panel!


    Using my Intuous on a late 2011 17" MacBookPro with Mountain Lion and Windows 7 and the stylus only works as a simple mouse in Windows. Wacom drivers are installed for both Windows and OS X.

    If I try to start the Wacom control panel under Windows it just puts up a MessageBox saying "A supported tabled was not found on the system". If I go to "Parallels menu->Devices->USB->PTK 440 #4" (just a guess - I hadn't seen that device before plugging the Intuos in) and get a tick next to it, the whole thing behaves perfectly in Windows and I get the Wacom control panel and everything. But, the stylus is lost to OS X - probably not a problem since I will only want to use it on one platform at a time and don't run Windows much but could it not be made so that the Wacom behaves like all the other shared hardware?



Share This Page