Just purchased 3.0 but it installs 2.5!!!

Discussion in 'Installation and Configuration' started by robotix, Jul 11, 2007.

  1. robotix

    robotix

    Messages:
    4
    Hi, I just purchased 3.0 upgrade from parallels. Did the credit card thing and got an email with links to download 3.0 and an upgrade serial.
    Did the download, and the filename says:

    Parallels-Desktop-4128-Mac-en.dmg

    Did an install, it prompted me with an upgrade button, went through the upgrade and then ran the application. It looked exactly the same as 2.5. So I thought, ok maybe it installed the upgrade into a different directory. Renamed the current directory, reinstalled from the "3.0" installer and ran it, and again it looked like 2.5. So I did a get info on the application and sure enough, it says version 2.5. Also it never asked for activation, and was still showing my original information.
    So I had just downloaded the 2.5 updater before paying for 3.0, and had that image, so I mounted the 2.5 updater:
    Parallels-Desktop-3214-Mac-en-ND.dmg
    And then ran the uninstaller, after backing up my VM folder from library->parallels, and it said it uninstalled, it did remove the parallels folder, and so I started again running the 3.0 installer.
    Did a get info on the "new" parallels application in the "new" parallels folder, and it says 2.5!!! :eek:

    Tried customer support telephone... "You are in line for customer support, there are 6 callers in front of you..." or something simliar.... ok, not too bad... 5 min later, "You are in line for customer support, there are 6 callers in front of you..." ... 10 min later ...*CLICK* *BUSY SIGNAL*....
    Call back... try sales, "you are in line.... 2 callers" ... 10 min later ... "you are in line .... 2 callers..." ugh, have to attend to other things, hang up... call again, try customer support "you are in line, 8 callers in front" :mad: 5 min goes by "you are in line... 8 callers, estimated wait time 60 minutes" :eek:

    Anyone have any idea why a 3.0 installer would install 2.5? TIA.
    Regards,
    robotix
     
  2. Purplish

    Purplish Kilo Poster

    Messages:
    521
    Did you use the update feature within the program? That will give you the latest 2.5 update.

    Try using the download link at the top of this page. Click Downloads/Parallels Desktop For Mac. You should find 3.0 there. (It will be called 4128)
     
  3. robotix

    robotix

    Messages:
    4
    Hi Purplish. Thanks for the reply.

    Sorry if I wasn't clear in my original post, late in the day you know :p

    1) I actually went to parallel's website and purchased the upgrade.
    2) Received several emails from parallels accepting payment and sending me my 3.0 license and a "download URL that expires", to click on, where I can download the 3.0 full application. The URL downloaded an image to my desktop with the name:
    Parallels-Desktop-4128-Mac-en.dmg
    3) The installer from the above image installed 2.5....

    what's more, the pdf readmes inside the Parallels-Desktop-4128-Mac-en.dmg image are all 3.0 related.

    Regards,
    robotix
     
  4. w7ox

    w7ox

    Messages:
    152
    Make sure you are running the .app file from the directory, not using the shortcut on the Dock. You need to delete that shortcut and create a new one.

    Phil
     
  5. robotix

    robotix

    Messages:
    4
    Hi, Phil. Yes that's what I am doing. Running the app straight from the directory. The actual app itself, when doing a get info, reports 2.5 version.

    Regards,
    robotix

    p.s. I am currently on hold with customer support, again... this time it says im in line at position 2, and I have to wait approximately 2min.... oops wait, im #2 and now I have to wait "4 min" sigh... wish me luck! ;)

    UPDATE: Still on hold, going on 50min as first person in queue.
     
    Last edited: Jul 12, 2007
  6. w7ox

    w7ox

    Messages:
    152
    That is really weird, installing 3.0 but getting 2.5.

    Good luck with "Customer Support".

    Phil
     
  7. robotix

    robotix

    Messages:
    4
    Solution Found.

    Hi all. I wanted to start out by thanking those that took the time to read and reply.
    After spending quite a bit of time on hold, I did finally get through, and while I am grateful that they helped find a solution, I must say the experience as a whole was not a pleasant one. When you call technical support for a product you pay money for, you expect a professional experience, and mine was definitely not. That being said, they did help solve the problem, so I will not go further into the negatives of the experience, and just share what helped solve the problem so that others that experience this (and yes, btw, my experience is not unique, apparently many others have had difficulties with their installers, not just for 3.0), will hopefully not go through what I went through.

    Now, even the Tier 2 support guy has told me that he's at a loss for why this happens, and complained that talking to the coders was useless because they are all russian... beware the "potato bugs" in your parallels people ;) .... but here's what we "tried" and it seemed to get things working:

    I went through all the same steps that I had done before, but this time I moved the older 2.5 update image to my documents folder, and did the uninstall from there after mounting the image... (why this would matter is beyond me, considering that when an image is mounted it's root is in the volumes directory...) we did an uninstall, and I restarted the computer.

    Reran the 3.0 installer and it worked first time. So, somewhere, some installer script apparently is pointing to "something" even after you use the uninstaller, possibly a pref file, and triggers the "3.0" installer to install the same version you previously had installed :eek:

    I had restarted before after doing the "upgrade", not an uninstall then clean install, and it was still installing 2.5 using the "upgrade" option, so to save headaches, just backup your virtual machine in your user->library->parallels folder so you have a backup, then uninstall 2.5, then restart (this seems to clear out I guess temp uninstaller files etc), then do a clean 3.0 install.

    After that, it behaved as 3.0 should and appears to be working quite well.
    So anyway, all is well and while the software is engineered quite well, I must say unfortunately the support is not. Any way that's my experience, and FWIW, I have VMware on my pc, and the support is like night and day.

    Just IMHO.
    Regards,
    robotix
     

Share This Page