Kernel Panic with 3.0: invalid frame pointer into com.parallels.kext.vmmain

Discussion in 'Windows Virtual Machine' started by fdm, Jun 17, 2007.

  1. fdm

    fdm Bit poster


    Evaluating the 3.0 release #4128, I have just experienced two kernel panics (and thus crash of MacOSX ...) when just starting my XP VM (basically when the BIOS shows its infos).

    I have a MacBook Pro 2.33 with 3G of RAM and 10.4.9. FYI I never experienced such crash during my eval of the previous release (#3188) with the same XP VM.

    Here is the Apple tech data:

    panic(cpu 1 caller 0x001A429B): Unresolved kernel trap (CPU 1, Type 27=Unknown), registers:
    CR0: 0x8001003b, CR2: 0x4e45c000, CR3: 0x00e1b000, CR4: 0x000006e0
    EAX: 0x0000000a, EBX: 0x6d626572, ECX: 0x00000000, EDX: 0x01076e00
    CR2: 0x4e45c000, EBP: 0x36823b18, ESI: 0x6d616769, EDI: 0x63216e75
    EFL: 0x00000246, EIP: 0x4d3188f1, CS: 0x00000008, DS: 0x4e450010

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x36823908 : 0x128d08 (0x3cb134 0x3682392c 0x131de5 0x0)
    0x36823948 : 0x1a429b (0x3d0e4c 0x1 0x1b 0x3ca5fc)
    0x36823a58 : 0x19ada4 (0x36823a70 0x36820048 0x36820010 0x190010)
    0x36823b18 : 0x94eb86 (0x5a49998 0x0 0x5a49984 0x16d)
    0x36823bd8 : 0x94f2de (0x5a49984 0x36823eb8 0x18 0x399435)
    0x36823d38 : 0x94b959 (0x5a49984 0xc0185401 0x36823eb8 0x6)
    0x36823d68 : 0x1f05d7 (0xd000000 0xc0185401 0x36823eb8 0x81)
    0x36823da8 : 0x1e7411 (0x36823dd0 0x297 0x36823e08 0x522d3e8)
    0x36823e08 : 0x1df212 (0x52e5630 0xc0185401 0x36823eb8 0x81)
    0x36823e58 : 0x331c4c (0x5684e20 0xc0185401 0x36823eb8 0x522d3e8)
    0x36823e88 : 0x34ffa8 (0x5684e20 0xc0185401 0x36823eb8 0x522d3e8)
    0x36823f58 : 0x379e23 (0x522d3e8 0x52482e0 0x5248324 0x0)
    0x36823fc8 : 0x19b17e (0x4c03620 0x0 0x19e0b5 0x4c03620) No mapping exists for frame pointer
    Backtrace terminated-invalid frame pointer 0xbfffdf88
    Kernel loadable modules in backtrace (with dependencies):

    Kernel version:
    Darwin Kernel Version 8.9.1: Thu Feb 22 20:55:00 PST 2007; root:xnu-792.18.15~1/RELEASE_I386

    Model: MacBookPro2,2, BootROM MBP22.00A5.B01, 2 processors, Intel Core 2 Duo, 2.33 GHz, 3 GB
    Graphics: ATI Radeon X1600, ATY,RadeonX1600, PCIe, 256 MB
    Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 667 MHz
    Memory Module: BANK 1/DIMM1, 1 GB, DDR2 SDRAM, 667 MHz
    AirPort: AirPort Extreme, 1.0.47
    Bluetooth: Version 1.7.14f14, 2 service, 1 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: Hitachi HTS541616J9SA00, 149.05 GB
    Parallel ATA Device: MATSHITADVD-R UJ-857D
    USB Device: Built-in iSight, Micron, Up to 480 Mb/sec, 500 mA
    USB Device: Apple Internal Keyboard / Trackpad, Apple Computer, Up to 12 Mb/sec, 500 mA
    USB Device: Bluetooth HCI, Up to 12 Mb/sec, 500 mA
    USB Device: IR Receiver, Apple Computer, Inc., Up to 12 Mb/sec, 500 mA

    Hope we will see a fix very soon as I can "survive" a Parallels crash but not a crash of my OS. I can provide more infos about the XP VM if needed.

    Best regards,

  2. me7486

    me7486 Bit poster

    Kernel Panic with 3.0 Exact the same error

    I have same machine and spec MBP 2.33 3GB Ram, and I had about 4 Kernel Panic in the past 3 days.

    I have ran Apple Hardware Check and cleanly reinstalled Parallels Build 4128. It still happens.

    Once when I try to start the VM
    Once when I try to Login
    Once when I return from sleep
    Once when I return from screen saver.

    Is there any quick fix for this problem? Or is this a known issue?

    I use my MBP for visual studio development, and I dont have a single game installed on the Windows XP SP2 VM, and I have not enabled DirectX in the VM config.
  3. me7486

    me7486 Bit poster

    I think this might be related to Hide Task Bar option in Coherence Mode. I have the option turned off when Kernel panic start to happen, I have since turned it back on (ie show task bar), kernel panic has not happened yet.
  4. Mike@Parallels

    Mike@Parallels Hunter

    Thank you for your post. We will investigate this problem.

    2me7486 can you provide Apple crash log please
  5. Mike@Parallels

    Mike@Parallels Hunter

    2 fdm

    Check your PM please.

    Best regards,
  6. me7486

    me7486 Bit poster

    Kernel Panic log

    please find in the attachment the kernel panic log from my previous 3 kernel panic with parallels version 3 build 4128.

    I am running MacBook Pro 2.33 17" 3GB RAM 160GB harddrive Guest OS is windows xp sp2 with all the latest patches applied volume license. the Guest is running in virtual hdd image 36GB, it is a image upgraded from version 2.5. the mac os x is version 10.4.9.

    i have disabled directX option and running coherence mode, no game installed, very clean windows installation, just got visual studio running on it. no anti virus, no firewall.

    hope this help you with your debugging.

    Attached Files:

  7. chrup

    chrup Bit poster

    I'm getting the same kernel panics and sent 2 messages to support without any reply. Have you gotten a reply to this problem and how to fix it?
  8. me7486

    me7486 Bit poster

    No word, nothing. But after I enabled windows task bar (i.e. not using the Coherence option of hiding the windows task bar), i have not had this problem.
  9. btg

    btg Bit poster

    I have gotten this kpanic several times the last couple of days. I will post a crash log next time it happens but here are some conditions are shared among each of the 6 or so kpanics:

    (build 4128)
    Windows Vista
    MBP 2.33, 2GB RAM
    fresh install (2 weeks) of 10.4.9, bare bones installs

    -VM already running all day with the laptop plugged in to AC
    -Laptop closed and put to sleep, woken running off battery
    -Switching to a new wireless network upon awake
    -guaranteed kernel panic after 5 mins
  10. nall

    nall Bit poster

    I'm getting these as well. Is a fix/workaround available yet?
  11. whobutdrew

    whobutdrew Bit poster

    Same thing

    I'm also getting this KP when I start my VM. I do not have my taskbar hidden, so I don't think its that.

    I'm running a 2.16 MBP, 2 GB RAM, 10.4.10, XP w/SP2
  12. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

  13. whobutdrew

    whobutdrew Bit poster

    Is it supposed to ask me for my serial number again, even though I've already serialized Parallels 3?
  14. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    No - it should work with old 3.0 key.
  15. whobutdrew

    whobutdrew Bit poster

    I tried putting my old v3 key in and it wouldn't take it... I'll look more into that. Thanks for your help.
  16. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    It shouldn't ask for the key at all if you just upgrade from 4128. Are you using copy/paste for entering key?

Share This Page