Key caps reverses polarity in Windows

Discussion in 'Windows Guest OS Discussion' started by dangcookie, Sep 14, 2007.

  1. dangcookie

    dangcookie

    Messages:
    21
    Somewhere in the middle of my work day, the key caps inevitably gets triggered into reverse polarity. I assume this is a Parallels issue. Please advise, because it's really annoying.

    I'm using a Macbook.

    Thanks,
    David
     
  2. gegervision

    gegervision

    Messages:
    185
    I get this as well occasionally. Just shutdown Parallels/Guest OS and restart OSX. Then you'll be fine for a while.
     
  3. Eru Ithildur

    Eru Ithildur

    Messages:
    1,960
    If the caps locks are on for the OS X side when you start the VM it will have the reverse polarity. There was a setting in the config file that I is part of my default set-up now, I'll try and dig it up. Let me know if your issue follows the patter I outlined above, though.
     
  4. asrinivasan

    asrinivasan

    Messages:
    2
    I was able to resolve the issue by disabling the caps lock key in Windows.

    -andre.
     
  5. pendolino

    pendolino

    Messages:
    75
    how do you 'disable the caps lock key in windows' ?
     
  6. asrinivasan

    asrinivasan

    Messages:
    2
    I found a tool called KeyTweak and installed it in Windows. I used it to remap the caps lock key to be the left shift key which disabled the caps lock key.

    -andre.
     
  7. pendolino

    pendolino

    Messages:
    75
    interesting and thank you for the very quick response!
     
  8. rbh

    rbh

    Messages:
    53
    Actually I've found I only need to log out/log in to my Vista VM when this "feature" bites me.
     
  9. aaltieri

    aaltieri

    Messages:
    22
    I have the same problems listed. The system randomly reverses my caps lock key in the guest OS (Not just windows, It did this in Ubuntu also). Logging out, or shutting down the VM may be a work around, but is there a SOLUTION to this problem. If several of us are having this issue it is clearly either an OS X issue or a Parallels issue. And I'm pretty sure we can rule out OS X.

    I do not always have the luxury, in the middle of a presentation or meeting, to reboot my VM. And honestly, I think it's insultingly lazy of the software manufacturer to have NOT solved this issue since posts for this issue go back almost two years.

    --anthony
     
  10. Eru Ithildur

    Eru Ithildur

    Messages:
    1,960
    Optimize things for Guest OS Performance in the config window, I think that this was the magic setting.
     
  11. josch

    josch

    Messages:
    3
    Hi Eru, what do you mean with "Optimize things "?
    I am having the same trouble.
    I am running XP on Mac OSX 10.5.
    All of a sudden that problem appeared after a year of working with parallels.

    Thank you.
    jo
     
  12. Drdul

    Drdul

    Messages:
    2
    The suggestion to optimize for Guest OS performance doesn't solve the problem (at least not with OS X 10.5.2). That's what i had it set at, and the caps lock annoyance kept occurring. I would have expected Parallels to have resolved this issue by now, but perhaps it's a new Leopard-related "feature."

    in the meantime, I found a freeware app called NumCapsScroll Indicator that I'm going to install, to at least provide me with a visual indication that the caps lock setting is on. If anyone can come up with a solution to this problem, please advise!
     
  13. aaltieri

    aaltieri

    Messages:
    22
    It hit me again this afternoon. I exited out of Parallel Tools and restarted it. That seemed to fix it.

    For my money, that demonstrates that this is an issue with tools, not the VM or Leopard. As soon as tools was quit, the VM resynched with my keyboard. But having to restart software is not a solution.

    --anthony
     
  14. Hugh Watkins

    Hugh Watkins

    Messages:
    946
    what keyboards are you guys using ?

    Hugh W
     
  15. rbh

    rbh

    Messages:
    53
    It's not a Leopard issue as I'm running my VM daily on 10.4.11.

    Re: keyboards - I'm using the keyboard on my 17" MBP.

    The tip on just quitting/restarting Parallels Tools in the VM is a neat one. I'll try that next time I get "bitten". :)
     
  16. aaltieri

    aaltieri

    Messages:
    22
    I'm using a Microsoft Ergo 4000. USB, no adapters.

    RBH: Please post to let us know if restarting Tools works for you too. Again, it's not a solution, but it does tend to narrow down the problem.

    Peace

    --anthony
     
  17. rbh

    rbh

    Messages:
    53
    Hi Anthony,

    Happy to let you know - but you will be in for an indeterminate wait as it does not happen to me very often (maybe 4 times in 6 months)...

    cheers
    R
     
  18. jgcamil

    jgcamil

    Messages:
    9
    Same here...

    Same issue here, caps get reversed. Same routine as everybody: shut down Windows XP, exit parallels, start windows again...

    It gets pretty frustrating! It happens to me at least twice a week... Can we have a fix for this please?

    My system:
    MBPro 2.33 C2D
    Leopard 10.5.2
    Windows XP SP2
     
  19. Rothgarr

    Rothgarr

    Messages:
    21
    The caps lock gets reversed for me, too. What's the official fix? I can't keep restarting parallels...

    Using the wired Mac keyboard.

    Thanks.
     
  20. Rothgarr

    Rothgarr

    Messages:
    21
    By the way... caps lock was ON when I reinstalled Windows XP (yet again), this morning.

    Not sure if that has anything to do with it.
     

Share This Page