Key caps reverses polarity in Windows

Discussion in 'Windows Guest OS Discussion' started by dangcookie, Sep 14, 2007.

  1. Rothgarr

    Rothgarr

    Messages:
    21
    I think I figured it out...

    I reinstalled Parallels Tools yesterday and made sure the Caps Lock key was OFF when reinstalling. So far it hasn't messed up on me...
     
  2. Eoin@eskodoc.com

    Eoin@eskodoc.com

    Messages:
    1
    Same problem using Win/Xp with Parallels 2.5 Build 3214

    I've noticed this several times, but sometimes I just don't want to restart the guest OS. (which does seem to be all that's required - ie you don't have to restart Mac OS/X).

    I'd hoped to find a way of 'tricking' the GUEST OS into missing the key state change. Some of the things I tried included - switching off/on my bluetooth keyboard (with caps lock on, then off) Mac OS.X recovered to the keyboard state from before the connection (turning on /off the caps lock light to the way it was prior to powering off). I tried doing the same while the VM was 'paused' and even tried logging off/on but (and this is the key indication) when you are looking at a password prompt. if Caps lock is on, Windows warns you if you hover over the password field.

    I suspect if we could identify the situation that caused the problem (what we are all doing in common) we might be able to find a way to repeat it at will and/or toggle the state at will.

    The only thing I can remember about the start of today's misbehavior was that it happened after the screen saver kicked in (which requires me to enter my password). When I tried to enter the password, it was invalid (because I was typing it in the wrong case) - maybe if screen saver is invoked while caps lock is on, o the mac side...

    I'm using Windows XP, on Mac OS/X 10.5.2 on a MacBookPro with the EFI keyboard firmware update.
     
  3. clogs

    clogs

    Messages:
    1
    reboot

    After disabling 'enable' in Parallels Tools then re-enabling and checking apply, I restarted XP from Windows start menu. Works fine now.
     
  4. John@Parallels

    John@Parallels

    Messages:
    6,440
    We are aware about this problem, and your experience is valuable, we are trying to find out the common reason, for now
     
  5. dsa157

    dsa157

    Messages:
    6
    re: Caps Lock reverses

    any update on this issue? It is a real pain in the butt to have to restart the VM whenever this happens...

    Dave
     
  6. arcanumy

    arcanumy

    Messages:
    1
    The way I've observed this happening is when I accidentally put on caps lock and start typing in Windows in a Microsoft application (e.g. Word). It will recognize that I have caps lock on by the third or fourth word and switch it off automatically for me. When it does, the Mac caps lock and Windows caps lock are reversed.
     
  7. midiwall

    midiwall

    Messages:
    8
    Add another person that's not liking to reboot the VM when this happens.

    Something interesting is that I'm using an external keyboard with my MacBook, and when this happens, I can almost-kinda' get things in sync if I hit the capslock on the Mac keyboard. But then SHIFT on the external doesn't work...

    sigh...

    time to reboot the VM again!

    :)
     
  8. midiwall

    midiwall

    Messages:
    8
    Well, as quickly as I complained, I think I figured out what's causing it.... at least one thing.

    It looks like the reversing will happen if the VM boots with CAPS LOCK on. I just rebooted a few times with/without caps lock set and the problem tracked with having it set/unset at boot.

    One thing that may be worthwhile to note is that I'm running an external keyboard on a MacBook Pro, and my testing was done with that. I haven't seen if this behavior tracks with the built-in keyboard.

    Bottom line looks like the VM is coming up assuming that caps lock is off, so if it's actually ON at the keyboard, it will be reversed in the VM.


    Hope that helps...
     
  9. michaelstanford

    michaelstanford

    Messages:
    6
    Here's how to fix it

    It is just Windows being "helpful."

    When CapsLock is active (regardless of the state of the little LED on the CapsLock key), start a new word using the shift key on the first letter only. It looks like this: hELLO

    But as soon as you press the space bar to go on to the next word, Windows miraculously fixes it: Hello world

    Now the Caps Lock state has flipped without flipping the LED.
     
  10. blinky

    blinky

    Messages:
    11
    Kbd HAL not trapping caps lock LED call

    You nailed it.

    This can be used to flip the caps lock back too. My testing showed me it occurs using MS Office 2003 and 2007.

    Only seems to happen under Parallels. As reported above & elsewhere, the problem DOES NOT occur when booted in Boot Camp; Apple's Boot Camp drivers are handling it correctly.

    PARALLELS DEVELOPERS: Your HAL is simply not trapping the call by Microsoft to flip the state of the caps lock light on the keyboard!
    (I submitted a formal tech support request with this info.)
     
    Last edited: Oct 25, 2008
  11. John@Parallels

    John@Parallels

    Messages:
    6,440
    As far as I remember you wrote in support in ticket , that here are the steps to reproduce,
    Could you please paste them
     
  12. midiwall

    midiwall

    Messages:
    8
    I hadn't filled out a ticket, but I can make it happen simply by starting a Parallels session with the caps lock on.
     
  13. blinky

    blinky

    Messages:
    11
    Hi John,

    The steps are in the post #29 directly above yours.

    - Start a new document in Windows MS Office Word (either version Office 2003 or 2007, both exhibit the symptom. I didn't bother testing the older Office XP.)
    - Press the Caps Lock key to turn it on.
    - Begin typing the word "hELLO" by holding the shift key for the first character, then letting go for the rest.
    - After pressing the spacebar or typing a punctuation character the MS Word Auto-correct feature changes the word to "Hello "

    At this point your caps lock light is out of sync. Having it lit produces lower case by default, whereas having it off produces caps lock. The caps lock works normally back in MacOS apps, but not in Windows.

    Fortunately, a workaround for the moment is that the same procedure can be followed to reverse the caps lock light back to normal.

    I think you'll be able to reproduce this on your systems.

    One of my clients complained about this to me and I replicated it on my laptop. He's got an iMac (early 2008) with a similar software setup to mine.

    Here's my setup in which I reproduced it.
    MacBook Pro, 2 GHz, 2 GB RAM
    MacOS 10.5.5
    Parallels 3 build 5608
    Windows XP SP3
    MS Office 2003
    MS Office 2007

    - Peter

    Mark -- I tried having the caps lock key on when I start Parallels. I started it up, then opened WordPad and typed. The letters came out in upper case as they should. I must have left out some detail that I didn't replicate. What am I not getting right with that?
    GOT IT, MARK -- The trouble you saw is only reproduced when using an external keyboard. I plugged one in & tried your scenario.
    Try the MS Office steps to fix it. That's much easier than restarting Windows, of course.
    - Open a new document in Windows MS Word
    - With the caps lock key lit, type the 'h'
    - turn the caps lock to off, and type the rest of the letters 'ello' letting the word show as "hELLO"
    - press the spacebar or a period or comma or some such word termination
    At this point MS Word's autocorrect feature (presuming you didn't turn that feature off) will change the word to "Hello " and your caps lock blinky will be sync'd correctly with the upper/lower case status correctly.
     
    Last edited: Oct 27, 2008
  14. John@Parallels

    John@Parallels

    Messages:
    6,440
    I will try to reproduce on weekend
     
  15. blinky

    blinky

    Messages:
    11
    Thanks, John. I expect it to be straightforward.
     
  16. nickelshine

    nickelshine

    Messages:
    2
    Rebooting the virtual machine with the caps lock off did not work for me.

    Unplugged the USB keyboard - plugged back in - annoying problem gone.
     
  17. nickelshine

    nickelshine

    Messages:
    2
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  18. blinky

    blinky

    Messages:
    11
    The trouble's still there in Parallels 4, so don't bother upgrading just to fix the problem. 4 does have other very compelling features, but not a caps-lock fix. (Tested on 4.0.3540) I'm wondering if it's a deeper Windows problem. Oh well, opening an MS Word doc to fix isn't that bad now that I can tell people what to do.
     
  19. sanjin

    sanjin

    Messages:
    13
    I noticed the same problem with caps lock and here here is what I find out.

    If caps lock is in inverse and I start Mac screen saver (move mouse pointer in hot corner) then after a second or two when screen saver is activated I press caps lock button and it goes out of screen saver and caps lock is behaving normal. Voila :)

    Maybe this workaround will help to fix this issue until they fix it for good.
     
  20. swivet

    swivet

    Messages:
    20
    Longstanding problem!

    I've been living with the Caps Lock inversion on a 2007 MacBook Pro for about 20 months, through 2 versions of Mac OS and 3 versions (many builds) of P Desktop.

    Almost used to it by now... but really, really hate this and do not see why it is so entrenched.
     

Share This Page