Key caps reverses polarity in Windows

Discussion in 'Windows Guest OS Discussion' started by dangcookie, Sep 14, 2007.

  1. John@Parallels

    John@Parallels

    Messages:
    6,450
    The situation is when Caps Lock on, when you start your VM, try to start VM, when Caps Lock is off
     
  2. edeslaur

    edeslaur

    Messages:
    30
    John,

    That is not the sole cause.

    My VM has been started, was working fine. "Suddenly" the caps lock problem manifested itself. And, of course, I work for an extended period in either one or the other, so it's not immediately evident what I did differently.

    Short of rebooting the guest OS (not an acceptable workaround)... how do I resolve this?

    Per the note above (Sorry, can't nav to it while typing this message to provide credit to the poster), start an Office application, preferably Word (or Outlook with Word as the editor may work as well), and type into it in whatever mode gives all caps. I typed "TEST" and hit space, now they're back in sync.

    Since, on my regular PC, this changes the state of the CAPS light, seems PD3/4 (did this on PD3 too), is not capturing and managing the software-switching of the CAPS lock key state back to the host OS.

    OSx 10.5.6, PD4, XP SP2 is guest OS.
     
    Last edited: Jan 29, 2009
  3. John@Parallels

    John@Parallels

    Messages:
    6,450
    Could you please submit problem report from Help - report a problem, and post here report ID?
     
  4. hovis

    hovis

    Messages:
    11
    easy fix

    My experience:
    Windows and OS X doesn't see what the other does with caps lock.
    So, if you get the inverted caps lock in Windows, just switch to an OS X app, like Finder, hit caps lock, switch back: Voila.
     
  5. totvos

    totvos Bit Poster

    Messages:
    31
    I have been having this problem on and off, and can confirm that the quick fix from hovis fixed the problem for me.
     
  6. hschneider

    hschneider Kilo Poster

    Messages:
    507
    This problem still exitst on Parallels 4, Built 3844 !


    -- Harald
     
  7. Steve Bristo

    Steve Bristo

    Messages:
    1
    How to fix WITHOUT rebooting parallels

    So this issue has bugged and haunted me as well for the LONGEST time. I never knew how I triggered it until tonight. And I was on this forum trying to figure it out, and then the forum didn't really help and I found this trick on my own. Although, I'm sure this has probably been figured out and posted on the forum elsewhere.

    I run parallels in FULL SCREEN MODE. ALT+CTRL will bring me into MAC mode and shows the MAC menu bar at the top and changes the mouse to the MAC cursor.. The launch bar will show up at the bottom if you scroll to the bottom (if it is on autohide).

    So, the trick is........... if you have caps lock light ON to type in regular more.. or caps lock light OFF and it is actually on.. Hit ALT+CTRL to go into that mac mode. then toggle the caps lock button. And then click back on your parallels desktop or window or app or whatever you are running and VOILA.. When you start typing in windows again it is FIXED.

    No more rebooting the VM.
     
  8. richdean

    richdean

    Messages:
    4
    I solved this on my MBP 15 (internal keyboard) by switching to the MacOS, hitting the caps lock key a few times, then returning to parallels. No restart or log in/out.

    I can't figure out what triggers the problem to start, but it happens every few days. Super annoying.

    Rich
     
  9. BenA

    BenA

    Messages:
    1
    another suggestion

    On my iMac I found that connecting and disconnecting the keyboard seems to force caps lock back into sync (Devices -> USB -> Apple Keyboard).

    Hope it gets fixed properly in the next release.
     
  10. slylabs13

    slylabs13

    Messages:
    7
    This happens to me even while I am working in Windows

    This has been happening to me with the latest build. It looks like when I hit the Shift key, Parallels is locking the caps internally in Windows. I have had this happen while simply typing a login password. You can imagine the havoc that has been creating for me. Version 3 did NOT do this! I suspect you should go back and look at what you changed between 3 and 4 involving the keyboard interface.
     
  11. Peter Monahan

    Peter Monahan

    Messages:
    7
    Fix for Caps Lock Reversed

    The actual fix for this is to open the offending Windows Program, usually Word.

    Launch Microsoft Word and start typing in a new document. Make sure Caps Lock on the Mac is off; this will mean that Caps Lock in the Windows XP instance is on. Start typing normally (that is, as if Caps Lock in the Windows XP instance is off); if you try to type "Hello" what you'll get instead is "hELLO" but as soon as you hit the space bar, the app will "correct" what you typed to "Hello" and toggle the Windows XP instance Caps Lock off--and as a result, Caps Lock will be back in synch between the Mac and the Windows XP instance.

    Peter
     
  12. Peter Monahan

    Peter Monahan

    Messages:
    7
    Fix for Caps Lock Reversed

    The actual fix for this is to open the offending Windows Program, usually Word.

    Launch Microsoft Word and start typing in a new document. Make sure Caps Lock on the Mac is off; this will mean that Caps Lock in the Windows XP instance is on. Start typing normally (that is, as if Caps Lock in the Windows XP instance is off); if you try to type "Hello" what you'll get instead is "hELLO" but as soon as you hit the space bar, the app will "correct" what you typed to "Hello" and toggle the Windows XP instance Caps Lock off--and as a result, Caps Lock will be back in synch between the Mac and the Windows XP instance.

    Peter
     
  13. Piggy

    Piggy

    Messages:
    9
    Me too, and it's very disruptive. I had this problem in VMware Fusion, too, but they have a "sends caplock" key that Parallels does not. Regardless of the state of this issue, it would be a big help in Parallels if the equivalent key existed. I recently migrated over from Fusion.
     
  14. fmckinnon

    fmckinnon

    Messages:
    21
    Official Solution?

    Is there no "official" solution to this from Parallels after all this time?

    This happens to me all the time - at least 2-3 times per day. I do not even have "Word" for XP installed. I'm using a Windows program called "Shipworks" ... I'm either in Shipworks or QuickBooks Pro ... and I'm copying tracking numbers from my Mac's Mail.App program into Shipworks - and everything is going fine ... then all of a sudden, in Shipworks, when I go to type "UPS Ground" it shows up as "ups gROUND".

    I'll try going back into Shipworks and typing it, followed by the spacebar - but as you can see above on UPS GROUND - there is a space in that phrase, and it doesn't correct the problem.
     
  15. Piggy

    Piggy

    Messages:
    9
    I've been experiencing this problem in VMware Fusion for a very long time, and having now switched to Parallels (due to performance issues) I still have the problem. I can only assume whatever the cause it's not easy to fix.

    Fusion has a "send caps-lock" keypress option where Parallels is missing this. It would be a nice, simple addition for Parallels to add this since they have ctrl-alt-del, etc., etc.

    That said, I've looked into various ways to solve this and have found a real simple solution that doesn't require installation of additional software. Plus, it's so transparent that since implementing it a couple of weeks ago I've only noticed the problem occur once and even then nearly missed that anything had happened.

    The solution is to have Windows' SHIFT key behave like a typewritter. For you youngins unfamiliar with this glorious mechanical device, pressing the SHIFT key would disengage CAPS-LOCK. Here is how you configure it:

    Control Panel > Regional and Language Options > Languages > Details > Key Settings. Set "To Turn Off Caps Lock" to "Press the SHIFT key".

    As mentioned this change was transparent to me. It will probably be to you, too. Post a comment if you find it useful.
     
  16. JayA

    JayA

    Messages:
    1
    My Fix

    MS Word 2007
    Win 7 Pro
    MacBook Pro

    Go to Word Options... Proofing...AutoCorrect Options... Uncheck the Correct Accidental use of the CAP LOCKS Key.

    NOTE: If you are already stuck in this reverses CAP LOCKS mode follow above steps to correct. Then this will stop it from happening in the future.
     
  17. ionblue

    ionblue Bit Poster

    Messages:
    27
    This has happened to me once so far in WinXP in Parallels 5 and 10.6.2. Restarting the VM was required to correct.
     
  18. ZephB

    ZephB

    Messages:
    1
    Toggling on the MacOS side works for me

    Restarting the VM did not work for the one user I've got that has this problem, but switching to a MacOS app, toggling the caps lock, then returning to WinXP does do the trick.
     
  19. sshero

    sshero

    Messages:
    4
    I am miffed that after all these YEARS there is not a software fix for this. I will try your recommendation. This happens not just in Word and other Microsoft aps, but in Intuit softwares as well. There's no limit and it's not a Mac issue.
     
  20. LawrenceH

    LawrenceH

    Messages:
    1
    I also have been frustrated with this and I know that occasionally I get it re-synced without a reboot. I almost alway use an external keyboard and a old core duo macbook. The problem is alsmost certainly due to the fact capslock is just a state flag and on intrisinic to the keyboard.

    I just 'fixed' it by moving the mouse out of windows and into the OS X context. Pressing the CAPS LOCK key on the macbook keyboard so the light is on. THen moving back into the Windows context where the external keyboards light is off and (1) checking that I still have caps when I type, then (2) pressing CAPS LOCK on the external keyboard so it's now lit up adn seeing I now get lower case. Go back to the mac context and unlock the CAPS LOCK on both keyboards. Now when I go back to Windows I get lowercase when I type and the shift and CAPS LOCK functions appear to work.

    YMMV and I may have missed something but this worked for me and in the past fiddling has worked. I think the 'trick' is basically to get the keyboards synced up in OS X then move back into Paralles and Windows.

    Now if they could only figure out how to check the state when moving in and out and forcing it to be correct.

    Lawrence
     

Share This Page