Keyboard / Mouse lockout on Win boot

Discussion in 'Installation and Configuration' started by sixsigma9999, Jul 17, 2007.

  1. sixsigma9999


    When a disk image boots up, the keyboard will work in DOS, but as soon as it hits windows (be it win2k, winXP Pro), click in the pc window, and the mouse and keybaord do not pass events to windows. Therefore I can't log in, and on my windows 2k transport / install it is stuck at accepting a driver install because I can't click 'yes'. Parallels gets keyboard events because the ctrl-alt escape from capture keys do work.

    My XP pro image got this problem after working successfully for a few days. When I ejected a (real) windows CD, the Parallels tool driver came up, said it need to install a driver, I said yes, parallels then crashed, then my mac. Now the xp pro boot hangs at my password account prompt because I can't type in my password.

    I have tried re-transporting things that worked before, plus a whole series of other things like disabling this or that, re-installs, permission fixes, various permutations of usb settings, etc, plus suggestions from tech support (some indicating they didn't really read my bug submission) - but at least they responded!.

    As of now Parallels is dead. I can't use it at all, for anything. Anyone have this similar problem and or found a work-around?????: HELP!!!!!!!!!!!!!!!!

    Macbookpro 15" LED, 2gb, osx 10.4.9
    Last edited: Jul 19, 2007
  2. sixsigma9999


    V3.0 d4560.0 No Fix

    :( I have downloaded, installed and tried the new version. Problem NOT FIXED. However, am now using Parallels Explorer to examine XP Pro drive image to see if there is a driver, temp file, what ever inside image that parallels is choking on (but should have an exception routine to handle anyway). Happy to see that PExplorer was at least able to open damaged WinXP Pro image.
  3. mace


    Sorry I can't help... But, I'm having the same problem! I'm a first time user but so far I've been unable to use it at all. I downloaded and installed the latest 3.0 version build 4560 and obtained a trial key. I did a fresh install of XP Professional. I can't do anything at all with parallels because the mouse and keyboard don't work. I'm using a MacBook Pro with OS X 10.4.10 and all the latest updates as of today.

    Any help???

  4. sixsigma9999


    It is obvious that Parallels has major problems in USB mgmt and in User events mgmt, that they need to fix ASAP (like the next 30 days), if they are going to survive.

    But the software is working for some people. Let's try to find what is special about our set-ups where we have the problem, vs others who don't. Might fix it for us or help Parallels get a clue.

    * You said macbookpro. Is this one of the new Santa Rosa based laptops - like mine which is a 15"Led?
    * I have 10.4.9, you have 10.4.10 so OS is not likely the problem.
    * I have also tried re-installs of the software, re-transports of good VPC7 images. That didn't work, plus I have the problem on more than one image, so I think the problem is not in the images, but in Parallels itself.
    * I have also tried removing all non Mac system software this didn't fix it either.
  5. JollyRoger


    Ok this is pissing me off....

    I just updated to 4560 from the previous version and now every time i boot an XP vm the VM just locks up...

    This shit is getting old real fast.. I have work that needs to be done, if parallels cant figure out how to execute a proper SDLC they should shut their damn doors.

    Here is a hint.. dont push "beta" code as production...

    Well while others at my place of buisness have cursed parallels for its crashes, random bugs, and general retardation i have been the staunch supporter...

    Up until this point, I think parallels just kissed 50+ renewals good by (not to mention new purchases).
  6. sixsigma9999


    Mac PRAM re-set = NO FIX. I saw a suggestion to remove Paralles folder/parallel tools in winxp image = NO FIX.
  7. icecore


    I had the same problem and I did not manage to avoid to format my virtual machine.
    However, it seems that the bug is caused from the instalation of the Shared Applications in Parallels Tools. So, open your Parallels explorer from your Mac OS, locate paralles folder in program files and delete it (see screen shot). Reboot your virtual machine and if you have your mouse back, try to custom install Parallels tools and untick the Shared applications installation. It worked in my mac book for both bootcamp and virual disk installations. The only bug I have now is a .dll error message upon start up, but nothing really serious.
    Hope it will help.

    ps. anothr user managed to remove the Parallel Tools installation using safe mode (by hitting f8) during restart but with a dead mouse and keyboard I don;t think it will work in your case

  8. Hugh Watkins

    Hugh Watkins

    you guys please state which model Macintoshes - OS etc you are using

    I have never seen this problem with my Mac Book Pro with which I use an old PS2 Dell keyboard and an adapter to USB and USB a Microsoft Basic Optical Mouse

    there were problems with bluetooth keyboards some months ago

    what make and type of mouse and keyboard please?

    My daughters WInXPpc has limitations with her wireless mouse and keyboard
    on Win XP boot you had to use a hard wired keyboard to get in to the black screens

    I took my mighty mouse back to the apple store after one day
    (i go pains in my hand)

    and obviously a windows keyboard solves the alt gros problem too

    Hugh W
    Last edited: Jul 22, 2007
  9. mace


    I tried the fix suggested above (deleting the Parallels folder on my WinXP image) and it did not help.

    I have a 1 week old MacBookPro, running 10.4.10 with all the latest updates as of today. The keyboard and mouse (trackpad) I'm trying to use is the one built into the MacBookPro.

    The rest of my story: I bought Parallels from Amazon and installed it, then installed WinXP professional. I booted and the mouse and keyboard worked first time. Parallels said it had an update available so I downloaded and installed it. It rebooted and then it didn't work. I did not note the exact build revisions *but* Amazon sent me version 2.5. So, I downloaded version 3 and installed and still no mouse/keyboard.

    Another weird thing... when I use the Mac menu command "Send Keys:ctrl-alt-del" the VM does not respond. Right now, my VM is just showing the screensaver and unresponsive to any keyboard/mouse input. So, when I use the "Send Keys" command it should at least stop the WinXP screensaver... but it does not! So, there is some sort of seriously screwed up issue here.

    If I have time I'll reinstall fresh... but I got Parallels to just goof around with some old games etc. Thank goodness I don't need it for real work.


    Last edited: Jul 22, 2007
  10. icecore


    Hi again,
    replying to Hugh first, you are right that you need wired mouse and keyboard. I use my Macbook's keyboard and a usb typical optical mouse.
    Mac OS 10.4. and Parallels Desktop 3.4650
    I am afraid that the only solution is to reinstall windows.
    I formated my virtual machine almost 4 times before I manage to understand the bugs and then I made an installation to my boot camp too.

    The sure thing is that you need some time in order to have a virtual machine working without problems. sometimes the combination of software that you are using can cause a crash. For example, I used to have my Kaspersky internet security on and it prevented the installation of Parallels Tools, causing freezes.
    Of course I wouldn't say that I know everything about Parallels issues, but I had problems with the mouse and the keyboard as well.
    another thing that you can do is to plug a usb keyboard and see if it works in your virtual machine. If you manage to hit any keys with that, reboot in safe mode and remove Parallels Tools. But to be honest, you will save more time if you install some fresh Windows in a new version of Parallels.
  11. mace


    I went ahead and deleted everything and reinstaled both Parallels 3.0 build 4560 and WinXP from scratch (express install) and now the mouse/keyboard work fine.

    Thanks for all the tips here.

    Hopefully it will be OK from now on.

  12. iceyone


    I was having a similar problem this morning attaching Parallels to a Boot Camp partition. It was stuck because it was trying to re-activate windows.

    I was able to fix it by manually connecting the mouse to the Windows installation (with the little USB icon on the lower right hand corner of the Parallels screen). Once I re-activated my windows and it rebooted, everything worked like a charm.

    So, quick synopsis:

    1) Attach the USB devices manually using the USB icon in the lower right corner of the parallels VM window.
    2) Do the things you need to do in Windows
    3) REBOOT WINDOWS to get your mouse & keyboard back.

  13. embe



    today I had exactly the same problem as described in post #9.

    I reported it to the support, and (very quick!!) got the following reply from parallels support:


    1. Please update your build to latest available, by clicking Check for Updates in Help Tab, but do not agree to update automatically after package is downloaded. Do this:

    Uninstall PD tools (Start>Control Panel>Add/Remove software)

    Uninstall your current build via Uninstaller file (located in downloaded

    Reboot your Mac.

    Install PD from downloaded file, boot your VM, install tools (Actions tab), reboot VM.

    If above does not help, repair windows partition :

    # Open your Virtual Machine.
    # Click on the CD/DVD-ROM device to open its settings.
    # Make sure that "Emulation" is set to "Use CD/DVD-ROM".
    # Click on the "Options" menu on the left side of the Configuration Editor. # Click on the "Booting" tab on the right side. # Set "Boot Sequence" to "CD-ROM, Hard Disk, Floppy" # Click "OK" to close Configuration Editor. # Put Windows XP installation disk to your Mac CD/DVD drive. # Start the Virtual Machine. # Windows should ask you to press any key to boot from the CD - click inside the VM window to capture input and press any key. # Windows Setup should start loading, wait for it to load completely then press Enter (Return) key. # Press F8 (or Fn+F8 on the Macbook keyboard) to accept Windows License Agreement. # Now Windows should scan your VM for the exisitng Windows installation
    - wait for it to finish and choose to repair existing installation. # Wait for the repair operation to finish. # Try starting Windows again. Re-install Parallels tools


    Regarding to this instruction, I downloaded the very new build 3214, installed it like described and ... SURPRISE ... everything works fine at the moment, I can use my mouse and keyboard !!!

    Hope this might help somebody,

  14. sixsigma9999


    50% SUCCESS! - Keyboard Icon worked - w/ Caution

    Thanks Icey. !!

    My XP Pro is now back working. (My Win 2k transport still broken). The trick was to use the keyboard icon in lower right. Note I tried menu options before with USB permutations, this did not work, but the icon did. HOWEVER, WARNING!! The exact steps are tricky as I will explain, but also help narrow where Parallels problems lie.

    1. I have an external Kensington trackball, 15" LED w/ keyboard and trackpad
    2. When I clicked on usb button in lower left, and put a check next to K Trackball, this made my trackball dedicated to windows, and I now had a cursor in win xp, but my trackball no longer worked in mac.
    3. Seeing this, I used mac trackpad to swap settings.
    4. First turned off (uncheck) trackball to get it back for mac - worked OK
    5. Then assigned mac keyboard and trackpad to windows - this worked and I could log in and finish win boot.
    6. CAUTION!! - When mac kb & trackpad assigned to win, then it was GONE for the mac. Ctrl-alt to release keys back to mac did NOT work. It was only because I now had my trackball back that I could communicate with the mac with anything that could be clicked on. NO KEYBOARD INPUT to mac, only win.
    7. So do this only if u have a dual set-up, or at least know you may have to physically reboot if something goes wrong
    8. Once I had my win xp pro image up, I did a 'custom' install of the tools and made sure not to install Application sharing.
    9. Did the install, win reboot.
    10. Now mac keyboard, trackpad, and trackball all work correctly - that is both in mac and windows as it should.
    11. Onto to other problems. Among them, a trivial one, winxp now boots and says it can't find "program files/prallels/parallels tools/PrlSAShellext.dll". 'SA' being the shared app tool I selected not to install. More obvious clean-up needed on aisle 6.

    I think there may be a fuzzy design concept underway by Parallels in regards to USB devices. I think we generally want USB devices to work in both environments depending on current 'focus'. The intent of this USB choice may be more like "Dedicate this device to Windows Only." I think if they labled it that way it would clarify things - for them and us.

    So any device checked is dedicated to windows. Any device not checked is alive and working in both. I suppose greyed out would mean that Parallels sees it, but windows does not. This might make sense for some people with special devices or multiple screen and keyboard set-ups - but not the majority. However, it would appear to me that a lack of clear design purpose means this choice is not properly implemented and some code may be working at cross purposes. In any case this area needs help BIG time.

    BTW, my win2k Transport / 1st time boot is still hung with same keyboard problem, but now I have some new ore to mine. Thanks again Icey.

Share This Page