Keyboard stuttering-delays between Parallels ver 17 and 18 on Windows 11-M1 chip

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by JeffreyW1, Oct 28, 2022.

  1. JeffreyW1

    JeffreyW1 Junior Member

    Messages:
    17
    And the keyboard delay/stuttering continues in Parallels 19 with absolutely no improvement. Very discouraged. I adjust just about every setting I could and have rebooted dozens of times to test. Staying with Ver 17 as long as I can, but I do continue to have audio problems there. Latest Ventura 13.5
     
  2. LucasS8

    LucasS8 Bit poster

    Messages:
    2
    Hi, I'm experiencing the same issues on Parallels 19.0.0 on MBP M2 Max with Linux as the guest.

    Random delays especially on the key release. Happens with both external keyboards and the internal one.

    I can confirm that attaching the USB keyboard directly to the VM does not show these issues.

    What can we do to escalate this issue?
     
  3. JeffreyW1

    JeffreyW1 Junior Member

    Messages:
    17
    LucasS8, can you tell me precisely how you got the USB keyboard directly attached to the VM? I tried that a while back, but it didn't seem to work properly that way as well. I'd like to test again using your method. thank you
     
  4. LucasS8

    LucasS8 Bit poster

    Messages:
    2
    Parallels has list of USB devices and wether to connect it to host or to guest, or ask. I changed it there. Might need a reboot of host and guest.

    Additionally I removed it from MacOS using this trick: https://apple.stackexchange.com/a/421645 Don't know if that is needed
     
  5. Ray Konopka

    Ray Konopka Member

    Messages:
    27
    I too am experiencing the same behavior with the keyboard being sluggish inside VMs. I am running Parallels Desktop 19 (but the problem existed in 18 as well), and host is a MacBook Pro M2. My VMs are running Windows 11 ARM.
     
  6. BardB

    BardB Bit poster

    Messages:
    1
    I also have a very noticeable lag in my Windows 11 ARM VM. I mostly notice it when playing games, but there's also lag when using apps like MS Word, Excel or Photoshop.

    PS! I'm running a Mac mini M2 with macOS Ventura. My keyboard is an Apple wired keyboard.
     
  7. JeffreyW1

    JeffreyW1 Junior Member

    Messages:
    17
    Best Answer
    I have only been able to solve the problem with the keyboard lag in both Parallels 18 and 19 on my M1 MacBook Pro and Mac Studio this way:
    1 - Note: get a WIRED external apple keyboard
    2 - go to Configure/Hardware/USB & Bluetooth in Parallels control panel and select USB Connection Preferences (I think before starting up the Windows VM)
    3 - connect the wired keyboard and make sure it connects in those preferences only under Windows 11
    4 - Launch the VM and select the apple keyboard in the USB connection icon in the upper right of the VM. It may already be connected properly, but by selecting here, you are certain it's connected properly. This keyboard will not work in macOS, so you'll need to keep your usual keyboard on the MacBook Pro for macOS or a alternate keyboard if you're using something like a Mac Studio.

    Apparently the Virtual Keyboard connection within Windows that is installed with Parallels is the culprit. When I use the wired apple keyboard in this manner, there is absolutely no lag or delay as it's connected directly to the VM. I could NOT get a second keyboard to connect using a wireless Apple Magic Keyboard in Windows. There seems to be something written about that I saw where those Bluetooth Magic keyboards and mice do not work in this manner. Luckily I have a bunch of those old wired keyboards still around. This is the first time I haven't had keyboard lag since Parallels 17 and can finally use Parallels 19 so I don't have audio stuttering.

    It's a workaround, but for me it allows me to get something done around here.
     
    SLIMES likes this.
  8. H.D

    H.D Bit poster

    Messages:
    2
    Having same Problem with Macbook Pro M2 / Windows 11 Pro ARM64 VM/ Parallels 19. Cursor overshoots sometimes when using auto-repeat function of a key. This is VERY nasty in a development scenario (coding, e.G.: Placing cursor to a line with auto-repeat of up/down keys or delete/back key in a line) . Please PARALLELS, help!
     
  9. zipexaqez

    zipexaqez

    Messages:
    1
    I am having exact same issue.
    Found out if you disable(off) "Key repeat rate" in Keyboard setting in macos keyboard delay is gone on windows but you lose key repeat on macOS.
    Currently I'm switching off "Key repeat rate" when I use windows and enable when using macOS.
     
  10. M__24

    M__24

    Messages:
    1
    Is anyone from Parallels reading this?

    The issue with Parallels 18 and 19 is that sometimes the keyboard in Windows 11 keeps repeating a key for about 0.5 sec after it was released. From my experimentation it happens roughly once every 5-15 keypresses. It's easy to reproduce:

    1. Launch Windows 11 Notepad.
    2. Hold any letter key and look at characters being typed.
    3. Release the key after about 1 second.
    4. The characters should instantly stop being typed. Instead (once in about 5-15 times), the typing keeps going on for a short period of time, but long enough to type several more characters after the key was released (likely around 500ms).

    This is extremely annoying when using any text editor or coding with Visual Studio, and especially annoying when using arrow keys to move the cursor. The cursor unpredictably overshoots the place I was aiming for it to stop. This is annoying enough that I have downgraded to Parallels 17, which does not have this issue.

    Parallels - please fix it, it must be something simple. You have a working code in Parallels 17. Parallels 18 introduced the change that causes this issue.

    I have two Macs, M1 Air and M2 Pro 16". The issue happens on both of them, both on Ventura and Sonoma host OSes. The issue happens in guest Windows 11 and also in Linux Ubuntu (it's not Windows specific). The issue happens in all versions of Parallels 18 and 19, including the latest updates. The issue does not happen in the latest version of Parallels 17, and presumably in any earlier version.
     
  11. SLIMES

    SLIMES Bit poster

    Messages:
    2
    Thank you so much for mentioning this, I actually play videogames that require high presition key presses and this annoyed me from the very second I installed parallels 19. I have submited countless help requests a posts and no staff from the team would answer.

    Guess it's up to wait for them to launch a new update. But, until then, we shall use version 17, I have researched this topic for 15 days and there's no workaround.
     

Share This Page