"KMODE Exception not handled" BSOD after any windows 11 update

Discussion in 'Installation and Configuration of Parallels Desktop' started by NotY, Jan 25, 2023.

  1. NotY

    NotY Bit poster


    I have a windows 11 virtual machine on my mac (ventura 13.2). I use parallels 17.1.1. Occasionally windows update are applied upon the vm starting up, and right after the update is finished the vm reboots and I get a "KMODE Exception not handled" blue screen of death, rendering the vm unusable (I just can't boot into windows anymore, I keep getting this BSOD).

    After the first time it happened I went back to an earlier snapshot during which the vm was running; I tried disabling auto updates in the windows control panel, but never managed to do it entirely, and since I use that vm very infrequently and only to play some old windows games I picked up the habit of never shutting it down, and of only occasionally restarting it by selecting the "restart" in the windows shutdown menu (not "restart and apply updates"), so that auto updates are never applied.

    Recently I updated macos from 12.1 to 13.2 (ventura). Upon starting the vm for the first time after that update, I get a message telling me that the vm has to restart because "the configuration of the Mac or of [my vm's name] has changed". Upon restarting it, a windows update is auto-applied, causing a BSOD after the update and upon every subsequent boot of the vm.

    What can I do to fix that and be able to boot it again without running into this BSOD? I've tried booting into safe mode by maintaining fn + F4 upon startup, but it seems that windows goes immediately into "updates are being applied to windows" without giving me the chance to boot into safe mode. Is there any way i can trigger a safe mode boot from the parallels control panel? Or is there any way I could recover access to the vm after a "KMODE Exception not handled" BSOD?

    Thanks a lot.
  2. KirstenG

    KirstenG Bit poster

    I'm having the same issue. Were you ever able to resolve this? And if so, how? Any advice would be much appreciated. Thank you!
  3. RoyZ

    RoyZ Bit poster

    I just updated the parallels version and fixed it

Share This Page