Linux for Apple Silicon (M1) Mac

Discussion in 'Linux Virtual Machine' started by WillowW, Nov 23, 2021.

  1. WillowW

    WillowW Bit poster

    Ok so... I've had nothing but issues trying to run any version of linux provided by Parallels Desktop.
    Fedora Workstation 35 (arm64) seems to work for longest but still... I tried everything to install Chrome today and I can't get diddly squat to work, it keeps coming up with errors while using Software and terminal just fails. The website version fails as well. I got Chromium to install but there's no way to sign into Google account for sync. Over half the stuff fails. Oh! The only way to get Fedora to be usable was to install Cinnamon desktop as the Activities only shows about half the apps installed.
    Ubuntu 20.04 same problems, nothing installs correctly. App Menu only shows half the apps installed.
    The other two I haven't even tried yet.
    I'm trying Linux so that I can learn more about Linux. I've always been curious about different Linux distros but I've never had the time to sit down and play. It's been interesting to say the least but still half the stuff is broken. What I do like is the pure customizations you can do... Then everything breaks. Yeah!!! IDK. Windows 11 for Arm also has issues like not wanting to play purchased movies in the Movies & TV app. This might be related to the Parallels Toolbox installation but again IDK.
    Another Note: Outside Linux Arm64 distros I've tried to install instantly break and will not run.

Share This Page