Linux, Parallels 5600 e Parallels Tools

Discussion in 'Linux Guest OS Discussion' started by salvomic, May 9, 2008.

  1. salvomic

    salvomic Bit Poster

    Messages:
    95
    I'd just installed the new version 5600 of Parallels Desktop and it's ok.
    But there are still trubles with Parallels Tools with my Debian 4 installation: after the Parallel Tools installation X go bad and the graphic system isn't usable at all.
    Any chance to have a working system?
    Any workaround?

    I hope the Parallel Team could solve it definitely.

    Thanks and best regards!

    Salvo
     
  2. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    The good news for me is that Vista SP1 works very well with this new build. The bad news is that I still can't install Parallel Tools in Ubuntu Hardy Heron. Anyone know of a workaround?
     
  3. shavital

    shavital

    Messages:
    69
    Parallels Tools installation problem remains after 5600

    Terminal output when trying to install Parallels Tools:
    -----------
    shavital@Ubuntu7:/media/cdrom0$ sudo sh parallels-tools.run
    Verifying archive integrity... All good.
    Uncompressing Parallels Tools for Linux.................................................................................................
    You are about to start installing Parallels Tools. Save your data and close all
    applications to prevent data loss during possible X-Server restart.
    Continue ? [Yes/No]:Yes
    Found xorg version .
    Installation for xorg.. not found.
    shavital@Ubuntu7:/media/cdrom0$
    ------
    Parallels version identification in same above directory:
    3.0.5600.0

    --------

    Therefore I must *guess* that although the Parallels Tools installer recognizes correctly the version of the newly installed Parallels build, Tools installation still fails because of the xorg issue: Parallels and Ubuntu 8.04 (Hardy Heron) run different xorg versions.
    I don't know whether there is a workaround. I still believe in Parallels Support statement that an Ubuntu compatible Parallels build will be released during May, or beginning June 2008.

    Windows XP Pro SP3 runs fine, after Parallels Tool Wizard did its job, correctly identifying build 5600. Booting back into Windows after Tools installation took quite some time, but finally completed.

    MacOSX 10.5.2
     
  4. John@Parallels

    John@Parallels

    Messages:
    6,360
    For Ubuntu 8.04 please wait updated build in June
     
  5. lelex

    lelex

    Messages:
    1
    Build 5608 does not yet support Ubuntu 8.04...

    Hi,
    In previous posts, the support of parallels-tools for Ubuntu 8.04 (related to the problem non supported Xorg 1.4) was normally promised for the build in June... I just installed the last build 5608, and again there are problems... Is there a chance to have a fix for this?

    :/media/vmtools-linux$ cat tools-version
    3.0.5608.0
    /media/vmtools-linux$ sudo sh parallels-tools.run
    Verifying archive integrity... All good.
    Uncompressing Parallels Tools for Linux.................................................................................................
    You are about to start installing Parallels Tools. Save your data and close all
    applications to prevent data loss during possible X-Server restart.
    Continue ? [Yes/No]:Yes
    Found xorg version 1.4.0
    Installation for xorg.1.4 not found.
     
  6. salvomic

    salvomic Bit Poster

    Messages:
    95
    in fact, there is still problem trying installing the new 5608 version and Parallels Tools also in Debian 4.x: "floating point error... xorg 1.7..."
    But, is it so hard solve definitely this issue? :-((
     
  7. Frank STENGEL

    Frank STENGEL

    Messages:
    12
    Build 5608? How (and where) did you get it?
     
  8. salvomic

    salvomic Bit Poster

    Messages:
    95
  9. schwartz

    schwartz

    Messages:
    54

    is the 5608 build that came out today the fix for ubuntu 8.04 parallels tools?
     
  10. salvomic

    salvomic Bit Poster

    Messages:
    95
    I think no. For Debian 4.0.x it *doesn't work at all*
     
  11. mfox

    mfox

    Messages:
    15
    It doesn't seem to be. Unofficial built 5604 seemed to be the most successful, as the Tools could be installed with it onto Ubuntu 8.04 virtual machine. The one problem that remained was with mouse function - right-click and scroll didn't work. Build 5608 didn't fix that (at least not on my machine (iMac C2D 2.16ghz running 10.5.3). After removing build 5604 and installing 5608, I tried the Tools again, and this time, it wouldn't install them at all, being stopped by xorg 1.4. I don't know what else, if anything, that 5608 fixed that 5604 didn't, but the Tools situation was better in 5604.
     
  12. John@Parallels

    John@Parallels

    Messages:
    6,360
    I am checking it now
     
  13. John@Parallels

    John@Parallels

    Messages:
    6,360
    5608 doesn't have Parallels Tools compatible with Ubuntu 8.04
    5604 was unofficial build, we are preparing new build which will be available in the end of June
     
  14. salvomic

    salvomic Bit Poster

    Messages:
    95
    thanks John, I hope that the fix would be good also for Debian 4.x
     
  15. benriley

    benriley

    Messages:
    3
    New build?

    Hi John@Parallels,

    Any sign of the new build that supports Ubuntu 8.04 yet? You stated end of June but it's now nearly end of August. Would love to now when I'm going to be able to install Parallels Tools for 8.04 ...

    Many thanks.
     
  16. John@Parallels

    John@Parallels

    Messages:
    6,360
    Build is passing QA tests
     

Share This Page