Lion + Parallels 6 unable to connect USB

Discussion in 'Installation and Configuration of Parallels Desktop' started by nferran, Jul 21, 2011.

  1. DoniK

    DoniK Hunter

    Done, Report ID: 9620762

    Incidentally, the same happens with a fresh WinXP VM installed from scratch. Also happens if I install Paragon NTFS 9 and reinstall PD6 (not that I thought that would make a difference, but I noticed MacFuse wasn't installed like it is on my Snow Leopard machine, so I figured I'd install NTFS drivers just in case).
  2. Pawtracks

    Pawtracks Bit poster

    Report ID: 9622173

    After upgrading to Lion, external USB blu-ray drive no longer mounts in Windows 7 Ultimate (64).
    I tried rolling back to an earlier snapshot, no luck.
  3. Here's my experience

    Specs: iMac late 2009 model, lion and Parallels 6, latest build, VM = Windows 7, the 300 GB drive is docked in a Thermaltake BlacX Duet external Storage controller- Serial ATA-300- 300 MBps.

    When I plug in the USB cable from the storage controller I get a apple prompt that says "The disk you inserted was not readable by this computer", option are Initialize, Ignore, Eject. Once and a while I'll get the Lion OS prompt to link the device to Lion or the Windows 7 VM.

    Technically Parallels 6 didn't give me an error but I went ahead and gen'd a problem report - 9622970

    Perhaps my problem is not being caused by Parallels 6.
  4. DoniK

    DoniK Hunter

    VictorV, your problem isn't related to Parallels; in you case OS X itself isn't reading your drive. You may have a drive or dock problem, but I don't see how it's a parallels issue -- certainly not the same as this thread. Good luck!
  5. The drive is encrypted with Windows 7 BitLocker encryption so I"m not surprised Lion can't initialize it. I thought I could bypass Lion and simply have W7 initialize the drive. Like it was before I upgraded to Lion. If others are able to mount their USB devices to Lion and just not their VMs then perhaps my problem is Lion specific...

    However, I have a separate external Seagate 2T Hard Drive (not using the Blacx Duet USB Storage Controller) with a split partition, one for TimeMachine and the other for Windows 7 and that has no problems being seen by both Lion and my W7 VM.

    Perhaps the storage controller is not compatible with Lion + P6... Probably not the case...

    Thanks for the feedback DoniK. I'll keep looking for a solution.
  6. Christoph_63

    Christoph_63 Bit poster

    Hi guys, after having updated my MacBook Pro with Lion I had the same problems with the not connecting USB devices to Parallels 6. I solved the problem with reinstalling the 12094-Parallels-Update a second time. Then I reinstalled the Parallels Tools out of the Parallels menu bar with /virtuell machine/ parallels tools install new. And I didn't uninstall any Software before the reinstalling. Now it works perfect again...

  7. DoniK

    DoniK Hunter

    Interesting that a reinstall works for some, not for others. Hopefully root cause analysis by Parallels support will help determine why.
  8. juzci

    juzci Guest

    Thank you for reports, we do appreciate it. We're now investigating the issue.
  9. PatrykG

    PatrykG Bit poster

    I have same problem with Lion Parallels 6 with win xp. Any solution?
  10. dadbizdoc

    dadbizdoc Bit poster

    Same Issue

    I have the same issue. Have just upgraded from Win XP to Windows 7 on my iMac and Parallels 6. The only reason I am running Parallels is to run Quicken in the Windows environment and because i do not now have even a network connection (or access to any other USB items) I am stuck. I have tried the fix outlined in the following thread:

    by using the following line in terminal mode to no avail:

    sudo sed -i".bak" '/PrlProbeScore/d' /Library/Parallels/Parallels\

    I fear I am not smart enough to execute the script outlined in the above post. I just don't know how to do it and I would be willing to try if anyone could walk me through it. But, of course, I would rather have a permanent fix.

    Please help!
  11. DoniK

    DoniK Hunter

  12. PatrykG

    PatrykG Bit poster

    hi, here is what helps me:
    1)run VM
    2)Connect USB
    3)Sellect connect USB to VM, after that will appear "Unable to connect the USB device to your virtual machine." but...
    4)restart windows (USB is still in!)
    5)after restart windows see USB
  13. DoniK

    DoniK Hunter


    So remember when I said I'm also seeing the same USB mounting problem with VMware Fusion & 10.7? Well, VMware support figured it out!

    This worked for me for both Parallels & VMware:

    NOTE: PaulMcg's life-saving workaround [thanks again!] is temporary; this should be permanent.
    Last edited: Aug 12, 2011
  14. nferran

    nferran Bit poster


    I can confirm PaulMcg's solution works instantly.

    Just open a terminal window and paste the following:

    sudo kextutil -t /Library/Parallels/Parallels\
  15. DoniK

    DoniK Hunter

    Yes, but you have to run that after each time you boot your VM. The suggested fix in my post above is persistent.
  16. NiltonHC

    NiltonHC Bit poster

    Permanent solution that worked for me

    I have a MBP 15" 2010 with OS Lion and Parallels Desktop 6 build 12094. I was having a similar problem: when I plugged USB flash drive Parallels asked if I wanted to connect it to Lion os VM; I chose VM and the drive was "ejected" from Lion but was not connected at Windows (an error message said it was not possible to start the USB device).

    After trying unsuccessfully reinstall the driver for USB flash I reinstalled Parallel Tools (this option is available at "Virtual Machine" menu) and now the problem is completely solved.
  17. Confirmed, USB Drive now working

    Like the last user, I just reinstalled Tools and now my W7 VM can see the external USB connected, windows encrypted hard drive.

    I thought I did this awhile back and it didn't work but now it does. I also should note that I installed the latest Lion update.

  18. CliffD

    CliffD Bit poster

    Thanks for this - that same sudo fixed an issue with an R/C flight sim (Real Flight) not recognizing the installed USB controller!

    BTW - installed Parallels 7 this morning and it appears to resolve this issue.
  19. mbevin

    mbevin Bit poster

    so we have to pay yet another $49 to keep getting bugfixes? ... seems like just yesterday I had to pay to upgrade to Parallels 6 and now I have to pay upgrade to 7 already if I want it to keep working like it did before Lion :(
  20. DoniK

    DoniK Hunter

    Did you try what I posted earlier? Worked as a permanent fix for me in PD6...

    1) Shutdown Parallels
    In a terminal:
    2) Run "sudo -s"
    3) run "chown root:wheel /"
    4) run "chmod 755 /"
    5) Reboot

    Even if your / permissions seem fine (mine did), this worked.

Share This Page