Long, Technical Post; Update (not 3.0 upgrade) problem

Discussion in 'Windows Virtual Machine' started by nstahl, Jun 16, 2007.

  1. nstahl

    nstahl Bit poster

    I bought II's at an Apple store and installed it from the DVD and then installed Win XP Home in it, and everything was great.

    Then a couple months ago I updated and now can start II's but can't run Windows. I get the message:

    "Unable to allocate virtual machine memory!

    This error may occur mostly if there is no enough free disk space available on the physical disk to allocate virtual machine paging file. Try to clean up the physical disk (remove unnecessary files). If it doesn't help, try to re-install Parallels Desktop."

    There's a ton of room on my physical disk and I reinstalled the update, as did an Apple genius repeatedly, and we could not get past that message. I'll give the error report (which I've sent in twice with no response from II's folks) below. Unless I get good advice from someone here quickly I'll remove II's and reinstall from the CD and perhaps upgrade to 3.0, though I've just been reading bad things about that. (Any advantage to upgrading , if I do, before I install Windows?)

    For what it's worth, I originally installed II's and then Windows as an administrator. When I discovered I couldn't access the Windows from the account I work in, I moved stuff over there from the Admin account; as I said it worked well till I updated.

    Error report follows:

    ----------------- Activation Data ----------------
    Status: Valid
    User Name: Neil
    Company Name: Me
    Product ID: 6-3221561063-******
    Validity period: Not limited
    Product Name: Parallels® Desktop for Mac
    Product Version: Build 3188 (March 7, 2007)
    -------------- End of Activation Data ------------
    --------------- Host PC information ------------
    ---Primary OS version:
    Darwin Kernel Version 8.9.1: Thu Feb 22 20:55:00 PST 2007; root:xnu-792.18.15~1/RELEASE_I386---End of Primary OS version
    ---Processor(s) info:
    Number of CPU: 2
    ---End of Processor(s) info
    ---Memory info:
    User memory: 1999507456
    ---End of Memory info
    Home directory: /Users/n
    Session: local
    Memory size: 2048
    ----------- End of Host PC information ---------
    ------------ Current configuration file ------------

    Boot = c

    Parallels VM Name = XP Home

    VM Id = {1024690b-8d28-4075-a500-61a7f3******}

    VM Description =

    OS Type = 135
    (Windows XP)
    Memory = 536

    Video Memory = 16

    Memory block size = 10

    Acceleration level = 2

    Enable write-back disk cache = 1

    VT-x support = 1

    Start auto = 0

    AutoShutdown = 0

    Start full screen = 21

    Start dashmode = 0

    Start full screen warning = 1

    PC Speaker enable = 1

    Window Mode = 0

    Multi frame = -1

    Guest Tools Status = -1

    [Shared folders]

    Shared folders enabled = 1

    Sharing enabled = 0

    Shared folders count = 1

    Folder0 enabled = 1

    Folder0 readonly = 0

    Folder0 name = OS X Desktop Shared Folder

    Folder0 path = /Users/n/Desktop/Parallels Shared Folder

    Folder0 descr =


    Video resolutions enabled = 1

    Video resolutions count = 0


    Show taskbar = 1

    Relocate taskbar = 0

    Exclude Dock = 1

    Multiple displays = 0

    [IDE devices]

    Disk 0:0 enabled = 1

    Disk 0:0 = 1

    Disk 0:0 media = 0

    Disk 0:0 connected = 1

    Disk 0:0 image = winxp.hdd

    Disk 0:0 cylinders = 16254

    Disk 0:0 heads = 16

    Disk 0:0 sectors = 63

    Disk 0:1 enabled = 1

    Disk 0:1 = 2

    Disk 0:1 media = 1

    Disk 0:1 connected = 1

    Disk 0:1 image = Default CD/DVD-ROM

    Disk 1:0 enabled = 0

    Disk 1:0 = 0

    Disk 1:1 enabled = 0

    Disk 1:1 = 0

    [Floppy disks]

    Floppy 0 enabled = 1

    Floppy 0 = 1

    Floppy 0 image = /Users/n/Library/Parallels/winxp/unattended.fdd

    Floppy 0 connected = 1

    [Serial ports]

    COM1 enabled = 0

    COM1 = 0

    COM2 enabled = 0

    COM2 = 0

    COM3 enabled = 0

    COM3 = 0

    COM4 enabled = 0

    COM4 = 0

    [Parallel ports]

    LPT1 enabled = 0

    LPT1 = 0

    LPT2 enabled = 0

    LPT2 = 0

    LPT3 enabled = 0

    LPT3 = 0


    Sound enabled = 1

    Sound = 1

    Sound connected = 1

    Sound device = Default Audio

    Mixer device = Default Audio


    Network enabled = 0

    Network = 1

    Network2 enabled = 0

    Network2 = 0

    Network3 enabled = 0

    Network3 = 0

    Network4 enabled = 0

    Network4 = 0

    Network5 enabled = 0

    Network5 = 0


    USB enabled = 1

    USB = 1

    USB autoconnect = 1

    Thanks for your help.
  2. Purplish

    Purplish Forum Maven

    I haven't experienced the problem you are mentioning so these are basically guesses:

    Could be
    1) a permissions problem

    2) a Parallels Tools (wrong version) problem

    3) a fragmented virtual memory problem (least likely)

    1) With Parallels and the VM NOT RUNNING, go to the HDD file in the place where you moved it. Right click on the hdd file. Select "Get Info". Look down until you see "Permissions". Check to see that you have read/write access to the file. Expand to see the details. You also might try to repair permissions using the Disk Utility.

    2) If it is a Tools problem, you can uninstall Parallel Tools using the windows add/remove programs feature, then reboot the VM, then re-install Parallels Tools using the Parallels Actions drop down menu in the running VM.....which you can't do because it wont even start for you........so maybe try booting up in SAFE mode....and reinstalling Tools.

    3) If it is 3, it seems that a simple reboot of the MAC would cure it, so I don't think that 3 is likely.

    Wish I had more ideas. Good luck.
  3. Purplish

    Purplish Forum Maven

    One more idea...but do this only after backing up your hdd and pvs files.

    Open Parallels, without attempting to start the VM. Click HELP/CHECK FOR UPDATES

    Download and install the latest update


    I only mention this because if it is a Tools problem, the latest updates seem to have done a better job at automatically installing the right version of Tools.

    Be sure to back up first.
  4. Purplish

    Purplish Forum Maven

    Finally, the best idea of all...wait a while before trying the above...and see if one of the Parallels guys answers.
  5. nstahl

    nstahl Bit poster

    Purplish, thanks. I tried 1) and have read/write permission to all three files in the library folder.

    I don't see how to start in SAFE mode; I can't get started starting Win and I don't see a setting for that in II's.

    Thanks again.
  6. nstahl

    nstahl Bit poster

    If there's a Parallels Guy or Gal out there, please help if you can.

  7. Purplish

    Purplish Forum Maven

    If you see the Orange bar below, click on "Forum Leaders" and send a private message either to ANKOU or to PARALLELS SUPPORT.
  8. supriyo

    supriyo Junior Member

    I read somewhere on the forum that, you need to check the box in the memory section of the virtual machine configuration that says "preallocate virtual memory". This will very likely solve this problem.

Share This Page