Lost Selection Keys with Lion

Discussion in 'Installation and Configuration' started by BillRo, Jul 21, 2011.

  1. BillRo

    BillRo

    Messages:
    3
    I am running the most current version of PD6. When I upgraded to Lion I lost the ability to use the control and shift keys in Windows to extend a selection. I also now must use the control key rather than the command key when cutting and pasting in Windows. It worked fine yesterday and broke when I upgraded to Lion.

    Any ideas?
     
  2. KonstantinO

    KonstantinO Parallels Developers

    Messages:
    38
    If coherence/crystal view mode used, try to use window/full screen.
     
  3. BillRo

    BillRo

    Messages:
    3
    Fixed?

    When I switched to Window mode it worked. When I switched back to Coherence it continued to work. Hopefully that is permanent. If not, let's hope for a fix in the next release.
     
  4. Mike Mcc

    Mike Mcc Bit Poster

    Messages:
    5
    I'm seeing the same exact thing. I might not be on the latest patch, but the changing factor was installing osx lion. Maybe Parallels support can chime in?
     
  5. Mike Mcc

    Mike Mcc Bit Poster

    Messages:
    5
    I've tried it in full screen mode and in window mode. That's how I usually operate. Also tried disabling the ctrl + shift setting, but that didn't seem to do anything. I'm going to update to the latest parallels release later today and see if that helps.
     
  6. MarCoTech

    MarCoTech Bit Poster

    Messages:
    7
    It's a problem with the new keyboard shortcuts for Mission Control in Lion. I resolved this problem by going to System Preference, Keyboard, Keyboard Shortcuts and under Mission Control unchecking:

    Move left a space
    Move right a space
     
  7. Mike Mcc

    Mike Mcc Bit Poster

    Messages:
    5
    MacCoTech - that did it! Thanks!
     
  8. willmow

    willmow Bit Poster

    Messages:
    44
    All hail MarCoTech! Thanks for the solution!
     
  9. BennettD

    BennettD Bit Poster

    Messages:
    40
    Selected answer didn't work for me...

    My mission control for left a space and right a space was set to command + arrow key, so I'm not sure how that's related. My fix was entering window mode and returning. I'd say this is a definitely a bug that needs to be addressed.

    I'm sure Parallels will have it squared away soon though :)
     
  10. willmow

    willmow Bit Poster

    Messages:
    44
    You're wrong there, D. The Mission keystrokes involve the CTRL key (symbol ^) not CMD, so the interference with Parallels is plausible.
     
  11. BennettD

    BennettD Bit Poster

    Messages:
    40
    Wow, so I'm wrong huh? Perhaps I just don't understand what it is that we're talking about.

    As a heavy keyboard shortcut user, a Parallels user and a Windows user, the default mapping for change space (control + arrow) didn't work for me. Why? Because in Windows control + arrow is move carrot to the next word (holding shift selects while moving by words). Because of this the default change space mapping just didn't work for me, so I changed it to something more suitable, command + arrow. Not surprisingly, my Snow Leopard change survived the update to Lion...

    I've attached a screenshot to show what I'm talking about just in case its not what you're talking about.
     

    Attached Files:

  12. willmow

    willmow Bit Poster

    Messages:
    44
    Oh I see. It was your wording that slightly muddied the waters. The main thing is that right now Parallels is working just dandy and that's fine with me.
    Thursday's a different matter: I'm creating a Boot Camp partition, chucking out Vista Home Premium, installing Windows 7 in the partition and reinstalling the Windows program I have to use (which isn't available for the Mac), then getting Parallels to create its image disk or whatever it is based on what's in the partition. Yuck!
     
  13. DusanS

    DusanS Bit Poster

    Messages:
    1
    I've been looking for this since I upgraded to Lion... Running Parallels 6 with the latest patch...I changed the setting as MacCoTech suggested, but it worked a few minutes and when I started an application in Windows7.. it stopped working... argh ... back to Windows shortcuts only and no Parallels shortcuts...

    I've tried reinstall Parallels, even Parallels tools.. always it worked the first time.

    Did anyone experience the same issue?
     
    Last edited: Jul 28, 2011

Share This Page