[Mac] Add an option to disable Windows key

Discussion in 'Feature Suggestions' started by Zhou, Dec 28, 2006.

  1. Zhou

    Zhou

    Messages:
    6
    It irritates me when I see that start menu popping out when I press Cmd+Tab to switch to another application. It would be good if there was an option to disable the windows key.
    Another useful option would be to make Cmd become a Ctrl key. Many default shortcuts in MacOS and Windows are same except for modification key (Ctrl+S in Windows is Cmd+S in MacOS)
     
  2. tacit_one

    tacit_one

    Messages:
    438
    Please, check out our latest beta of Parallels Desktop - this feature was already added.
     
  3. jwiegley

    jwiegley Bit Poster

    Messages:
    19
    Oh please tell me, how can this be done? I've looked everywhere!

    John
     
  4. Zhou

    Zhou

    Messages:
    6
    Check preferences, Keyboard.


    The preference is there. And it does work. But...
    I'm using Eclipse (it's Java IDE) and the most common shortcut I use is Ctrl+Space. It doesn't work for some reason if I swap Ctrl & Cmd keys. Can you add a preference so both Cmd & Ctrl keys work the same?
     
  5. Zhou

    Zhou

    Messages:
    6
    Another thing to integrate Windows Apps more closely to MacOS X would be to remap the text navigation shortcuts - Cmd+Left to Home, Cmd+Right - End, Alt+Left-Right - Ctrl+Left-Right.

    I'm starting to think that some UI for custom key mappings would be really great.
     
  6. palter

    palter

    Messages:
    243
    It probably doesn't work because Cmd+Space is the default shortcut for Spotlight. Try turning that off in the Spotlight preferences.
     
  7. ericchiu

    ericchiu

    Messages:
    8
    I did check the 3120 RC1, in Keyboard preference there are just four options for toggoling different screen modes, no words on disable windows:confused: key?
     
  8. bfiller

    bfiller

    Messages:
    1
    Please, please, please add a specific option to disable the Windows key. Remapping ctrl/cmd does not work for me, because I want to keep the cmd key where it is because I'm used to it there, but I do want to disable the Windows key.

    Specifically, I am running Fedora Core 6 Linux in Parallels and the left cmd key and right cmd key work differently. I would like them to work the same. The right cmd key always displays a popup menu on the Linux desktop, which is annoying and not what I want (because when I cmd-tab to switch to a Mac OS app, it pops up a Linux popup which I later have to dismiss when I switch back). Also, I'm a big emacs user and the special mapping Parallels does with the right cmd key messes emacs up into thinking I pressed "meta-x" which is NOT what I want.

    Is there any undocumented way to disable this under the covers? Any conf files or anything like that?
     
  9. mpatel696

    mpatel696

    Messages:
    4
    I use Parallels mostly for excel in Windows- the major advantage of which is that all of the quick shortcuts (alt-e>r>d, etc.) that I've been using for years work right out of the box. The only problem is that most windows keyboards have the alt key net to the space bar, which is the apple key on the mbp. Is it possible to either have the ability to custom map keys (as per some of the earlier posts) or just have an option to redundantly map that key as the alt key?
     
  10. mmulin

    mmulin

    Messages:
    31
    as for my part, i just disabled the windows key in xp. it might not help all of you but at least you get rid of the annoying pop of the window start menu:

    instructions:
    - open "regedit"
    - go the the key: "HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Keyboard Layout"
    - select "New" -> "Binary value" from the "Edit" menu
    - name it "Scancode Map"
    - give it the value binary value "00 00 00 00 00 00 00 00 03 00 00 00 00 00 5B E0 00 00 5C E0 00 00 00 00"
    - restart xp

    since i dont use bootcamp, i am not sure if this will also kill the windows key under bootcamp boot. does it use the same registry? anyways, you probably can work around it hitting <ctrl+esc>
     
  11. lupus

    lupus

    Messages:
    17
    Definitely could do with an option to disable the windows key. I have gone down the route of disabling the key in windows, but it is a fiddly way to do it.

    When the windows key is there, it seems to disable the option for remapping CMD-ZXCVAF as all those key combos bring up the pesky windows menu....

    Cheers,

    Joel
     
  12. pigwiggle

    pigwiggle

    Messages:
    34

    Worked like a charm. Great tip.
     
  13. ABR

    ABR

    Messages:
    3
    Another vote

    I too would like an option to disable the Windows key. I'm using PD 4.0 and in the prefs for Keyboard & Mouse I unchecked the mapping of "Cmd" to "Win", but it didn't seem to do anything -- press and release Command and the Start menu annoyingly pops up, as it often will when trying to alt-tab in/out. If this change requires a virtual machine restart (which sucks), it should say so.
     
  14. ihatewindowskey

    ihatewindowskey

    Messages:
    1
    I hate the windows key with a passion

    I've been using Parallels since version 3. The last version I had did have this option to disable the key and it worked.
    According to the "valuable" information provided by the Parallels Team below, it has been added. And, honestly, I do see in the keyboard prefs to change this command. I've actually shut everything off that concerns the command button just to see if it would stop haunting me. No luck.

    Unfortunately like all of you, it has been unstoppable. While the overall interface and speed of parallels seems easier and faster, there are other things that just don't make any sense. I really shouldn't have to enter regedit as described below. And frankly, i refuse. I'm sure there are many challenges that the Parallels team needs to overcome, but this one is really annoying.

     
  15. nvrmore100

    nvrmore100

    Messages:
    21
    One thing to note, I did the disable reg value thing, and it does work. However, when in coherence mode, you no longer able to click the Parallels icon to bring up the start menu... I have ended up having to do a mix of the two.

    First, you can use the reg key item from this URL to do the work for you:

    http://johnhaller.com/jh/useful_stuff/disable_windows_key/

    Second, I added a new keyboard shortcut for ALT --> CONTROL-ESC

    This does not re-enable the Parallels icon from working, but at least now my Win key on my keyboard brings up the start menu, and I am not plagued by it popping up any time I Apple-TAB away from Parallels.
     
  16. arkaycee

    arkaycee

    Messages:
    4
    I found a workaround that doesn't involve registry hacking. After unchecking the Cmd to Windows mapping and finding it it still happened, I finally tried mapping Cmd to Alt, and Shift+Cmd to Windows. Of course, now I must hit Shift+Cmd (I guess I could've done something like Option+Cmd if I need to really Shift+Cmd in Windows, though I don't use the Windows key for anything but to bring up the Start Menu anyway).
     
  17. johncarn

    johncarn

    Messages:
    5
    Doesn't work for me

    I have a microsoft intellitype keyboard. I use the option to swap the Option and CMD keys so that it matches the Mac keyboard.

    However, when I deselect the option in Parallels that maps the CMD key to the WIN key, it doesn't make a difference. Even if I change the option back to not swap the Option and CMD keys in the keyboard driver, it doesn't make a difference.

    The way I had to get around it is to add a new mapping to map CMD to ALT in Parallels. This removed the CMD to WIN mapping, and now things seem to work as anticipated.

    Not sure why deselecting the option didn't work. I'm running latest version of Parallels and Windows 7 on Mac OS X 10.6.2
     
  18. Cobra

    Cobra Bit Poster

    Messages:
    5
    I don't get why unchecking Command as the Win key still doesn't stop it from behaving like the Win key.
    Running Win XP in 5.0.9344

    As this has been an issue for years now, I'm hoping it will be resolved some time soonish.
     
  19. alexusu

    alexusu

    Messages:
    2
    Apple-TAB

    This does not re-enable the Parallels icon from working, but at least now my Win key on my keyboard brings up the start menu, and I am not plagued by it popping up any time I Apple-TAB away from Parallels.
     
  20. mammothboarder

    mammothboarder

    Messages:
    3
    Microsoft Knowledge Base - Disabling Windows Key

    Evidently Microsoft has had complaints about the Windows key behavior, even on Windows. The following article will point you to a "Fix It" button that will do the work (disable the Windows key automatically) or you can follow the instructions to have edit the registry yourself.

    http://support.microsoft.com/kb/216893

    It just disables the key-to-menu feature as far as I can see. Once gone, the mapping of Command-x/c/v, etc. to cut/copy/paste/etc. all work as expected. Just no annoying start menu popping up.
     

Share This Page