Mac M1 guest OS

Discussion in 'macOS Virtual Machine' started by PaulC47, Jun 14, 2021.

  1. PaulC47

    PaulC47 Bit poster

    Some question:
    1. No Intel Mac OS could be emulated by Parallels? Never or in the future will be possible?
    2. Why Parallels tell me Big Sur OS cannot be installed (it's ARM, no Intel)?
    OlivierD and griffdb like this.
  2. Hello,
    please find list of Supported Guest Operating Systems (Mac with Apple M1 chip):
    Only ARM versions of operating systems are supported.
    • Windows 10 on ARM Insider Preview
      • Learn how to install Windows 10 on ARM Insider Preview in this video.
        Additional information on the M1 experience may be found in this article.
      • Windows on ARM can run most of the regular Windows x86 applications. You can download the Parallels Desktop trial and install the application you need. If it doesn't work, let us know at Parallels Forum.
    • Ubuntu 20.10, 20.04
    • Fedora Workstation 33-1.2
    • Debian GNU/Linux 10.7
    • Kali Linux 2021.1
  3. And could you provide us with a bit more information about the issue with macOS Big Sur installation please?
  4. PaulC47

    PaulC47 Bit poster

    I've a mac mini 2020 m1.
    I tried to install Big Sur, which is ARM (the same installer with which I installed Big Sur on my Mac Mini).
    After converting the installer into image file, the application stopped by saying that only the arm operating systems are supported.
    But big sur is Arm.
    griffdb likes this.
  5. PaulC47

    PaulC47 Bit poster

  6. BrianH23

    BrianH23 Bit poster

    Curious about this issue as well. M1 Mac Mini, Parallels running Windows 10 ARM, would like to play with a fresh Parallels-hosted Big Sur. Go through the process to create an ISO, from the Big Sur Installer- I get the same dialog box. I've also tried the process listed in this KB article:
    There is no option for installing from the Big Sur Recovery Partition, I see only the 4 free Linux installs. Would love to see a solution to this. Big Sur runs on ARM, I'm running Big Sur on my M1 Mini...what's the problem? Screen Shot 2021-06-24 at 8.51.09 PM.jpg
    griffdb and PaulC47 like this.
  7. AsadUK

    AsadUK Bit poster

    I've spent quite a bit of time on this, and it really is starting to sound like macOS VM's are currently not supported on Parallels for M1. I've searched the entire Knowledge Base, the "Install from Recovery" option is not available for M1, and creating a VM using the .app file for macOS also fails at the image creation stage.

    Kinda disappointed. :-(
    OlivierD, LaurentM6 and griffdb like this.
  8. griffdb

    griffdb Member

    It would be nice if they would support a bootable installer of macOS Big Sur for the M1 macs.
    JohanE6, LaurentM6 and AsadUK like this.
  9. JohanE6

    JohanE6 Bit poster

    This is the only reason we bought an extra Parallels license for our m1 mac, to be able to run the macOS 12 beta. Nowhere in the sales pages does it highlight that OSX would not be supported on the m1, that other VM's need to be arm is clearly specified and makes sense, but not being able to run the same OS it runs on top of was unexpected.
    OlivierD likes this.
  10. SeanM26

    SeanM26 Bit poster

    Going to bump this - any update if anything on this o_O, would like to get an explanation.

    Attached Files:

    OlivierD likes this.
  11. ManziM

    ManziM Bit poster

    Didnt look like @Maria@Parallels knew the answer.
    Anyway, fast forward to August 2021......
    With Parallels 17 now released, boasting it is ready for Monterey, can we at least now install Big Sur in v17?
    And should we be using v17 Pro for it, or can v17 Standard run it too?
  12. Elric

    Elric Parallels Team

  13. DKim

    DKim Bit poster

    Thanks a lot. I've created Monterey VM successfully on my M1 Mac mini.
    Unfortunately, I cannot create a snapshot of this VM; Manage Snapshots... menu item doesn't exist.
    Does it mean this functionality doesn't exist yet? When are you planning to add it?
  14. JPJ1

    JPJ1 Bit poster

    Is there a way to update the Monterey VM to a more recent build? It runs build 21A5304g and current build is 21A5506j.
    When I check the VM for updates, it claims "latest software update allowed by your administrator", like there is a policy to block updates.
    Do I have to trash it and download a new one? What is the way forward?
  15. MatthiasS9

    MatthiasS9 Member

    This appears to be a known issue, I saw a workaround mentioned somewhere, but did not yet follow it up.
  16. JPJ1

    JPJ1 Bit poster

    Well, deleted my VM, requested a new MacOS install, and it has the latest beta. So no in-place upgrade, but I can get current macOS beta code (and the rest is brew automation, it is fast).

Share This Page