mac os x ferezes when waking form hibernation with VM running

Discussion in 'Windows Guest OS Discussion' started by gfbgbgb, Feb 21, 2011.

  1. Vicki_Mongan

    Vicki_Mongan Bit Poster

    Messages:
    2
    I'm having the same issue. At first Yosemite and Parallels worked fine running Windows 7. Seems like the recent Parallels upgrade was the cause of my computer starting to completely freeze every time I step away for more than a couple of minutes. Neither the Mac side or Windows 7 works until I reboot. Very frustrating.
     
  2. Parallels_User123456

    Parallels_User123456 Bit Poster

    Messages:
    5
    Same here. Very, very annoing...
     
    Peter Huynh likes this.
  3. Peter Huynh

    Peter Huynh Bit Poster

    Messages:
    7
    Hi Parallels. Has there been any updates on fixing this problem?

    Does anyone have any more information on this problem, or how to prevent it? I'm using Yosemite, Parallels 10, and Windows 8.1 Pro and am currently experiencing this problem.

    Thanks.
     
  4. Peter Huynh

    Peter Huynh Bit Poster

    Messages:
    7
    Update: I contacted Parallels customer support, and I was told that my issue needed to be investigated at the code level by the engineering team. They could not provide me an ETA on a fix, but I hope it will be soon. If anybody else has this issue, please contact Parallels and let them know, so that they'll raise the priority for this bug.
     
  5. MichaelI2

    MichaelI2 Bit Poster

    Messages:
    1
    Same problem here. iMac Retina 5k, Mac OX 10.10.2, Parallels 10.1.4, Windows 8.1 Pro

    Add your post so we can raise the priority for this issue.
     
    ValorP1 and Peter Huynh like this.
  6. Parallels_User123456

    Parallels_User123456 Bit Poster

    Messages:
    5
    Any news on this issue? I'm still running into it regularly, so I'm starting to look for other options. Anyone know if VMWare Fusion suffers the same issue?
     
  7. Peter Huynh

    Peter Huynh Bit Poster

    Messages:
    7
    None from me. The only thing I've been able to do to mitigate the issue is suspend the vm before I put my mac to sleep. Not a great solution. I often forget to suspend it because I'm used to just closing the lid when I'm done using my computer.
     
    ValorP1 likes this.
  8. Parallels_User123456

    Parallels_User123456 Bit Poster

    Messages:
    5
    Yeah, that works, but as you say, it's easy to forget. Guess I'll have to check out VMWare Fusion.
     
  9. Parallels_User123456

    Parallels_User123456 Bit Poster

    Messages:
    5
    Anyone knows if this has been resolved with Parallels 11?
     
    Peter Huynh likes this.
  10. ValorP1

    ValorP1 Bit Poster

    Messages:
    6
    Thanks to some additional googling, I discovered "pmset" as did IshkanN.
    In reading the MAN page, it *appears* that on my iMac Retina 5k, it should not "hibernate" but only sleep (keep memory powered). This does not seem to be the case, as each night (after ~3 hours of inactivity), I see in the console logs references to hibernation and reading the hibernation file from /var/vm/sleepimage, which shouldn't be the case, given that "hibernatemode 0" means "don't write memory contents to disk".

    At any rate, the man page states that the "standby" setting is set to "1" for machines that support it, and my "standbydelay" is set to 10,800 seconds, or 3 hours.
    The description for "standby" reads: standby causes kernel power management to automatically hibernate a machine after it has slept for a specified time period. This saves power while asleep. This setting defaults to ON for supported hardware. The setting standby will be visible in pmset -g if the feature is supported on this machine.

    I've tried the following setting, and will report back if it fixes/doesn't fix the issue.
    sudo pmset -a standby 0
     
  11. ValorP1

    ValorP1 Bit Poster

    Messages:
    6
    Update: Works great!
    There's a bug in Apple Power Manager that allows iMac 5k to hibernate, even when hibernate mode is set to 0 -- It may be an interaction with the Parallels hypervisor asking the hardware to hibernate, and the hardware executing the command even when it's not supposed to. Then, the Memory not being paged to disk doesn't exist upon waking, causing the behavior we're all seeing.
     
  12. Peter Huynh

    Peter Huynh Bit Poster

    Messages:
    7
    Anybody able to get a hold of Parallels to ask them if Parallels 11 solves this issue? I'd rather not disable hibernation on my laptop. I'm a bit busy, but I'll see if I can contact them or try out the Parallels 11 demo.
     
  13. harpo01

    harpo01 Bit Poster

    Messages:
    7
    I've been having the same problem for about a month with Windows 8.1, then I upgraded to Windows 10 (same problem).
    I have thought it was an Apple problem and have been working with them for a solution, so far they have asked me to install Yosemite 10.10.5 over the top of my existing OS X. The latest is they have as me to do a clean reinstall of everything which I decided not to do because of the 24 hours work of reinstalling.
    I have also discovered a solution is to suspend the VM.
     
  14. Peter Huynh

    Peter Huynh Bit Poster

    Messages:
    7
    @harpo01, are you using Parallels 11 or 10?
     
  15. harpo01

    harpo01 Bit Poster

    Messages:
    7
    Hi Peter,
    I'm using Parallels 10.
    I don't think I will be upgrading to 11 (which I always do) because of the new software policy.
     
  16. Parallels_User123456

    Parallels_User123456 Bit Poster

    Messages:
    5
    I can confirm that this bug still exists in Parallels 11...
     
    Peter Huynh likes this.
  17. Peter Huynh

    Peter Huynh Bit Poster

    Messages:
    7
    Same here. I'm going to keep an eye out for changes, but until then, I won't be upgrading.
     
  18. ValorP1

    ValorP1 Bit Poster

    Messages:
    6
    @Peter Huynh @harpo01 Did you try the fix that worked for me, above?
    FYI, I had to do this again after a recent Apple software update reverted my custom setting.
     
  19. harpo01

    harpo01 Bit Poster

    Messages:
    7
    Apple have just replaced parts of my Mac to fix this problem, I have also switched to VMWare Fusion.
     
  20. Peter Huynh

    Peter Huynh Bit Poster

    Messages:
    7
    @ValorP1: yeah, disabling standby worked. I didn't like the idea at first, but not having to remember to suspend the VM before closing the lid was better than not having standby. It's not good that I have to do this, but it works. Thanks for sharing your idea.
     

Share This Page