Mac OS X Snow Leopard and Parallels Desktop for Mac compatibility topics

Discussion in 'Installation and Configuration' started by Forgiven, Oct 2, 2009.

  1. Forgiven

    Forgiven

    Messages:
    46
    [​IMG]

    Dear Customers,
    We tried to analyze most popular topics related to Mac OS X Snow Leopard and Parallels Desktop for Mac compatibility. In order to help you to resolve your questions in timelier manner we would like to provide you with the list of applicable solutions. Hope it may help.
    Here are the topics we are going to provide you with solutions:

    1. I cannot download the .dmg file from your web site.
    2. What Guest OSes are supported by Parallels Desktop 4 for Mac build 3846?
    3. What's new in Parallels Desktop 4 for Mac build 3846?
    4. I get annoying pop-ups that update is available for my version of Parallels Desktop.
    5. How do I upgrade from Mac OS Leopard to Snow Leopard?
    6. How do I upgrade from Parallels Desktop version 3 to version 4?
    7. How do I upgrade from Parallels Desktop build 3844 to build 3846?
    8. What will be with my data, Virtual Machines during upgrade?
    9. I cannot upgrade: missing files, missing dependencies, cannot run both versions 3 and 4 at the same time errors occurred.
    10. I cannot register PD on your website: cannot login in to My Account, annoying pop-up you need to register.
    11. I have questions/issues regarding Parallels Desktop 5 beta.


    We also strongly recommend you to address technical issues to our Troubleshooter Assistant (http://www.parallels.com/support/free/troubleshooter/categories/?id=731);*check comprehensive Knowledge Base (http://kb.parallels.com/)*and participate in Forum (http://forum.parallels.com/)*discussions to find solutions for known issues.


    ==================================================================

    Below you will find solutions for the mentioned above issues.

    ==================================================================

    1. I cannot download the .dmg file from your web site.

    Please pay attention to the solutions provided in our Knowledge Base articles:
    http://kb.parallels.com/en/6696
    http://kb.parallels.com/en/6684

    The main point is that you need to copy/paste the full link to the file provided by download request to your browser.



    2. What Guest OSes are supported by Parallels Desktop 4 for Mac build 3846?

    Please check our documentation for the list of supported OSes:
    http://download.parallels.com/desktop/v4/docs/en/Parallels_Desktop_Users_Guide/23583.htm

    In addition, build 3846 fully supports Ubuntu 9.04 (which means that Parallels Tools can be successfully
    installed in Ubuntu 9.04 Guest):
    http://kb.parallels.com/en/6537



    3. What's new in Parallels Desktop 4 for Mac build 3846?

    Please check Parallels forum thread where detailed answer is provided:
    http://forum.parallels.com/showthread.php?t=93202&highlight=build+3846



    4. I get annoying pop-ups that update is available for my version of Parallels Desktop.

    Once you get message about new available updates, please try to update Parallels Desktop application.
    If automatic update fails for some reason, you can always find the latest build at our website and install it
    manually:

    http://www.parallels.com/download/desktop/

    The following Knowledge Base article can be also helpful if you wish to check the current version of Parallels Desktop and to finish update manually:
    http://kb.parallels.com/en/6684



    5. How do I upgrade from Mac OS Leopard to Snow Leopard?

    Please check Apple website for details on upgrading OS:
    http://www.apple.com/macosx/uptodate/

    List of software incompatible with Mac OS X Snow Leopard can be found here:
    http://support.apple.com/kb/HT3258

    Information on Parallels Desktop on Mac OS X Snow Leopard is available in the following article:
    http://kb.parallels.com/en/6637

    Questions that might arise about Parallels Desktop and Mac OS X Snow Leopard are covered at this page:
    http://www.parallels.com/products/desktop/snowleopard/

    The overview, instructions and other useful information on Snow Leopard *can be found here:
    http://store.apple.com/us/product/MAC_OS_X_SNGL



    6. How do I upgrade from Parallels Desktop version 3 to version 4?

    The process of Parallels Desktop version 3 --> 4 upgrade is outlined here:
    http://download.parallels.com/desktop/v4/docs/en/Parallels_Desktop_Users_Guide/23672.htm



    7. How do I upgrade from Parallels Desktop build 3844 to build 3846?

    The general way is to click on the Help option --> Check for updates.
    If the download has finished, but Parallels Desktop is not updating, please find the installation file on your desktop and launch it manually. The other way is to download build 3846 from our website:
    http://www.parallels.com/download/desktop/

    If the download does not start cause of "Forbidden" error in the internet browser, please copy the link sent to your email and paste it to your Internet browser.

    The following articles cover such situations:
    http://kb.parallels.com/en/6696
    http://kb.parallels.com/en/6684



    8. What will be with my data, Virtual Machines during upgrade?

    Parallels Desktop upgrade does not change Virtual Machines. Your Virtual Machine files are located in your /Home_folder/Documents/Parallels/VM_folder/ by default *(it also might be in your /Home_folder/Library/Parallels/VM_folder/ if the virtual machine was created under builds 1970 and earlier).



    9. I cannot upgrade: missing files, missing dependencies, cannot run both versions 3 and 4 at the same time errors occurred.

    If you see "Conflicting virtual machines" when updating Parallels Desktop, please refer to:
    http://kb.parallels.com/en/6659

    'Operating System Too Old' warning message can be fixed by applying this article:
    http://kb.parallels.com/en/6660



    10. Guest OS Windows falls to BSOD (Blue Screen of Death error).

    If Windows falls to BSOD (Blue Screen of Death error), you can repair it as described in the following article:
    http://kb.parallels.com/en/5138



    11. I cannot register PD on your website: cannot login in to My Account, annoying pop-up you need to register.

    Most probably Firewall blocks Parallels registration. Configure your Firewall settings or try to register from a different network. Any public Wi-Fi will work.

    Make sure that you are using the latest build of Parallels Desktop 4.0 - 3846. You can download it from our website:

    http://www.parallels.com/download/desktop/

    If the download does not start cause of "Forbidden" error in the internet browser, please copy the link sent to your email and paste it to your Internet browser.

    If you cannot login to your account, please make sure that you are using correct and the same e-mail address you used when you created account at Parallels website. If necessary, please use "Forgot your password?" link to restore your password.



    12. I have questions/issues on PD5 beta.

    We appreciate your attention to Parallels Desktop 5 for Mac Beta program.

    Please be advised that the Beta version is not the final version of Parallels Desktop 5 for Mac. It has been thoroughly tested but may still contain some issues. Parallels Support Team does not provide technical support for the Beta version. If you have any questions and feedback on the product or wish to share your Beta experience, please use this e-mail address pdfm5beta@parallels.com as point of contact.

    Your feedback will be much valued and will help us improve the product.

    Information on release date is not available yet. Please visit our web site www.parallels.com for new announcements.

    Sincerely,
    Parallels Support Team
     
  2. Forgiven

    Forgiven

    Messages:
    46
    If you have the question about the topics mentioned above you can ask. If not please do not spam, the messages will be deleted, account will be banned.
     
  3. James R.

    James R.

    Messages:
    2
    Shut Down Windows XP in 3.0?

    OK,

    So I upgraded to Snow Leopard last week and when I click the Paralles Icon on my desk top it says;

    You can't use this version of the application Parallels Desktop with this version of Mac*OS*X.

    So I purchased the new 4.0 version, but during the installation it says that I need to shut down Windows XP before I can complete the installation process. The problem is I can't get into 3.0 to turn XP off? What do I do to get XP shut down so I can install?

    Should I uninstall 3?
    If I uninstall 3, am I going to lose all of my files I have saved in 3?
     
  4. Forgiven

    Forgiven

    Messages:
    46
    >The problem is I can't get into 3.0 to turn XP off? What do I do to get XP shut down so I can install?
    Shutdown VM and quit Parallels Desktop 3.

    >Should I uninstall 3?
    it will be uninstalled automatically when you run PD4 installer.

    >If I uninstall 3, am I going to lose all of my files I have saved in 3?
    no.
     
  5. Michael D

    Michael D

    Messages:
    4
    same problem for me...

    I (foolishly) upgraded to Snow Leopard (should've waited, at least to install it). I have PD 2.5 for mac. After the 10.6 upgrade I tried to open Parallels, which of course did not work. I quickly found out that I needed to ugrade to 4.0.

    I have since done that. I looked through the tips at the parallels online store... They said to back up all of your data because it will be lost during the installation of the 4.0 upgrade.

    Now I read here that it will not be lost. Which is it, I need to know for sure. I cannot access my files in Win XP in Parallels, one way or another I need to get these files a.s.a.p.

    Someone please help me...

    I am using a 2007 MacBook Pro, Intel Dual Core 2.16GHz, 2GB RAM, 500GB HDD, 17", now with 10.6, trying to use PD 4.0 without losing all of files that are in Win XP.

    Thanx,

    shotgunn
     
  6. Michael D

    Michael D

    Messages:
    4
    same problem here...

    I just upgraded to Snow Leopard 10.6 from 10.5.8 (should've waited, at least to install it...) I tried to open Parallels (2.5) it said it cannot be opened with this OS. (or something like that)

    So I upgraded to PD 4.0 I am hesitant to do the upgrade now. I have some VERY important files on there and I cannot afford to lose them. When I purchased the 4.0 upgrade I saw some FAQ, it said something like 'when you install 4.0 be sure to back up your VM data because all will be lost otherwise.

    Since I am at 10.6 I cannot access PD, so I cannot backup my XP data. How can I get back to my data now?

    I need to access my Win XP files a.s.a.p.

    I am using a 2007 17" MacBook Pro, Intel Dual Core 2.16Ghz, 2GB RAM, 500GB HDD, 10.6, PD 4.0

    Please help, my business depends on this.

    Thanx

    shotgunn
     
  7. NatLyman

    NatLyman

    Messages:
    1
    SL 4.0 upgrade, cannot turn off VM

    Victor: I am having the same problem as the first poster. Snow Leopard is already installed. The VM was not turned off before upgrading to SL. 3.0 will no longer work in SL, but the 4.0 upgrade requires the VM to be turned off. It is a catch-22, because we cannot run 3.0 to turn off the VM, and the install is requiring it to be turned off before upgrading to 4.0

    Is there a command line to force quit the VM through terminal, or some similar procedure? Thank you for your efforts.
     
  8. Forgiven

    Forgiven

    Messages:
    46
    Michael, I created the ticket for you and sent you an email.
    The upgrade does not wipe virtual machines but it changes the format of the virtual machine's files and this changes irreversible, that is why it is better to do the backup before the upgrade.
    =========================================================================
    NatLyman, yes you can stop or start the VM from the terminal.
    prlctl list -a
    will let you know the ID of the VM.
    prlctl stop <vmID>
    to stop VM
    prlctl start <vmID>
    to start VM
     
  9. James Lawrence

    James Lawrence

    Messages:
    2
    Conflicting virtual machines error after upgrading to Mac OS X Snow Leopard

    I have the error described at http://kb.parallels.com/en/6659

    The directory /Users/<me>/Documents/Parallels/ is empty and the problem does not go away if I rename it.
    No other user has a Parallels virtual machine - so there are no directories like /Users/<some other user>/Documents/Parallels/

    There is a virtual machine that I can access using Parallels Explorer, however I don't know where it is stored on the hard disk. Is there some location other than Users/<me>/Documents/Parallels/ where it could be? Was there another location used prior to version 3?

    I have tried running prlctl list -a as suggested. I get the following error:
    -bash: prlctl: command not found
    What is the path to prlctl?
     
  10. Forgiven

    Forgiven

    Messages:
    46
    Hello James,
    PD version 2 stored VM's folders at /Users/<you>/Library/Parallels/ , also check /Users/Shared/Parallels/ . The best way to figure out the location of VM is to check the configuration of your VM and in the section "Hard Disk 1" check the path where the hard drive image is located.
    prlctl utility is included supported with PD version 4 , according to kb you mentioned you still have version 3.
     
  11. James Lawrence

    James Lawrence

    Messages:
    2
    Thanks - the virtual machine was at /Users/Shared/Parallels
    Having moved the virtual machine, I had to use prlctl to register it again after installation:
    prlctl register /Users/<me>/Parallels/<machine name>/<machine name>.pvs
    Now working through the steps to complete the upgrade ...
     
  12. MacRush

    MacRush

    Messages:
    1
    I am surprised that no item "very slow shut down after Snow Leopard Upgrade" is in the compatibility issues list. The Forums are full of issues and several (including my experience) clearly point to issues with Parallels (including 3846 build):

    Normal shut down with SL: below 5 seconds
    Shut down with Paralells installed: 2 minutes!
    Some posters solved this problem by completely removing Parallels and reinstalling it. But in my case this did not work:
    Shut down with Parallels: more than 2 minutes
    Shut down after deinstalling Parallels according to Parallels support advice: less than 5 seconds!!
    Shut down after re-installing Parallels: more than 2 minutes.

    As this issue is not solved for me I appreciate any help and advice!
     
  13. Forgiven

    Forgiven

    Messages:
    46
    Hello MacRush,
    I created the ticket for you and send the message to your email.
     
  14. Tim B

    Tim B

    Messages:
    2
    I've just received an e mail (14 day time limited) offer from Parallels team to upgrade to 5.0 for $39.95. I am currently running version 3.0 with XP and it all works fine however I was thinking of upgrading to 5.0 in order to keep my options open with a view to upgrading from Leopard to Snow Leopard in future ( I believe you needs Parallels 4 or above to run in Snow Leopard ?). So I just wondered what happens when you upgrade your version of Parallels or Mac OS?
    1. If I upgrade from Parallels 3 to Parallels 5 via online upgrade, do I have to re install windows XP after the upgrade? Also , do I have to re install any programs that I currently run inside XP and Parallels? Hopefully Parallels 5.0 just installs over the top and upgrades , leaving everything where it is. (That's what the Parallels forum seemed to imply)
    2. I also assume that , if I do upgrade from Leopard to Snow Leopard, that won't effect my Parallels 5.0 or will I have to re install Parllels 3 from my disc and then upgrade to 5.0? Has anyone upgraded to Snow Leopard , in which case did you need to re install Parallels or does snow Leopard just do it's thing and leave all your other bits where they are ?
    I don't have VM Fusion so if it's all too much trouble I won't bother, however an upgrade to Parallels 5 and Snow Leopard would be good if it's at a price too good to miss.
    Any advice from those who've upgraded either Snow Leopard or Parallels please ?
    Many thanks from a bit of a numpty when it comes to all this. Relative New Kid on the Mac block !!
    Tim B
     
  15. Dave Wells

    Dave Wells

    Messages:
    14
    Why are all the solutions posted for the "Snow Leopard upgrade" referring to Parallels 4, instead of 5?
     
  16. Forgiven

    Forgiven

    Messages:
    46
    >If I upgrade from Parallels 3 to Parallels 5 via online upgrade, do I have to re install windows XP after the upgrade?
    No.
    >Also , do I have to re install any programs that I currently run inside XP and Parallels?
    No.
    >Hopefully Parallels 5.0 just installs over the top and upgrades , leaving everything where it is. (That's what the >Parallels forum seemed to imply)
    Yes, during the upgrade of VM only the Paralells drivers reinstallation on windows takes place.
    >Hopefully Parallels 5.0 just installs over the top and upgrades , leaving everything where it is. (That's what the >Parallels forum seemed to imply)
    Yes
    >will I have to re install Parllels 3 from my disc and then upgrade to 5.0?
    No.
    >Has anyone upgraded to Snow Leopard , in which case did you need to re install Parallels or does snow Leopard just >do it's thing and leave all your other bits where they are ?
    Yes.
     
  17. Forgiven

    Forgiven

    Messages:
    46
    >Why are all the solutions posted for the "Snow Leopard upgrade" referring to Parallels 4, instead of 5?
    Because post originally was created before PD5 release. But most of the points can be also applied to PD5.
     
  18. Tim B

    Tim B

    Messages:
    2
    Thanks Victor, I have gone ahead and upgraded to 5.0 and it was truly painless. As you said, everything was left as before. Now I'm all set up for an upgrade to Snow leopard when the mood takes me. Many thanks.
    Tim B
     
  19. Robin Bassett

    Robin Bassett

    Messages:
    3
    Now can't find Build 3846 for Parallels 4 on your website therefore can not update my current build 3049 despite using the check updates link in help menu the instal quits and will not download the full dmg to install from. Please help we don't want to spend £34 on upgrade just yet.
    Now running on Snow Leopard please advice.
    Thanks
    Robin
     
  20. Robin Bassett

    Robin Bassett

    Messages:
    3
    Can't download build 3846

    Have tried running update from the menu on build 3049 (original cd) but despite the install starting it crashes out. I can no longer find the dmg file on your website for build 3846 update and instead there is the trial download of Parallels 5 which we currently can't update to.
    I am using Snow leopard 10.6.1

    Please send procedure to update because I no longer can use Windows at all on my machine.
    Thanks
    Robin Bassett
     

Share This Page