Mac Pro / Network - Telnet works, Web Doesn't

Discussion in 'Parallels Desktop for Mac' started by adamjroth, Sep 7, 2006.

  1. adamjroth


    System: Mac Pro 2.66ghz stock setup with 2gb of Ram

    Parallels: Build 1884

    Router: Netger RangeMax WPN824v2

    VM Network: Bridged Ethernet; Default Adapter

    - XP installs fine.
    - Web pages won't load in IE...
    - I can connect to a server via telnet just fine
    - I can connect to an FTP server, but transfering files DOES NOT work (hangs there, like the webpages)

    - I can ping local IPs
    - I can ping remote IPs
    - I can ping hostnames, too.

    This problem sounds familar from years ago on a Windows setup I had... but I can't recall exactly what's wrong.

    Any ideas?
  2. adamjroth


    Follow up

    More tests:

    - It will transfer FTP files if I connect to a host via IP
    - It will load webpages if I connect to a host via IP

    - Parts of some webpages will load in IE if I use the hostname. For example, I connected to one and the source was visibile.. but the images would not load.

    ...of course this looks like a DNS issue, but I can ping hostnames, so I'm not exactly sure.

    Last edited: Sep 7, 2006
  3. adamjroth


    From a thread further down:

    "Go back to the trick of toggling the ethernet connection (in MAC world) from jumbo (apply) then standard (apply) do this with your guest os running, it will take immediate effect.
    network is working with bridging, running windows update as I type (oh and compressing about 40 mp3s and playing second life while its patching) gotta love the pro"

    Had to do with MTU settings. Works now.
  4. Pleiades


    Bring up a Windows command shell and type in: ipconfig /all

    What do you see under DNS servers? Do you see the ones supplied by your ISP or do you see your router's IP address? Or do you see nothing at all under DNS? Your problem certainly sounds like you're not getting DNS resolution.

    When you say you can ping hostnames, are they hosts on your own network? If so, you may be getting those names resolved through WINS or perhaps a host file.
  5. amin


    I'm not getting internet access on the Mac Pro through Parallels. It's really a shame. Parallels is working so well on my Core 2 Duo iMac.
  6. ojala


    I had the very same problem. Never seen similar problem with either MacOS X or Windows XP installations.

    IP connectivity was there, ping worked just fine with IP or FQDN, also ftp to the local network worked including file transmissions. However anything that tried to do TCP/IP to the Internet failed eventually (FTP connected but transfers didn't work).

    On MacOS X System Prerences / Network changed the MTU from 1500 to Jumbo and back and the XP fixed "itself" inside Parallels. I haven't yet tried if I have to do it every time.

  7. ojala


    .. tried and one needs to change the MTU every time one restarts the WinXP VM.

    I hope Parallels is checking this thread and planning a fix for the final release.
  8. jamez


    Same problem here

    I have the same problem with my macpro as well, nice that I can fix it with changing the MTU, but since it is windows it needs to be rebooted pretty frequently, so that is a pain. Hopefully the next version of the software will address this concern.
  9. TopShelf


    Same problem.

    Mac Pro, 2.66GHz cpus, 1 GB RAM.

    As noted in another thread, I have what you could call sporadic internet access. You could also call it predictably unreliable.

    Google sites load fully and fast. Most other sites (, hang on "Web site found". I have had a few sites load when clicking on links from a google search but in general, no go.
  10. hprice


    Does OS X net work while you're in XP?

    I had the same problem as you all in the XP window but then I noticed that the networking on the host Mac Pro wasn't working to any destination outside my home network.. Changing the MTU on the fly get Windies working OK but it doesn't help with the OS X situation. My Mac is basically off the net. I can however browse shares on other machines at home and even get to an internal web server, but nothing off my local domain.

    It gets worse. The only way I can get the Mac Pro back to normal ops it to uninstall build 1884. No other changes needed. This is a show stopper for me because need to be able to run XP and OS X side by side.

    Anyone seen something similar or got any ideas as to what I could to get the net running on the Mac and XP at the same time. Parallels is definately doing something to the Mac's network config as I get a warning saying "Your network settings have been changed by another application" if I have the ethernet pref pane open when I install 1884.

    Any help, ideas, suggestions would be very welcome.
  11. mikechadwick


    Mac Pro - Get to Google then.......

    I've just installed Parallels for the umpteenth time. First i used it with my macbook pro but it was too buggy, especially with USB devices. Shame 'cos i much prefer Parallels to Boot Camp.
    Now i've got a Mac Pro for home and i thought i'd try Parallels again. Initially it didn't work with the new Mac Pro now, with the latest build, it's fine. Except for (why is there always an except for??) it won't load the net properly. Sure i get Google but agter that no pages load! What gives? i can see i'm not alone with this problem but it doesn't make it any better. i ddn't get any further - presumably there are still the same problems with USB 2.0 devices?
    Parallels people - how can you release a build with such a ridiculous problem? Surely you guys must have tested the new build on a Mac Pro and part of the test must have been checking the net!
    I've just wasted another morning trying to get this program to work for me - why am i bothering? at least Boot Camp works - with no stupid USB 2.0 issues and seamless internet connection.
    Maybe it's time to just give up with Parallels - for me the dream (??) of a virtual machine is nearly over :mad:
  12. mvk


    Networking Semi-Fix

    Mac Pros have TWO ethernet connections. If you plug an active cable into each port (both cables going to a router), you can tell Parrales to use one and Mac to us the other (In Network Prefs make sure the Mac port is listed first - just drag it to the top). The Parallels Network Prefs allows you to select the ethernet port. You may need to set the parallels "MAC" address to the same as the real one on your Mac. Now both connections are independent and you will not loose your Mac connection, particularly if you have to toggle the MTU settings. I have used this with Bridged connections in Paraells. I still occassionaly have to reset the Parralells port due to unresposive internet connections after a while, but I am able to go the the most complex web pages with Citrix tunnels, JAVA and ActiveX controls.

    Having 6 GB of expensive RAM and having to throttle it down to 2 GB so that Paralles is stable makes this an excersize in stupidity. The other issues such as VTx flakiness (turn of sleep on your Mac) make is even more useless. Until they really fix Parallels, Bootcamp has never looked so good.

    Last edited: Sep 9, 2006
  13. bgose


    Your solution worked great!

    I had to do a little creative thinking to get 2 ports but it immediatly let me update windows!

    However, I didn't have 2 connections to the network into the wall so I used a cheapo hub.

    We don't have a DHCP server (we are a workgroup network) so we have to put all the static stuff in to setup our computers for internet access.

    Ethernet 1 was setup for use with the Mac just like the post said,

    Ethernet 2 was setup manually with a static IP address and all that stuff.

    -Sharing is OFF

    -Parallels configuration is set to Bridged Ethernet, and adapter is manually set to en-1 (not default, it won't work under default)


Share This Page