macOS 11.01 not updating to 11.2

Discussion in 'Mac OS X Guest OS Discussion' started by ZBoater, Feb 4, 2021.

  1. JulsS

    JulsS Bit Poster

    Messages:
    56
    Still not working after upgrading the host to Mac OS 11.3. Using Parallels Desktop 16.5 and my guest Mac OS is on 11.2.
    juls
     
  2. RogerZ2

    RogerZ2 Bit Poster

    Messages:
    1
    Same here. Still unable to upgrade. It stucks during upgrade process - white apple logo on black background and progress bar not moving after a while.
    Host: 11.3, Guest 11.2.1
     
  3. Gimbal

    Gimbal Bit Poster

    Messages:
    10
    OK, after 3 months and multiple support tickets, trying various customizations suggested by Parallels support, a Guest VM of macOS 11 Big Sur can now recognize and successfully install Apple Software Updates (on a Host macOS 11 Big Sur). It has something to do with the virtual video adapter setting, apparently.

    The instructions that worked for me (Parallels 16.5, on an Intel Mac running macOS 11.3, with a Guest VM macOS 11.x):
    1. Shut Down the VM.

    2. Add the following 2 boot flags in Configuration > Hardware > Boot Order > Advanced Settings > Boot Flags:
    devices.smbios.board_id=default
    devices.usb.speed.keyboard=high

    3. Find the VM file (.pvm) in your Parallels folder (usually in your User folder):
    - Right-click on the .pvm file
    - Choose "Show Package Contents"
    - Open the "Config.pvs" file in TextEdit
    - Locate the following strings (in my file, around line 454-456):
    <Video VideoMemorySize_patch="1" dyn_lists="">
    <Enabled>1</Enabled>
    <Type>
    2</Type>

    ... change the "Type" value from 2 to 0 (zero), save and close the file, and close the Finder window to get out of Package Contents.
    - Open Parallels and open the VM, and check for software updates, allow to install.

    4. If the VM successfully performs Apple Software Update, then shut down the VM, go back in to Step 3, and change the "Type" back to 2 from zero (so that video in the VM will perform properly).

    Your mileage may vary.
     
    PatrickHartling likes this.
  4. VineRider

    VineRider

    Messages:
    1
    This procedure worked for me. Thanks for sharing this! I updated today from 11.3 to 11.3.1. Hung on the progress bar and I stopped the VM, booted into startup manager and selected Mac OS and booted up to the login screen.
     
  5. PatrickHartling

    PatrickHartling Bit Poster

    Messages:
    3
    @Gimbal Those steps worked for me. Thank you for sharing that.
     
  6. MikeE

    MikeE Bit Poster

    Messages:
    9
    @Gimbal Your instructions worked for me also. Thanks over much.
     

Share This Page