macOS Big Sur and Parallels Desktop

Discussion in 'General Questions' started by IvanD@Parallels, Jun 22, 2020.

  1. Marc Hoffman

    Marc Hoffman Bit Poster

    Messages:
    34
    Just an update: this issue remains even after upgrading Parallels to version 16.
     
    EricW21 likes this.
  2. JulsS

    JulsS Bit Poster

    Messages:
    50
    I see the same behavior after installing v16 tools into a BigSur guest VM. I am running Catalina on the host.
    juls
     
    BenJ1 likes this.
  3. NiklasB1

    NiklasB1 Bit Poster

    Messages:
    1
    This problem was gone after i removed VirtualBox from Oracle from my system and rebooted. I was getting errors from "org.virtualbox.kext.VBoxDrv" when i was watching the log messages from kmutil and kernelmanagerd.
     
  4. mynetx

    mynetx Bit Poster

    Messages:
    2
    Weeks ago, I had upgraded from a macOS Catalina host to macOS Big Sur Developer Beta 1, and Parallels Desktop 15 stopped working, asking to reboot in order to "complete the installation". Yes, the System Extensions preferences panel was granted.

    I was sad and later reverted to Catalina, since none of my Windows and Linux machines were even able to boot, not even the Parallels Control Center showed up.
    OK, I said, let's wait for an update from the Parallels team.

    When I saw the news this morning that Parallels Desktop 16 has full support for Big Sur, I decided to give it a go now. On Catalina, the Parallels Desktop 16 upgrade works fine.

    But after I upgraded to Big Sur (this time Developer Beta 4 20A5343i), I'm, yet again, stuck in the reboot prompt loop.
    I'm a translator, and my software only works on Windows. The promises were set too high, it seems. Humph.
     
  5. DamienB2

    DamienB2 Bit Poster

    Messages:
    27
    UPDATE:

    I now have PD16 running on macOS Big Sur, with some help from PD 2nd line Tech Support. For me at least, the problem was something to do with VirtualBox. Running the uninstall utility in the terminal fixed the problem. The terminal uninstaller utility comes with the installer package.
     
    boyin and mynetx like this.
  6. mynetx

    mynetx Bit Poster

    Messages:
    2
    This helped me too, my PD16 now starts fine. :)
     
  7. boyin

    boyin Bit Poster

    Messages:
    2
    Thanks for your information. Just resolved my problem
    For anyone suffering from "To complete Parallels Desktop setup, please restart your Mac." and if you have install VirtualBox, here is how I resolved the problem:
    1. download VirtualBox package from : OS X hosts
    2. run VirtualBox_Uninstall.tool from the down right corner
    3. start PD16, and good to go, no reboot required
    PS: don't delete VirutalBox app from Finder, that won't work
     
    JARVIS1187 and NathanielM1 like this.
  8. Julio.Bouza

    Julio.Bouza Bit Poster

    Messages:
    7
    Well time to get this to work with VirtualBox lol. I have 2 other apps that leverages VirtualBox on the backend. SIGH.
     
  9. FrederikG

    FrederikG Bit Poster

    Messages:
    9
    can anyone do a Tutorial With Steps How to upgrade correctly
     
  10. JeffreyD5

    JeffreyD5 Bit Poster

    Messages:
    5
    I seem to be able to install v16. When I attempt to launch my VM (WIN 10) and am prompted to enter my license key, web site opens and states that license requires an upgrade ($49.99). The email I received yesterday from Parallels Inc. stated the upgrade was available to me for free. Which is it?
     
  11. AllanH3

    AllanH3 Bit Poster

    Messages:
    1
    I didn't have it installed but I ran it anyway. Still stuck in the "reboot" loop.
     
  12. RichardB35

    RichardB35 Bit Poster

    Messages:
    1
    Here's the deal. Upgrade from v15 of Parallels to v16 this morning. Downloaded the public beta of Big Sur and let Parallels create an .iso of it. (Host machine is a 2019 16" MBP with 16GB RAM and 512GB SSD i.e., base 16" model, running macOS Catalina 15.5.6). Installation of Big Sur as a VM took a while but completed successfully.
    Afterwards I installed Parallels Tools. No matter what I do I cannot get the Big Sur VM to enter full-screen mode. It stays at a resolution of 1024x720, or something like that. Anyone else see this?
     
  13. JulsS

    JulsS Bit Poster

    Messages:
    50
    Others on this thread have reported the same problem.

    juls
     
  14. FrederikG

    FrederikG Bit Poster

    Messages:
    9
    if I want to upgrade via dmg, there is only "parallels starts upgrade" but never finish the installation, any suggests?
     
  15. JanC7

    JanC7 Bit Poster

    Messages:
    2
    Uninstalling Virtual Box helped! It works now!
     
  16. OAW

    OAW Bit Poster

    Messages:
    10
    PD 16 s working fine for me running the macOS Big Sur public beta and a Windows 10 VM. I did the following ...

    1. Installed PD 16 in macOS Catalina first. Launched my Windows 10 VM and verified that it was working correctly.
    2. Upgraded macOS Catalina to macOS Big Sur. Launched my Windows 10 VM and verified that it was still working correctly.

    I should point out that given the initial issues I had running PD 15 on the macOS Big Sur beta on a different machine ... I elected not to try to upgrade to macOS Big Sur on my primary machine at all until PD 16 was released today. So I have not tried any of the various workarounds that have been mentioned in this thread which may or may not be a contributing factor to the issues people are experiencing.
     
  17. MadsJ1

    MadsJ1 Bit Poster

    Messages:
    1
    After installing Parallels 16 on BigSur Beta 4 I am receiving the following error when trying to start a docker-machine vm created with the parallels driver:
    Starting "docker"...
    Your Mac host is not connected to Shared network. Please, enable this option: 'Parallels Desktop' -> 'Preferences' -> 'Network' -> 'Shared' -> 'Connect Mac to this network'


    I check in the preferences and the box is checked, but the issue persists. here is the output from prlsrvctl net info Shared
    Network ID: Shared
    Type: shared
    Parallels adapter:
    IPv4 address: 10.211.55.2
    IPv4 subnet mask: 255.255.255.0
    Host assign IP v6: off
    IPv6 address: fdb2:2c26:f4e4::1
    IPv6 subnet mask: ffff:ffff:ffff:ffff::
    DHCPv4 server:
    Server address: 10.211.55.1
    IP scope start address: 10.211.55.1
    IP scope end address: 10.211.55.254
    DHCPv6 server:
    Server address: fdb2:2c26:f4e4::
    IP scope start address: fdb2:2c26:f4e4::
    IP scope end address: fdb2:2c26:f4e4:0:ffff:ffff:ffff:ffff

    NAT server:

     
  18. Regalian

    Regalian Bit Poster

    Messages:
    1
    Just to add another data point. With VirtualBox installed Parallels 16 on macOS Big Sur Beta would not start and would report that you needed to restart macOS to finish setup. Uninstall VirtualBox and Parallels starts OK. Reinstall VirtualBox and Parallels 16 starts requesting a restart to finish setup again. Uninstall VirtualBox and Parallels 16 starts successfully again. This would appear to point to a conflict between Parallels 16 and VirtualBox
     
  19. CHONGW2

    CHONGW2 Bit Poster

    Messages:
    2
    Hi, I do not have virtual box installed and still keep asking me reboot...
     
  20. SamuelN1

    SamuelN1 Bit Poster

    Messages:
    2
    Honestly, that isn't right that we have to pay again because of a bug fix. I understand if it was for new functionality, but you can't say, "Our fix is you paying more money to upgrade." It should be an update instead. That's why many people are leaving for VMware. I was just about to upgrade to the pro edition as well...
     
    ShkolaI likes this.

Share This Page