macOS Big Sur and Parallels Desktop

Discussion in 'General Questions' started by IvanD@Parallels, Jun 22, 2020.

  1. YouongsooLim

    YouongsooLim Bit Poster

    Messages:
    4
    I have too same problem when input key 't', 'y','1','2'. I can't input 4 letters. But do work when with shift key like T, Y, !, @.
    I am looking forward to wait this solution, at least temporal method. Thanks
     
    BobF2 likes this.
  2. YouongsooLim

    YouongsooLim Bit Poster

    Messages:
    4
    I am looking forward to see solved this,, urgently !! . thank you
     
    BobF2 likes this.
  3. darren3

    darren3 Bit Poster

    Messages:
    20
    I also had an issue where "O" key wouldn't work if hit quickly after another key, i.e. typing "you" quickly the "o" wouldn't work. I used the same trick, mapped "o" to "o" and "u" to "u" seemed to resolve this. Thanks Parallels for helping us out with the Apple beta, etc..
     
    YouongsooLim likes this.
  4. toonetown

    toonetown Bit Poster

    Messages:
    75
    Looks like your menu bar items are missing too...I'm guessing clicking where the clock is supposed to be will crash WindowServer and take you back to login...
     
  5. YouongsooLim

    YouongsooLim Bit Poster

    Messages:
    4
    Oh my!!
    Thanks you for giving hint and resolving that
    That's ok with key mapping, T->T, Y->Y, 1->1, 2->2
    I got it. THANK YOU VERY MUCH
     
    RAnthony likes this.
  6. Peter Witham

    Peter Witham Bit Poster

    Messages:
    9
    Hi all, so I have it working following a lot of what is listed in this thread but the one thing that will kill it from running for sure is installing the Parallels tools. Right now I suggest not installing those, yes the experience will suck with low resolution and terrible performance, but it will at least run. I'd suggest getting it running without the tools and make a snapshot ready for when the tools get updated.

    Just my two cents, that's where I'm at right now.
     
  7. hyph

    hyph Bit Poster

    Messages:
    4
    yes, exactly
     
  8. Carbonideus

    Carbonideus Bit Poster

    Messages:
    8
    Yep, and it happens in Fusion, too.
     
  9. ShikharB

    ShikharB Bit Poster

    Messages:
    5
    I am in a similar boat - installed MacOS Big Sur on my MacBook Pro. Since then I get the "To complete Parallels Desktop setup, please restart your Mac." error, and the same result of needing to Force Quit Parallels, and restarting the machine having no affect on the situation. I have submitted a technical report for this - ID 343418720. Hopefully we can get some information on/a resolution for the issue.
     
    Last edited by a moderator: Jun 26, 2020
  10. SelmaO

    SelmaO Bit Poster

    Messages:
    4
    Here are the solutions for all problems,
    • Before creating Catalina VM don't forget to resize disk size to 80 GB (at least)

    • Format 80 GB disc with using APF format before starting Catalina installation (otherwise you cant use 80 GB)

    • After Catalina VM installation start necessary update from Software Update, version will be 10.15.5

    • Copy "Install macOS Beta" (9 GB SUR installation file) to the Applications

    • Create 2nd Admin user and leave password blank (you will use it while login to SUR)

    • Don't install Parallels Tools

    • Copy current Catalina VM to external disk as a backup

    • Complete below process (run Terminal on the real MAC not VM)
    a. On a real, supported Mac, run this command in Terminal: Code Block
    ioreg -l | grep board-id

    b. Make a note of the board ID (mine is Mac-551B86E5744E2388, for example)
    c. Run this command in Terminal:
    Code Block
    sysctl hw.model

    d. Make a note of the hardware model (mine is MacBookPro14,3)
    e. In the VM configuration, under Hardware -> Boot Order -> Advanced Settings -> Boot flags, enter the following (inserting the information noted above where shown):
    Code Block
    devices.machwmodel="<model>"devices.smbios.boardid="<board ID>"

    at the end of this process,
    You will get two lines like below,

    devices.machwmodel=MacBookPro13,4

    devices.smbios.boardid=Mac-53FDB3D8DB9CA971
    • Shotdown the Catalina VM and put above two lines to the In the VM configuration, under Hardware -> Boot Order -> Advanced Settings -> Boot flags

    • Start Catalina VM again login with standart user (not login with the new created account)

    • Run "Install macOS Beta" from applications (copied SUR Installation file)

    • Wait approximately 45 mins. login with new account

    • Thats all
    Note: In this method you don't need to login apple developer site for verification etc.
     
  11. ShikharB

    ShikharB Bit Poster

    Messages:
    5
    URGENT UPDATE - ID 343418720

    Everyone, positive/good news! I have successfully been able to launch Parallels, and also start up both of my VMs on MacOS Big Sur. The issue was similar to what Garrick1 was facing (detailed this in post #127, if it gets approved by the moderator in time before this one).

    I found traces of VirtualBox dotted around on my machine (had that installed once upon a time). It appears that deleting these traces has allowed Parallels to launch! Additionally, I also executed the suggested steps by TobiasK6 (spctl kext-consent add 4C6364ACXT). Not sure if this also helps, will remove this and try again to check if VirtualBox was the sole culprit. I will report back if the command above has any implications on the issue that I was facing.

    I haven't tested all functionality yet but so far this is my progress report.
     
  12. EricG10

    EricG10 Bit Poster

    Messages:
    1
    I am having the reboot loop issue, this is what I pulled from the logs. no matter what I do, I cannot start parallels.

    06-26 07:10:35.421 F /prllog:2234:6a63/ pdfm-bootstrap: service[2162]: Failed to load kernel extension prl_vnic.kext with error code 1
    06-26 07:10:35.437 F /prllog:2235:6a65/ pdfm-bootstrap: service[2162]: Executing: /usr/bin/kmutil load -p /Applications/Parallels Desktop.app/Contents/Library/Extensions/10.9/prl_vnic.kext -r /Applications/Parallels Desktop.app/Contents/Library/Extensions/10.9
    Error: Error Domain=KMErrorDomain Code=1 "Kernel request failed: (libkern/kext) kext (kmod) start/stop routine failed" UserInfo={NSLocalizedDescription=Kernel request failed: (libkern/kext) kext (kmod) start/stop routine failed}
    06-26 07:10:35.481 F /prllog:2239:6a6d/ pdfm-bootstrap: service[2162]: Loading kernel extensions exit status: 1
    06-26 07:10:35.499 F /prl_client_app:2122:68c7/ [BOOTSTRAP] Services are NOT running (mode=service_start). Exit code is 1
    06-26 07:10:35.503 W /PrlGui:2122:6883/ [MESSAGE_MNG] MessageId={62fd5f41-40a1-4b25-b08d-5cedba49a946}
    06-26 07:10:35.504 W /PrlGui:2122:6883/ Message data: IssuerId=; Code=GUI_ERR_RESTART_TO_COMPLETE_INSTALL; Type=Critical; Spontanous=0; CanBeHidden=0; ForceShow=0; UseActive=0; EventHandle=0x0; DefaultButton=1; Hint=0x0; ReportGenerated=0; Answers=[Restart] [Quit]; Short="To complete Parallels Desktop setup, please restart your Mac."; Long=""; Details="";
    06-26 07:10:35.504 F /PrlGui:2122:6883/ Showing message box. Type = [Critical, GUI_ERR_RESTART_TO_COMPLETE_INSTALL].
     
    Wynter likes this.
  13. markt17

    markt17 Bit Poster

    Messages:
    3
    I installed Big Sur onto an already existing Catalina test machine with Parallels 15 on there already also. Can't start Parallels as all i get is the "To complete Parallels Desktop setup, please restart your Mac."

    Anyone have a solution to this? I don't want to start my OS installs all over again.

    Thanks
     
  14. ShikharB

    ShikharB Bit Poster

    Messages:
    5
    UPDATE #2 - ID 343418720

    I also encountered the '1', '2', 't' and 'y' key issues. The keyboard mapping was required and now the keyboard is fully functional.

    The kext-consent change is not required, VirtualBox is seemingly the only cause of issue that was encountered in my case. This means in my case I reverted the kext-consent change.
     
  15. RamL1

    RamL1 Bit Poster

    Messages:
    8
    I am having a different kind of problem. The upgrade went smoothly after, I increased hard disk space to 90GB. After the upgrade, I get login screen to enter the password. When, I enter the password - it spins for few seconds and I see black screen for few seconds and I am back at the login screen again to enter the password. I am entering right password. If, I enter wrong password the system recognizes and I get message wrong password. Why, I cannot login to Big Sur after the upgrade. It was working fine before the upgrade. Not sure how to fix this issue.
     
  16. gleb_dolgich

    gleb_dolgich Bit Poster

    Messages:
    1
    I managed to install Big Sur in Parallels:
    • Installed Catalina from recovery partition (without Parallels Toolbox!), shut down. NOTE: for the safety of my iCloud data I didn't login to iCloud during installation.
    • Resized disk to 128GB, restarted.
    • Added boot options as described in #25.
    • Removed account password, turned on auto-logon (to prevent login screen failure loop). Restarted.
    • Downloaded and installed Big Sur Beta (it sat at the Apple logo for a while, had to reset the VM to kick installation to continue.
    • At the login screen's password prompt pressed Return, and Big Sur desktop appeared, yay (with missing icons in the menu bar, boo).
    • Installed Parallel Tools, restarted.
    • Back in Big Sur, display resolution is still VGA, no Retina support, as I suspect Parallel Tools aren't fully functional.
     
  17. ShikharB

    ShikharB Bit Poster

    Messages:
    5
    Hi markt17, have you ever used VirtualBox at all? I had used VirtualBox previously and I had traces sitting around on my machine. Cleaning out these traces did the trick for me.

    To clear out VirtualBox content, I just searched for "VirtualBox" (without quotes) and deleted every search result item (I had emails with references to VirtualBox but they are non-consequential).

    Let me know if this is of any help to you.
     
  18. RamL1

    RamL1 Bit Poster

    Messages:
    8
    OK Gleb. I will try the following.
    1. Install OS Cat
    2. Install all the updates
    3. Shutdown
    4. Resize the disk to 90GB
    5. Insert required entry to boot option (boot flag)
    6. Power On
    7. Create additional account without password and remove password for current user that logged in to OS CAT
    7. Run Beta Utility.dmg to check for mac os Big Sur
    8. Download and install
    9. See what happens at first login.....
     
  19. RyanM22

    RyanM22 Bit Poster

    Messages:
    1
    I'm having multiple issues with Parallels on MacOS Big Sur Beta. When loading Parallels I cannot type a 1 or a 2. All other keys work inside and outside of Parallels. Also when shutting down Parallels it crashes and becomes unresponsive. The only way to quit it is to Force quit. I've tried uninstalling and reinstalling multiple times to no avail.
     
  20. markt17

    markt17 Bit Poster

    Messages:
    3
    I never used that and i searched for it and found nothing.
     

Share This Page