MacOS Catalina renders my Parallels useless

Discussion in 'Windows Guest OS Discussion' started by FabianB1, Nov 24, 2019.

  1. FabianB1

    FabianB1 Bit Poster

    Messages:
    1
    Hi there,
    after upgrading to MacOS Catalina (10.15.1) Parallels Desktop (Windows 10) became borderline unusable. The mouse lags and jumps back and forth. The system seems to be super slow (hard to verify with the lagging mouse though). I am using a MacBook Pro (specs attached).

    Anything I can do?
     

    Attached Files:

  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    6,846
    Hi, which version of Parallels Desktop you're using? Did you try to reinstall Parallels Tools?
     
  3. MarcelloR

    MarcelloR Bit Poster

    Messages:
    25
    Same problem here.
    I just upgraded to Catalina 10.15.1 (from 10.14.*).
    PD Desktop (Business) version is 15.1.1.47117
    First start of Windows 10 took a very long time.
    Parallels Tools reinstalled.
    Now the VM is still very very slow. completely unusable!
    I don't know what to do!
     
  4. MarcelloR

    MarcelloR Bit Poster

    Messages:
    25
    I don't know if this can help but I noticed that every time I do an action on the VM (Windows 10), for example I ran an app (Notepad) or start an explorer window or display running tasks, the Finder process on Mac starts an intensive I/O operation on the disk (Read). During this time, Windows freezes; when Finder ends, Windows starts to respond.

    I'm trying many different cases and I have the same issue:
    1. Finder (on Mac) is normal
    2. Switch to VM (Windows); the VM responds
    3. On Windows, start any task (i.e. open Notepad)
    4. Windows freezes
    5. In the while time, Finder, on Mac, starts to take an high disk usage (Read is 13/18 Mb/s, Write is 0)
    6. Windows is stille frozen
    7. Finder end the high disk usage (after some seconds)
    8. Windows starts to respond and show the app

    The described behaviors happens every time I start a new process on Windows.
    BTW: when I start the VM after a shutdown, it took up to 10 minutes to start => very very slow.

    It looks likes that the access to the disk from Parallels Desktop is "filtered" / "disturbed" by the Mac's Finder process in some way.
     
  5. MarcelloR

    MarcelloR Bit Poster

    Messages:
    25
    UPDATE
    Finally, I was able to restore the normal usability of my VM.
    This is not the first time I have issues with macOS and filesystem.
    Following are the (simple) steps that worked in my case.

    ABSTRACT
    I make a backup copy of my PVM file on an external disk; then I delete the original PVM file. Finally I restore the PVM file from the external disk back to Parallels folder. The goal is to enterely rewrite the PVM file.

    IN DETAIL
    1. Backup the .pvm file (in a different/external disk)
    2. Really! Check your backup, there is no plan B if you lose your files. I made three backups of my PVM on three different disks.
    3. Remove the PVM file from the Paralles folder (under Documents). Do not trash it, remove it permanentely.
    4. Alternatively, if you have enough space on your disk, rename the Parallels folder (under Documents).
    5. Run Parallels Desktop and remove the VM from the list of available VMs. Exit from Parallels.
    6. Now restore the PVM file from your backup.
    7. Run Paralles again and add the PVM file into the "Control Center".
     

Share This Page