MASSIVE decrease in performance after upgrading to 3.0

Discussion in 'Windows Guest OS Discussion' started by dschmidt, Dec 11, 2007.

  1. dschmidt

    dschmidt

    Messages:
    3
    Hello-

    I was running Parallels 2.5 very nicely, and recently upgraded to 3.0, and I'm suffering from a massive decrease in performances. Has this happened to anyone else? Are there any changes I could make? I've already tried adding more RAM and Video RAM to the VM, but this didn't seem to help.

    15" Macbook Pro, 2.33 Ghz, 2GB RAM
    OS X 10.5.1

    Upgraded from Parallels 2.5 to 3.0 build 5582

    Help!

    Thanks,
    Dave
     
  2. fbronner

    fbronner

    Messages:
    387
    Hi Dave,

    What kind of VM are you running? If it is XP have you made sure you don't have a runaway service. Also did you make sure you upgraded the parallel tools.

    I find that my XP session feels faster since I upgraded to 5582. So hang in there and lets see what could be happening.
     
  3. dschmidt

    dschmidt

    Messages:
    3
    Thanks for the quick response. I am running XP and the latest Parallels tools (I just reinstalled them to be sure). I also don't see any runaway processes in XP.

    I currently have the VM set to 1300MB Main Memory (used to be 1024MB and it worked fine), Video Memory = 32MB (used to be 16MB and worked fine). I'm driving an external 1680x1050 display as well as the MacBook Pro's 1440x900 display. I also tend to run Coherence.

    Any ideas?

    Thanks,
    Dave
     
  4. MattBaker

    MattBaker

    Messages:
    17
    I may be having the same problem

    I don't want to hijack your thread, but I may be having the same problem.

    I'm on 5582, Leopard, MacBook, XP Home Edition SP2.

    Like you, I'm running an external monitor. I'm primarily in clamshell mode.

    Characters I type on the screen are slow to echo back.

    If I do something more than type (like, for instance, send an email via Outlook 2003), I get the spinning disk of death for five or ten seconds.

    All my memory and other settings are the default values.

    I don't have a runaway Windows process.

    Does this sound like it's similar to your problem?

    Thanks.
     
  5. scotto

    scotto

    Messages:
    33
    I think it's 5582

    I'm getting the same symptoms (spinning disk of death for 5-10 seconds) with small actions (e.g. close an e-mail). But I've doing fine in 3.0 for months. This started happening when I upgraded to build 5582.

    I also have a MacBook Pro and a second monitor; Guest OS is XP under Boot Camp.

    Another detail: Mac OS X 10.4.11
     
    Last edited: Dec 13, 2007
  6. dschmidt

    dschmidt

    Messages:
    3
    Interesting...it sounds like it's build 5582 specifically, not Parallels 3.0 that is causing this performance problem. I upgraded directly from 2.5 for 3.0 build 5582, so I thought it was 3.0 in general.

    Parallels development team: any ideas? It looks like one common thread here is a Mac Laptop with an external monitor and build 5582 (running on either OS X 10.4 or 10.5).
     
  7. Stacey M

    Stacey M Parallels Team

    Messages:
    916
    Hello,

    please try to decrease the amount of memory allocated to your VM ('Configuration Editor' -> 'Memory' tab) and to Parallels ('Parallels Desktop' in menubar -> 'Preferences' -> 'Memory tab').

    Best regards,
    Stacey
     
  8. MattBaker

    MattBaker

    Messages:
    17
    This may or may not be related. When I got to the office this morning, my Mac needed to be rebooted due to a kernel panic.

    I'll try your suggestion to change the memory allocations.
     
  9. scotto

    scotto

    Messages:
    33
    Decrease memory by how much?

    How much of a decrease is the memory allocation are you suggesting? Even some rough guidelines would be a big help. My Parallels Preference is currently set to "Automatic." Should it be changed to manual? Thanks.
     
    Last edited: Dec 14, 2007
  10. jackybe67

    jackybe67 Kilo Poster

    Messages:
    472
    Im working with 512 MB ram and 16 video memory and parallels is very fast.

    MBP 2.4 with 2 gb
     
  11. schulzkeil

    schulzkeil

    Messages:
    7
    Decrease by how much, to what?
     
  12. Stacey M

    Stacey M Parallels Team

    Messages:
    916
    Hello,

    scotto, schulzkeil,
    try to use different combinations of allocated memory.
    Also please tell me how much RAM do you have on your Mac and what amount of memory is allocated to your VM ('Configuration Editor' -> 'Memory' tab) and to Parallels ('Parallels Desktop' in menubar -> 'Preferences' -> 'Memory tab').

    Best regards,
    Stacey
     
  13. NeoDynamic

    NeoDynamic

    Messages:
    6
    Hi All,
    I have had a similar problem and seems to occur when ever there's network activity. For example when I connect through VPN or do a Send/Receive will Outllook 2007 I get the spinning wheel of death for 5 to 10 seconds.

    I'm a developer so I like to have a big chunk of memory available as I always end up using it. I had up until 5582 release used 1.5GB of memory which was the maxium amount for earlier releases. I saw the new limit and thought "yay more memory lets do it". I increased it to 2GB and experienced these problems :(

    I've since reduced the memory back to 1.5GB and it hasn't made any difference. I think I will rollback to 4560 which has been working fine for me.

    My configuration is:
    15" Macbook Pro, 2.33 Ghz Core 2 Duo, 3GB RAM
    200GB 7200 HD
    OS X 10.4.11
    Windows XP SP2
     
  14. NeoDynamic

    NeoDynamic

    Messages:
    6
    Hi All,
    Just rolled back to 4560 and everything is now work AOK. After persisting for a bit with 5582 I found that it might be related to networking however this is only an observation. I saw the whell of death popup for 5 to 10 seconds in VPN on connections (using the standard windows VPN Client), Outlook 2007 on Send & Receive (towards the end of the process) and RPD on connection. It was very repeatable in that every time that I did those tasks I saw the rainbow wheel every time.

    I hope this helps the guys at Parallels. :)

    BTW the 5582 speed was great however the constant interruptions made it unusable.
     
  15. NeoDynamic

    NeoDynamic

    Messages:
    6
    Hi All,
    Just been doing some work and it seems that the issue is persisting even though I rolled back to 4560. I get the wheel of death (aka the rainbow wheel) only sometimes durring send / receives in outlook. It's seems less prevelant in 4560. :(
     
  16. Stacey M

    Stacey M Parallels Team

    Messages:
    916
    Hello,

    please try to decrease the amount of memory allocated to your VM. Please try to use 512 MB and 1 GB and tell me the result.

    Best regards,
    Stacey
     
  17. MattBaker

    MattBaker

    Messages:
    17
    My MacBook has gotten better over the last couple of days. Here are the changes I've made:

    1) Set the VM to 512 MB.
    2) Upgraded from 2 GB of physical RAM to 4 GB.
    3) Shut down Firefox.

    I know Firefox has been hanging at random times ever since I switched to Leopard. On the off chance that Firefox's misbehavior is somehow interfering with the VM, I just stopped using it.
     
  18. MattBaker

    MattBaker

    Messages:
    17
    Of course, as soon as I post the above message that things seem to have settled down, the problem is back!

    I'll try a 1 GB setting and see if that helps.
     
  19. Stacey M

    Stacey M Parallels Team

    Messages:
    916
    Hello,

    please provide me with the following screenshots:
    1. 'Configuration Editor' (Edit -. Virtual Machine) -> 'Memory' tab
    2. 'Parallels Desktop' in menubar -> 'Preferences' -> 'Memory' tab
    3. In Windows open 'Task Manager' -> 'Performance' tab.
    4. In 'Task Manager' -> 'Processes' tab please make the screenshots with all processes.

    Also please tell me if you reboot your Mac and start Parallels will the problem persist?

    Best regards,
    Stacey
     
  20. MattBaker

    MattBaker

    Messages:
    17
    Stacey,

    How do I send the screenshots to you?

    Thanks.
     

Share This Page