Maverics and alt-tab

Discussion in 'Installation and Configuration' started by MikeR., Oct 24, 2013.

  1. MikeR.

    MikeR. Bit Poster

    Hello! Just upgraded to 10.9 last night and I've noticed something different with Parallels v9 since the upgrade. The alt-tab / command-tab do longer gets passed to the windows VMs any more, it switches me to the MacOS application switcher instead.

    My setup:
    Two windows 7 VMs
    Microsoft Natural keyboard
    Option and Alt Keys swapped in the Mac OS keyboard control panel (so "Alt-s" etc become "command-s" in native mac applications)

    Now the Windows-Tab works as alt-tab, but I'd rather not relearn anything (alt-tab is pretty much mussel memory at this point) if I don't have to.

    This has worked great in v6 7 and 9 (I skipped 8) but now the "send system shortcuts" seems to not function...

    Any ideas?
  2. DanielSmon


    I've experienced the same problem. Before the upgrade these keys and shortcuts were passed through to the VM, but now CTRL+Left/Right moves between spaces. Not to mention my function keys which I use in Visual Studio in my Windows 8.1 VM.

    I've sent an email support request to Parallels - waiting to hear more.
  3. BenDean


    I'm also getting the same issue and clicking inside VS to step into code whilst debugging is a pain.

    Please lets us know how support responds.
  4. xz4gb8

    xz4gb8 Bit Poster


    1. Command-Tab has been the application switcher key in OS X for about forever and remains active in Parallels.
    2. If System Prreferences > Microsoft Keyboard > Options has checked: Swap Windows and Alt keys, The Microsoft key labeled Alt acts as the OS X Command key. And, the adjacent key now acts as the OS X Option key. This makes the layout of these keys match the big Apple keyboard.
    3. If this keyboard mapping changed with the Mavericks upgrade, check to see if the Microsoft Keyboard preference pane is installed. The latest version is 8.2.0 (v.305).
    4. If the Microsoft Keyboard preferences is installed, check the Options tab for the Swap Windows and Alt keys setting. Make it as you desire.

    Using a Microsoft Wireless Mediad Keyboard 1.1, the keys work as follows with the Swap option checked:
    OS X Command (MS ALT) - Tab is OS X application switcher
    OS X Option (MS Windows) -Tab is Windows Application switcher
    Unchecking the Swap option (and, possibly, rebooting) will result in the opposite behavior.
    This has worked this way since PDM3 and Windows XP through PDM8 and Windows 8.1.

    Which operating system do you want your muscle memory to serve? Windows or OS X? Since I am primarily an OS X user, Command-Tab is the same on a big Apple keyboard or my MS keyboard with Swap Windows and Alt keys. I have had no particular problem using Option-Tab for Windows task switching.
  5. MikeR.

    MikeR. Bit Poster

    Thats interesting (and the root cause of this post) was that it *was* working (no OS X switcher when the VM had focus) in every version of the OS and Parallels for the last 3 years ... I've not got any special keyboard drivers installed, I just swapped the keys in the default apple keyboard control panel. I spend about equal time in the VM vs native OS, so I appreciated just having the release the focus with ctlr-option keys before using the keyboard to tab away from the VM.
  6. AlokB123

    AlokB123 Bit Poster

    I'm seeing the exact same situation, where Alt-Tab in Parallels worked in OS X 10.8 but no longer does in OS X 10.9.

    I have two laptops in front of me right me right now:
    * 13" 2012 MacBook Pro with OS X 10.9
    * 13" 2012 MacBook Air with OS X 10.8.3

    They each have identical installations of Parallels, with the exact same settings. The major change I put in was remapping "Alt" to "Windows" and "Command" to "Alt". Both machines have this remapping, and both machines are running the same Windows 7 instance in Full Screen mode.

    On the MBA, in OS X 10.8.3, when I switch tasks to Parallels (Cmd-Tab), it stays on the OS X desktop and shows the Parallels Desktop menu across the top. On the other hand, on the MBP, in OS X 10.9, when I switch tasks to Parallels (Cmd-Tab), it directly switches to my Windows 7 desktop. That would be fine, but when I try switching applications in Windows (using Cmd-Tab, which has been remapped to Alt-Tab), OS X 10.9 captures it and brings me back to Finder (the only other open OS X application). On the MBA in OS X 10.8.3, when I'm in Windows in Full Screen mode, switching applications in Windows (again using Cmd-Tab remapped to Alt-Tab), Windows captures it and lets me switch between my open Windows applications.

    I've also noticed that other keyboard shortcuts like Alt-Space that work in one Windows 7 instance (on the MBA running OS X 10.8.3) no longer work in the other Windows 7 instance (on the MBP, running OS X 10.9).

    I'd love any tips for how I can fix this - it basically makes the MBP running OS X 10.9 unusable for me as a Windows machine.
  7. AndreyT

    AndreyT Bit Poster

    I have the same issue: It worked fine with m.lion and 8.1 on parallels 9, then suddenly stopped working right after upgrade to Maverics. I need a solution otherwise it is next to impossible to switch between windows applications. Thanks!
  8. gmetzker

    gmetzker Bit Poster

    Same issue here. Alt-Tab used to be passed to Windows to switch Windows apps. Now it is switching Mac apps. I tried looking for a way to get back to the old behavior but no luck. Any idea if there is a way to force this in the settings?

    Parallels 9 (9.0.23140)
    OSX Mavericks OS X 10.9 (13A603)
    Windows 8.1
  9. DanielSmon


    Hi all,

    For me it's more of an issue that the CTRL and function keys are being picked up by OSX instead of my Win8.1 VM. For example, in Windows I use Visual Studio 2013, and often use CTRL+Left/Right/Home/End to navigate around text, not to mention CTRL+<various keys> which are shortcuts in my Windows applications. These are now picked up by OSX which makes using these shortcuts difficult or impossible to use. I really don't want to have to re-map any of my shortcuts in either OSX or Windows (or Windows applications). I have found some workarounds, which I've included at the bottom of this reply.

    For those of you wondering about my support email, Parallels support did get back to me with the following not-so-useful information:

    As you can see, they provided no information as to whether;
    1. They have been able to reproduce this issue
    2. This in fact a bug or desired change in behaviour

    I indicated that I would like an answer to these two questions in the survey I completed in relation to this support request. It's great that they've escalated it, but we have been left completely in the dark.

    Parallels support - please provide us with some more information as to whether you've even acknowledged this issue. I appreciate an ETA is difficult to provide, but it is useful for us to know whether you can reproduce this issue or not - and whether it is a desired change in behaviour or not. Even if it cannot be resolved immediately, a KB article acknowledging the problem would be great.

    Meanwhile, I have noticed that one workaround for the CTRL key shortcuts is to add the CMD key to the combination. For example, in Visual Studio 2013 to perform a 'Find in files' the shortcut is CTRL+SHIFT+F. Because I have this mapped to something else in OSX, it gets picked up by OSX instead of my VM. Using the workaround, I can press CTRL+CMD+SHIFT+F which appears to send CTRL+SHIFT+F to my VM, triggering the desired action in Visual Studio. The same applies to CTRL+Left/Right, i.e. if I press CTRL+CMD+Left/Right, my cursor in Windows moves backwards and forwards by one work just as it did with CTRL+Left/Right before.

    It is also worth noting that I have my keyboard VM shortcuts profile set to 'Generic', so that no shortcut translation is being done. For those of you experiencing trouble with Alt+Tab being picked up by OSX, I think changing the setting here might solve your problem:
    Screen Shot 2013-11-05 at 15.27.42.png

    Of course, you could also simply modify the Alt+Tab shortcut specifically rather than disabling all keyboard translations. Using this configuration Alt+Tab switches between applications inside my Windows VM, and CMD+Tab switches between applications running on my OSX host.

    Hope this helps some of you.

  10. mourhoon


    Looks like I've found the solution. At least for me :)
    Maverickes introduced a new security feature: access to "Accessibility" (referenced as "Assistive devices" sometimes) is on per-application basis. And it looks like that this "Accessibility" is the thing Parallels uses to hook "Cmd+Tab" (System Shortcuts in parallels) and "Ctrl+something" key combinations. When I've enabled Accessibility for everything began to work again.

    To enable it do the following:
    System Preferences -> Security & Privacy -> Privacy tab -> Accessibility (blue icon). Make sure Parallels is checked in the list. (If everything is grey - it means you should press on lock icon in left lower corner and enter your password).

    Hope it helps
  11. DanielSmon


    Brilliant, thanks mourhoon! That did the trick for me as well. A nice and simple fix - once you know how :)

    Parallels Support - perhaps a KB article should be created to explain this change in behaviour? It would be great if Parallels could attempt to automatically change this setting after prompting the user first. If this isn't possible, I suggest modifying the text in the 'System shortcuts' tab in Parallels configuration to tell the user to tell users tahat they need to change this setting in System Preferences. That way users know that they need to enable this feature in the future.

    Cheers, Daniel.
    Last edited: Nov 7, 2013
  12. MikeR.

    MikeR. Bit Poster

    Nice work! Its working as expected now. I agree this needs a KB! (or an agendum to the existing keyboard shortcut entry)
  13. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Hi All,
    Thank you for your help! Based on your feedback, we've done some testing and created a KB article to cover this type of issues:
  14. gmetzker

    gmetzker Bit Poster

    Setting "Send System Shortcuts" to "Always" re-enables Alt-Tab for me

    The accessibility setting didn't work for me. But I did find something that worked:

    • Go to the Parallels Preferences from the System Menu
    • Go to System Shortcuts
    • For the setting "Send System Shortcuts" change it to "Always"
  15. gmetzker

    gmetzker Bit Poster

    So "Send System Shortcuts" --> "Always" fixes Alt-Tab for me but it breaks another short cut. I have a Logitech MX mouse with a few extra buttons, these buttons I typically use as a Back/Forward in a web browser. I believe they typically send "Alt-Left" or "Alt-Right" keys. These don't work when I set "Send System Shortcuts" to "Always" these only work when I set it to "Never" or "Condition".

    Somehow the new version has Xor-ed me into either the "Alt-Tab" or the back/forward buttons. : (
  16. AndreyT

    AndreyT Bit Poster

    Accessibility worked for me, but logitech mouse is screwed, yes... :(

Share This Page