Memory in FC7

Discussion in 'Linux Guest OS Discussion' started by seebs, Jun 19, 2007.

  1. seebs

    seebs

    Messages:
    19
    Since the forum shuffle lost this:

    I can't boot FC7 with more than about 512MB of memory, even though my host system has plenty (2GB). An older thread suggested the kernel argument mem=nopentium, but that has no effect.

    Anyone know of a fix or workaround? I'd really like to be able to give the virtual machine a bit more memory.

    Parallels 4128, OS X 10.4.9 on a 2.4GHz MacBook Pro.
     
  2. sundancer

    sundancer

    Messages:
    3
    Same problem but with Ubuntu 7.04. The highest setting is 610MB for the virtual machine. I really need more, because I'm developing with Java6 under Linux - the Mac Version has serious problems. :mad:

    This is not satisfying.
     
  3. sundancer

    sundancer

    Messages:
    3
    OK - after getting into it, I found a post with the solution:

    Prevent 'intel-agp' from loading. It works for me!
     
  4. seebs

    seebs

    Messages:
    19
    I can't even get it to work with 576... Seems to be some local variance.
     
  5. sundancer

    sundancer

    Messages:
    3
    It should at least work with 512MB. Then disable (I've blacklisted it) the kernel module intel-agp and you're done.
     
  6. seebs

    seebs

    Messages:
    19
    Mine crashes WAY earlier than modules come into play. Within about a second of the initial read of the kernel from disk.
     
  7. seebs

    seebs

    Messages:
    19
    Ahh, but agp=off in grub.conf has worked. Woo!
     
    Last edited: Jun 22, 2007
  8. dunetse

    dunetse

    Messages:
    1
    agp=off don't help

    how to disable module "intel-agp"

    Thanks
     

Share This Page