Memory integrity in windows 11 pro guest OS / on or off?

Discussion in 'Windows Guest OS Discussion' started by FabianS7, Sep 7, 2022.

  1. FabianS7

    FabianS7 Bit Poster

    Messages:
    13
    i run windows 11 pro guest os on PDM 18.0.1 (53056) on a 2018 intel core i7 mac mini w/ Monterey 12.5.1.

    after installing the latest PDM update, and the subsequent windows os parallels tools, i noticed in the windows 11 os the setting for windows security > core isolation > memory integrity was turned off (see attached screenshot image) (it was previously on, set by me manually and intentionally).

    is this required for my environment? just curious, not really too concerned yet. thanks.
     

    Attached Files:

  2. Mr. C.

    Mr. C. Bit Poster

    Messages:
    62
    Even when you enable it, upon the forced reboot, it is disabled again.
     
  3. FabianS7

    FabianS7 Bit Poster

    Messages:
    13
    interesting. ok. thanks.
     
  4. AndrewL75

    AndrewL75 Bit Poster

    Messages:
    1
    I am having the same issue with Parallels 17 on 2011 iMac Core i5 running High Sierra.
    Any suggestions?
     
  5. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    480
    You might have an incompatible driver that may be preventing it from enabling. I have one myself.
     
  6. DennyK1

    DennyK1 Bit Poster

    Messages:
    4
    Turns off every time after reboot with v18.0.2
    According to windows no incompatible driver
     
  7. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    480
    Interesting.
     
  8. Eduardo

    Eduardo Bit Poster

    Messages:
    12
    Me too. That began a couple of weeks ago, in the days of PD 17.x (for me, at least). PD 18.0.1 show the same problem. No incompatible drivers are detected. If one tries to activate Memory Integrity, Windows requires a reboot. After the reboot, Memory Integrity is off, and there aren't any incompatible drivers.
     
  9. Eduardo

    Eduardo Bit Poster

    Messages:
    12
    ^I meant PD 18.0.1 and 18.0.2 show the same problem.
     
  10. ParallelsU457

    ParallelsU457 Bit Poster

    Messages:
    2
    Same issue here. Windows 11 help text for Core Isolation - memory integrity mentions "you must have hardware virtualization enabled in your system's UEFI or BIOS". Perhaps this is an issue between Win 11 and Parallels 18.0.2?
     
  11. Unauthorized

    Unauthorized Bit Poster

    Messages:
    2
    To activate core isolation you need to enable "nested virtualization" for the VM, see https://kb.parallels.com/en/125195. However, I have no experience about how well this works, so make sure you create a snapshot before testing... ;)
     
    Eduardo likes this.
  12. JaanM1

    JaanM1 Bit Poster

    Messages:
    3
    Same symptoms. Monterey on Intel + Parallels 18.0.2 + W11.
     
  13. DouglasFS

    DouglasFS Bit Poster

    Messages:
    2
    Hey support team, hope you're all well and having a productive one
    Has there been any movement on this, experiencing the same issue here...
     
  14. Unauthorized

    Unauthorized Bit Poster

    Messages:
    2
    Just for reference: Worked for me on Win10 Pro 21H1 and Win11 Pro using Parallels 18.0.2 on a MBP16 with i9-9880H and 64 GB RAM after switching to Parallels hypervisor and enabling "nested virtualization". In the Task Manager it would look like running bare metal with virtualization enabled as opposed to "Virtual machine: Yes". However, performance was significantly worse, it took really long to boot and used more resources.

    OT: Sorry for answering late, my answer was shown as pending for mod approval and I did not see your answers until just now for whatever reason.
     
  15. NigelGB

    NigelGB Bit Poster

    Messages:
    10
    I'm seeing this too:
    - Windows 11 VM
    - I see a security warning. Memory Integrity is off.
    - Memory Integrity requires turning on core isolation
    - I turn it on in the settings.
    - Reboot is required.
    - It is turned off again after reboot.

    Looking at the answers above, the solution is to enable nested virtualisation.
    Selecting Parallels Hypervisor in the VM configuration does not show an option to Enable nested virtualization.

    System:
    - Macbook Pro 13" 2020 Intel
    - OSX Ventura 13.01
    - Parallels 17.1.4 (51567)
    - Windows 11 Pro 22H2
     
  16. DennyK1

    DennyK1 Bit Poster

    Messages:
    4
    Parallels support: switching to the parallels hypervisor (instead of the apple one) solves this.
    I can confirm this works
     
  17. NigelGB

    NigelGB Bit Poster

    Messages:
    10
    Hi DennyK1,
    I had tried that already. It is part of the solution linked previously in this thread.
    That solution suggests that you need to switch to the Parallels Hypervisor then Enable Nested Virtualisation.
    There is no option to Enable Nested Virtualisation as shown on the linked page https://kb.parallels.com/en/125195?

    I have checked again today by switching to the Parallels Hypervisor alone ... it does not fix the issue ... Core isolation is still switched off after a reboot.
     
  18. DennyK1

    DennyK1 Bit Poster

    Messages:
    4
    Hi NigelB6,

    I have the option as you can see in the screenshot.

    kr
    Denny
     

    Attached Files:

  19. NigelGB

    NigelGB Bit Poster

    Messages:
    10
    Hi DennyK1,
    Unfortunately that doesn't help me as I don't have the option as you can see in the screenshot.
    Not sure what it us but I don't have the Extended Memory Limit option either.
    kr
    Nigel
    System:
    - Macbook Pro 13" 2020 Intel
    - OSX Ventura 13.01
    - Parallels 17.1.4 (51567)
    - VM: Windows 11 Pro 22H2
     

    Attached Files:

  20. NigelGB

    NigelGB Bit Poster

    Messages:
    10
    Hi DennyK1,
    Sorry that was the wrong screenshot.
    Windows 11 VM options are the same as you can see in this screenshot.
    kr
    Nigel
     

    Attached Files:

Share This Page