Memory Leak in 5.0? Or what else could this be?

Discussion in 'Windows Guest OS Discussion' started by ionblue, Nov 10, 2009.

  1. ionblue

    ionblue Bit Poster

    Messages:
    26
    I'm not even sure how to describe this briefly, so I'm just going to explain as best I can. In WinXP with a recently upgraded 5.0 Parallels, I keep having problems with striking normal keys and then minimizing one or all the running Windows programs. Literally, I'll be typing something, hit a letter, and BOOM - the program minimizes to the dock OR all the open programs minimize.

    The first time this happened I figured I hit something weird key combination and locked the VM up or something. So I closed all programs via the menu and rebooted the VM. All was well again.

    The same exact thing happened again today after several hours working - about 6 hours (hence my thought of a memory leak) back and forth with WinXP and OS 10.5.8. This time I continued to try and type in Windows in IE or VS and nothing worked. Also, in IE which was running nice and quick was all of a sudden crawling and unable to refresh (again, I couldn't type so I just clicked refresh).

    All the while this was happening, I didn't see anything unusual happening in my Activity Monitor in the Dock and I had no problems switching to a Mac program and typing. So I again shut the VM down and I'm sure all will be well when I boot into it tomorrow - but I'm also sure that after several hours of running the VM it's going to up and do whatever you call this behavior.

    Does anyone have any idea what this could be? System problem? Parallels bug?

    Thanks.

    Anthony
     
  2. KonstantinO

    KonstantinO Parallels Developers

    Messages:
    36
    Please, create problem report and send it for us (menu -> Help -> Report a Problem), post ticket # here.
    May be this is stalled modifier key (CMD or ALT) -- several key press and release can help.
     
  3. ionblue

    ionblue Bit Poster

    Messages:
    26
    Done: ticket# 798979

    Hope this helps.
     
  4. ionblue

    ionblue Bit Poster

    Messages:
    26
    You may be right about the modifier keys. I had something similar happen today and every time I hit "r" it would open the run window. I hit "option" several times and it un-stuck. Maybe I should turn off the keyboard mappings and just run with Windows native shortcuts?
     
  5. CharlesR

    CharlesR Bit Poster

    Messages:
    4
    Happens to me at least once a month in Windows, and I use full blown Windows I'd say about 60-70 hours a week. Restart the VM and see if it continues.
     
  6. STEVEN J

    STEVEN J

    Messages:
    3
    this problem occurred for me last night for the first time, the r key would open the Run command, very bizarre. Parallels Rev 5, Windows 7.
     

Share This Page