Mouse clicks stop working in guest OS

Discussion in 'Windows Guest OS Discussion' started by billpatt, Apr 13, 2018.

  1. billpatt

    billpatt Bit Poster

    Messages:
    5
    I have a MacBook Pro 15" Retina. I'm currently on Parallels Desktop for Mac 13.3 and macOS 10.3.4, but this problem has been consistently present since macOS 10.2 and Parallels 11.
    After I've been working in Windows 10 Guest OS for a few minutes, it will stop responding to mouse clicks, left or right. The cursor still moves, but I can't change focus or activate anything. The trigger is a mystery, but generally happens when I have been working in the host OS and return to the guest.
    Restarting the guest OS fixes it, but the easier solution I've found is to switch to the host OS with the guest window in the background and move the cursor back and forth over the guest window. This triggers "big cursor", a feature of macOS used to find the cursor. This resets the issue in the guest OS.
    Reinstalling Parallels Toolbox doesn't help, and the new Toolbox seems to have made the problem worse.
     
  2. RandyB3

    RandyB3 Bit Poster

    Messages:
    6
    This has been happening to me too for some time and it is interfering with my ability to work. I have High Sierra version 10.13.4 on MacBook Pro Retina 13-inch Early 2015 running Parallels Desktop version 13.3.0 (43321). I am using it in clamshell mode with a 4K monitor and a 2K monitor attached. I have a USB mouse and keyboard attached. I've had Mouse & Keyboard | Mouse at each possible setting, Mouse & Keyboard | Advanced Settings all off, Boot Order | Advanced Settings Boot flags with and without 'device.usb.mouse=0'. Two or three times a day the mouse stops responding in the VM but responds when I release it back to the MacBook. The VM continues to respond to the keyboard okay. The only resolution is to shut down the VM and restart it. I am able to use Microsoft Remote Desktop from the MacBook to remote to the Parallels VM and the mouse works okay but the appearance and responsiveness is less than optimal. Pausing or suspending it and resuming does not work. Another odd behavior is that a couple times a day it goes into a right-click loop in the VM, i.e. if I right-clicked on something it starts doing that rapidly and endlessly until I use Ctrl-Alt-Delete to bring up the Windows Task Manger and then it stops. I really don't want to but it may be time to consider switching to a different platform for my Windows 10 development machine.
     
    Last edited: Apr 13, 2018
  3. billpatt

    billpatt Bit Poster

    Messages:
    5
    RandyB3, thanks for the feedback. You are seeing the same issues as me. I didn't mention something that may be a contributor to the issue. I don't run in clamshell, but I do use Apple Remote Desktop to view my MBP screen on my iMac 27". I just picked up a possible workaround better than mine or yours. Open the Force-Quit window on the host machine. Close it, without quitting anything. That seems to resolve the click issue for me.
    Parallels people, if you're watching this thread, I'd be glad to work with your developers to debug this issue. I've been a Mac developer for 27 years, and a Parallels DT user since it came out.
     
  4. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    117
    Hello billpatt, Parallels Toolbox is different from Parallels Tools, Parallels Toolbox is a separate bunch of applications so for the above mentioned issue,
    let us ensure that Parallels Tools are properly installed. Please follow http://bit.ly/1jbXVsI to install Parallels Tools. If you see reinstall or update Parallels Tools then kindly reinstall it.
     
  5. RandyB3

    RandyB3 Bit Poster

    Messages:
    6
    I just reinstalled it, restarted the VM, worked about five minutes and then the mouse quit responding again. That is not the solution. Any other ideas please?
     
    Last edited: Apr 14, 2018
  6. RandyB3

    RandyB3 Bit Poster

    Messages:
    6
    I'm not sure what you mean. Force quit Parallels DT? That would seem to be a temporary fix as is restarting the VM and Parallels but not as kind to the guest OS. Or did you mean do that once and it's a permanent fix? Thanks for clarifying.
     
  7. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    117
    Hello RandyB3, kindly go to the top menu bar, click on Actions--> Configure--> Hardware--> Mouse & Keyboard and set the Mouse option to "Don't optimize for games" and check if it helps.
     
  8. RandyB3

    RandyB3 Bit Poster

    Messages:
    6
    That has been off and hasn't helped.
     
  9. billpatt

    billpatt Bit Poster

    Messages:
    5
    AJ@Parallels, this issue predates Parallels Toolbox. As I said above, it has existed since Parallels 11. Yes, I have updated the Tools numerous times, but this does not effect the issue. Thanks for the response though.
     
  10. billpatt

    billpatt Bit Poster

    Messages:
    5
    RandyB3, here's what I mean about the Force-Quit window:
    On the host machine, select the "Force Quit..." item from the Apple menu. Close the window without doing anything else.
    I've only tried this a couple times, but it seemed to resolve the issue temporarily. Murphy's Law, now that I'm trying to test the workaround, I can't make it misbehave.
     
    Last edited: Apr 16, 2018 at 1:55 AM
  11. RandyB3

    RandyB3 Bit Poster

    Messages:
    6
    Ah I see, 'close the Force-Quit window'. I'll give that a try. That sounds like a possible corollary of using Ctrl-Alt-Del in the Windows client to get out of the right-click loop that happens to me occasionally. I've avoided coherence mode in the past but I'm giving that a try to see if it matters.
     
  12. RandyB3

    RandyB3 Bit Poster

    Messages:
    6
    Well, I'm grasping at straws. Coherence mode went one full day and most of another before it stopped responding to mouse clicks. That's much better than Full screen view had been but not good enough. I tried opening and closing the Force Quit window when it occurred in Coherence mode but it didn't help any. Alas.
     

Share This Page