mouse pointer positioning issue

Discussion in 'Windows Guest OS Discussion' started by TabSel, Jun 13, 2016.

  1. TabSel

    TabSel Bit Poster

    Messages:
    10
    1) MacBook Pro 15" Retina, late 2013, MAC OS X 10.11.5, Parallels Desktop 11.2 latest build, Windows 10 Bootcamp based VM, up to date as of today; Mac OS X main Screen Resolution "scaled" (1920x1200), "Monitors have separate spaces"
    2) VM Configuration: Resolution scaled (1920x1200); Mouse/Touchpad & Keyboard "optimized for games", VM running in OS X compliant Fullscreen (own Space "Parallels Desktop" @ MacBook main screen); All Screens running VM Fullscreen; Parallels Tools in VM up to date.

    3) working in Windows VM (mouse/keyboard captured), VM mouse pointer Location on Screen @ x1/y1, then leaving space/switching to a Mac Desktop Space with 4 finger swipe,
    => Mouse gets "uncaptured", Mac mouse pointer stays at the Location on screen @ x1/y1, where it was on Screen in the VM, ok

    4) moving Mouse pointer with Touchpad tap/drag to a different Position, say x2 = x1+100 Pixels to the right, y2 = y1+200 px downwards

    5) switching back to the "Parallels Desktop" space via 4 finger swipe
    => Mouse does NOT get captured by the VM, Mac OS X mouse pointer stays at the Location as in 4)
    (in my opinion, when running the VM Fullscreen, the mouse/Keyboard could be captured automatically, as it is "uncaptured" automatically when switching to Mac OS X space as in 3)

    6) tap(=klick) touchpad for the mouse/Keyboard getting captured by the VM
    => expected behaviour: VM mouse pointer is set to Location x2/y2 of the Mac OS X mouse pointer
    actual behaviour: VM mouse pointer jumps back to the Location x1/y1 the VM was left in 3)
    bug?

    7) now begin moving the VM mouse pointer via touchpad tap/drag
    actual behaviour: VM mouse pointer again jumps to another Location which seems to be calculated by the Delta of x1/x2 and y1/y2, ie, the mouse pointer jumps to Location x3 = x1 - x2 (100 Pixels to the left), y3 = y1 - y2 (200 Pixels upwards) before it begins moving according to the touchpad drag

    Can anybody confirm?

    (I can not work this way: on capturing/moving the VM mouse pointer, it jumps wildly around, sometimes it jumps to a different Monitor, I can NOT set "don't optimize for games" (mouse Location behaviour is consistent then), as I use a Windows application (Cakewalk Sonar) which requires "optimize for games" in order to reliably move onscreen controls (faders/knobs) with the mouse)

    (Also, the Mac OS X Setting "Accessibility / Mouse & Touchpad / Trackpad Options : checked "enable dragging"/"with drag lock" interferes with the captured VM mouse pointer - expected behaviour: this Setting has no influence to VM mouse pointer)
     
  2. defender007

    defender007 Bit Poster

    Messages:
    1
    What system are you on? Did you try restarting the game after changing its resolution?
    Maybe toggle the mousecursor option in the menu to use the system one.

    Lto 4 tapes
     
  3. TabSel

    TabSel Bit Poster

    Messages:
    10
    Did you even read the question? Systems mentioned, configurations mentioned...
     
  4. TabSel

    TabSel Bit Poster

    Messages:
    10
    Hello parallels? Can you reproduce? Any clues?
     
  5. TabSel

    TabSel Bit Poster

    Messages:
    10
    It's way easier to reproduce:

    configure VM to touchpad: optimize for games, run VM full screen, click VM to have mouse captured. Release mouse via alt-ctrl shortcut, move mouse, click again to have mouse captured.
    The mouse pointer jumps, and jumps again upon beginning to drag mouse pointer.

    Anybody else?
     
  6. Raj@Parallels

    Raj@Parallels Guest

    Messages:
    467
    Please try installing/reinstalling Parallels Tools followed the steps then follow this article for mouse issue in playing games.
     
  7. JoseA2

    JoseA2 Bit Poster

    Messages:
    5
    Hello,
    I have been a Parallels user for 4 - 5 years. Each year upgrading to the latest version, everything had worked spectacularly until this latest version of Parallels 12 with Windows 10 as guest system.
    My system is:
    MacBook Pro (Retina, 15-inch, Late 2013)
    2.3 GHz Intel Core i7 16 GB RAM
    Mac OS Sierra 10.12.3
    Parallesl Desktop 12 for Mac Pro Edition Version 12.1.3 (41532)
    Windows 10 Pro Version 1607 Build 14393.693

    I have this same problem, my Virtual Machine is not able to get the focus on the system, it is necessary to click or tap to acquire it.

    I have followed the indications of this and other forums to configure the 'Do not optimize for games option', reinstall Parallels Tools and nothing has worked.

    It is extremely inconvenient to have to be clicking to get the focus on the Virtual Machine, even more when you are in a writing application such as Outlook or Skype for Business (Lync)

    Please help!
    Best regards.
    Alejandro.
     
  8. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    You may check out this article to fix the issue: Go to Hardware > Boot Order > and paste in Boot Flags box: video.hw_pointer=0 and let us know how it works.
     
  9. JoseA2

    JoseA2 Bit Poster

    Messages:
    5
  10. Swati@Parallels

    Swati@Parallels Kilo Poster

    Messages:
    360

Share This Page