Mouse Problems - P12 - Host MacOS Sierra - Guest OS X El Capitan

Discussion in 'Mac OS X Guest OS Discussion' started by BenJ2, Jan 18, 2017.

  1. BenJ2

    BenJ2 Bit Poster

    Messages:
    4
    Hi all,

    System:
    Macbook Pro (Retina 13-inch Early 2015) 16GB RAM
    Magic Mouse 2
    Thunderbolt Display 27"
    Host OS: MacOS Sierra 10.12.2
    VM Guest OS: OS X El Capitan 10.11.6, 2 CPU, 4GB memory, 256MB video memory, Resolution setting: Scaled
    Parallels 12.1.1

    Since upgrading to Parallels 12 I've had a few different mouse issues. They're irritating, rather than catastrophic, but it would be nice if they could be resolved.

    First, I used to be able to move between the VM (VM is always in full screen mode) and the host and have the mouse focus follow automatically. Now, I often have to go back to the VM, click the special key combo to release the mouse from the VM and then go back to the host. My setup is such that I run multiple desktops that I swipe between and I treat the VM as another desktop (hence the full screen view). Just to be annoying, this doesn't always happen - just frequently.

    Second, and this one has only started fairly recently, I'll be working away in the VM and suddenly the mouse will not interact with any of the screen elements in the VM any more. I know the focus is still in the VM because, if I was working in a text file, for example, I can still type in the file. But I can't click on anything, move any of the windows around, click any menu items, etc. It even happened once when a drop-down list appeared and I couldn't select anything in the list. I can still move the mouse cursor around, though. On one occasion even the keyboard stopped working in the VM, but that's only happened once. I use a Magic Mouse 2 and it's never a problem in the host OS. When I've had the problem I've also tried to use the trackpad and the result has been the same: can move the mouse, but can't interact with anything.

    I've been able to work around the second problem by toggling the "Optimize for games" setting under the Configure > Hardware > Mouse & Keyboard settings for the VM. It's typically set to "Don't optimize for games". When this issue happens I switch it to "Optimize for games" and then it works again, more or less, except that scrolling then works backwards (ie. not the Mac "natural" way any more) and the pointer is sometimes slower to move around. When I have a break I'll usually reboot the VM and set the mouse back to "Don't optimize for games" and it will work again.

    I have tried re-installing Parallels tools, but that didn't help.

    Any help or input appreciated.

    Cheers,
    Ben
     
    AndrewL10 and BasilB1 like this.
  2. DavidV6

    DavidV6 Bit Poster

    Messages:
    1
    I have problem #2 in spades: I probably hit it 3-4 times / day. The quickest work around that I have found is to suspend the VM and then restart it. the mouse comes right back to life.

    The other bug that I hit daily is using a track pad with this configuration. It is essentially not usable, and I have not found a workaround (other than to not use a track pad).

    I have reported both of these bugs to Parallels, but Mac OS VM on a Mac OS Host is not a configuration that they seem to care much about. I have tried the same configuration in Virtual Box. It works like a champ.
     
    BasilB1 likes this.
  3. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,142
    Hello Ben, please be informed that Parallels Desktop 12 Update 12.1.3 (41532) was released. Please update Parallels Desktop to the latest build (Please note that Parallels Tools also needs to be updated (Actions > Update Parallels Tools)) and let us know how it works.
     
  4. BasilB1

    BasilB1 Bit Poster

    Messages:
    4
    Nope, problem still exists in Parallels 12.1.3. Happening to me repeatedly (mouse pointer visible within VM but with no effect) when switching from guest-macOS to host-macOS and back. This bug makes Parallels useless to me.

    Running Sierra 10.12.3 on both guest and host.

    I posted to apple.stackexchange.com.
     
    Last edited: Feb 4, 2017
  5. DanE1

    DanE1 Bit Poster

    Messages:
    1
    I am having the same issue and have noticed it on both 10.12.3 Guest OS as well as 10.11.6 Guest OS.

    I am running on Macbook Pro 15" Mid 2014, 16GB RAM, 2.5GHz i7, using the built in trackpad.
     
  6. BenJ2

    BenJ2 Bit Poster

    Messages:
    4
    Hi Paul,
    Thanks for the heads-up. Unfortunately, like BasilB1 above, the problem has not been resolved. After the update, the problem seems to occur less frequently, but it still occurs.
    Ben.
     
  7. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,693
    Hi guys, please try this Bootflag
    devices.usb.mouse=0

    And let us know how it works.
     
  8. BenJ2

    BenJ2 Bit Poster

    Messages:
    4
    Hi Maria,
    That didn't work at all - now there is no mouse pointer in the VM. Can't use the Magic Mouse or the trackpad on my MBP.
     
  9. AhmedH3

    AhmedH3 Bit Poster

    Messages:
    4
    I have this problem too. the guest mac starts normal and after a while the mouse stops clicking while it apears and moves normal.
    I installed linux elementary OS vm where the mouse is completely invisible.

    please respond.
    I'm running parallels dektop pro edition for mac on macOS Sierra
     
  10. Flint_6

    Flint_6 Bit Poster

    Messages:
    5
    Same problem here. I have latest Parallels Tools and Parallels 12.1.3, but Guest OS is Sierra. I lose trackpad control. Trackpad won't interact with any elements on the desktop. However, when I switch out of the VM, trackpad works fine, but not inside the VM. It also happened with the keyboard already, where the mouse would work but the keyboard would not take any commands within the VM (and only there). Host os is also latest Sierra 10.12.3.
     
  11. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,142
    Hi, we need a bit more information from you. Could you please generate the problem report using this KB and reply with the report 8-digit ID number. Please generate the problem report right after reproducing the issue.
     
  12. PeterD11

    PeterD11 Bit Poster

    Messages:
    1
    Same problem here, each time within minutes of starting the VM. Host and client running macOS 10.12.3; Parallels Desktop 12.1.3 (41532); MacBook Pro Retina 15 late 2013, 2,6 GHz i7, 16 GB RAM, Intel Iris Pro and NVIDIA GeForce GT 750M. I tried the following without success:
    - bootflag "devices.usb.mouse=0"
    - reinstall Parallels Tools
    - external USB mouse
    - additional video memory (now 512 MB)
    - bridged instead of shared network
    - mouse optimize for games (very slow and stopped working too)

    Restarting the VM works for a few minutes. Not long enough to get my work done...
    Moving the same macOS 10.12.3 VM to another laptop running OS X 10.11.6 and Parallel Desktop 10.4.0 seems to have better results (but that is my old environment that I will get rid of, I cannot continue to use this). Parallels Tools was installed again for this environment. As far as I have seen, the mouse seems to work stable in this configuration.

    I did not have time to try using an El Capitan virtual machine on a Sierra host using Parallels Desktop 12.

    Can you please advise on a temporary solution until this problem is fixed? Do you have an estimate on how long it will take to have this problem solved in an update?

    Thanks, Peter
     
    AndrewL10 likes this.
  13. RainerH2

    RainerH2 Bit Poster

    Messages:
    2
    I have had this problem occasionally from some time, and sometimes the mouse worked and the keyboard became unresponsive. P13 (13.1.0) did not make a difference.
    I migrated to a new MBP yesterday, installed it from scratch (no migration assistant) and found that the problem now is happening so frequently that I have to reboot 2-3 times per hour. I guess that the automatic pause mode has something to do with it - I found the mouse stuck a few times after the wake-up from pause. Suspend/resume did not help anymore - this did help usually on my old MBP.
    I do most of my work in VMS - a fix would be very helpful.
     
    Last edited: Oct 11, 2017

Share This Page