Mouse Sync, Keyboard - The Solution

Discussion in 'Windows Virtual Machine' started by bgrau2020, Jun 19, 2007.

Thread Status:
Not open for further replies.
  1. bgrau2020

    bgrau2020 Bit poster

    Very simple really:
    You must make sure that the keyboard driver does not conflict with the Parallels Mouse Synchronization Tool driver.
    So update the keyboard driver in Device Manager making sure you use the default Microsoft PS/2 keyboard: PC/AT Enhanced PS/2 Keyboard (101/102 Key).
    This would then allow you to use keyboard/mouse properly.
    On my trial version, I could not use either! until i went back to last configuration that worked, then after fooling around a bit, I sussed this out.
    Also the Mouse Synchronization pane in Tools Center will be available.
    Its unfortunate that tempers flared on this one, with the solution being so simple (driver conflict)...
    Thank you for the Fish :)
  2. Rachel Faith

    Rachel Faith Hunter

    Welcome to the forum.

    I am glad that YOU found a solution to YOUR conflict and that it was a simple driver conflict.

    However, that is NOT the case with my problem. I tried your combination of updating the keyboard and this indeed worked... for the few seconds before the reboot. After the reboot, as with 1000000% of all the other driver and reinstalls attempted, the problem returned anew the first time the unit was restarted.

    So to recap, there are now FOUR ways to trick the unit into working for any one session of time... and NO FIX that will actually make it work "from then on" as it is supposed to work.

    Now, while your reported personal success is worthy of sharing with the group... please, do not purport to speak for the entire effort as you have no way to know if your workaround is actually going to be effective.

    It would be far better to simply post the facts of your situation and allow the others with similar problems to discover for themselves if indeed the information is of any value.

    Kindly so,
  3. bgrau2020

    bgrau2020 Bit poster

    Thank you for welcome

    Wow Rachel dear, you are angry... :)
    So far, I have been on Coherence for 5 hours+, and no sign of collapse...
    The thing I didn't emphasize was that you must also ensure you have the Parallels Mouse Synchronization driver installed, for me I had to do that manually, same as for keyboard.
    If you are interested in the background of my installation, mine was a VM imported from a Microsoft Virtual PC, and it kept the drivers keyboard/mouse of that VM. These worked but without the pointer integration thing.
    When I installed the Tools, it kept the MS VPC keyboard driver and installed the Parallels Mouse driver, this is what caused my conflict so I could not use the Parallels VM anymore, so I had to reboot, F8 and chose Last best configuration, which put back the Mouse MS VM driver.
    So after that I had the idea to install manually a generic mouse driver (what best than Microsoft default PS/2 one), and install manually the Parallels Mouse Synchronization driver that is located in the Tools folder in Program Files of the Guest OS...
    I crossed my fingers and rebooted, it worked :)
    I hope you find your solution...
    Take care dude, and keep smiling ;)
  4. Rachel Faith

    Rachel Faith Hunter

    First, this is text, therefore any impart of emotion is projection. Please take care not to comment on my or anyone else's emotional state when it is impossible to tell without narrative, she said contemptuously. See?

    What If I would have said, she said with eyes rolling.

    A totally different state of emotion for the same unedited text.

    Second, I am a dudette not a dude, dude.

    Third, I am not ignorant and I fully understood your particular conflicted drivers situation. I checked my drivers first. I had the correct keyboard AND mouse drivers. I always have. I was going to try and uninstall the keyboard driver, but that was not an option, only the update as your post suggested.

    That had no effect.

    So I then upgraded it again and removed the parallels mouse driver and that worked. Until of course, I had to reboot and install the mouse driver. In which case it reverted to the previous non functional state.

    I have done these installs in various combinations, manually and with the tools.

    Simply stated there is a problem with the drivers in general that manifests itself with these similar but different mouse / cursor conflicts.

    Now as a final disclaimer, this entire post is written in neutral language without any emotion conveyance. If you have further doubts from your own projected imaginary emotions, try reading this with a mock Monty Python accent. Perhaps that will calm YOU!

    Good day.
  5. bgrau2020

    bgrau2020 Bit poster

    good luck

    OKi, I understand, dudess (I thought dude was gender free like -ya 'man-).
    Anyways, i prefer Mr Bean to Monthy Python... and thanks...
    I can see from your Sig that u have some experience with a few O/Ses...
    Hopefully, technical support here will come up with new keyboard/mouse drivers that work for every possible setting...
    For me mouse pointer integration is important, otherwise i would not have dug deeper to get it working on my system.
    If you only want mouse capture, maybe there is a mouse driver you can choose from the choose driver list when doing a driver update which will do the trick, not acceptable from point of view of support as you paid for mouse integration, but at least for now you will have a workable OS environment.
    For Coherent, its not good if mouse integration is absent as the mouse will have a tendency to disappear and create artifacts.
    I am not Technical Support, and just wished to share my experience in case it will help...
    actually I registered to this forum only for that aim...
    Cheers dudess ;)
    take it easy ... but, take it :D
  6. Rachel Faith

    Rachel Faith Hunter

    Thanks for the neutrality this time. Truly. As for coherence, you are correct, when I try it, I am HOSED BAD as the mouse vanishes completely and I was forced to cold quit Parallels entirely. I want only the correct performance and the bug fixed. The various workaround's are nothing more than horrid unacceptable temporary inconveniences. Perhaps your solution will work for some and if folks are having this problem and have the time to try all the various fixes, God speed them in doing so. There is nothing else for us to do but try until TPTB find the problem and fix it in a release or post instructions.

    Last edited by a moderator: Jun 20, 2007
Thread Status:
Not open for further replies.

Share This Page