MS-DOS 6.22 "move" command fails??

Discussion in 'Other Virtual machines' started by cepheid, May 13, 2016.

  1. cepheid

    cepheid Junior Member

    Hi, I have an MS-DOS guest OS that I created under Parallels 6. It worked fine under Parallels 8 when I ran OS X 10.9 (Mavericks). However, when I upgraded to OS X 10.11 (El Capitan), I am now getting strange errors -- commands that used to work no longer work. For example, the ASSIGN command which worked perfectly fine before is no longer working, I get "bad command or file name." Similar, the MOVE command -- which is BUILT IN -- is giving me the same error, "bad command."

    I tried creating a brand new MS-DOS OS using the instructions here ( That brand new OS gives me the exact same error when trying to use the built-in MOVE command -- "bad command or file name." I tried this under Parallels 11, in case v8 was causing problems, but the same error continues.

    Why is this happening and how can I fix it? I have a DOS program that I absolutely have to run...

    How can a _built_in_ command fail?!

    (Note: the RENAME and COPY commands work fine, but MOVE does not. I absolutely need the ASSIGN command, which is installed as part of the supplemental 6.22 disk, but that installer won't work without the MOVE command, either!)

    Any help is greatly appreciated.
  2. cepheid

    cepheid Junior Member

    I should note: this error occurs even if I boot from the MS-DOS install disk! That is, the "move" command won't work even when booted from the clean install disk! (The install disk was downloaded from, as in the instructions in the KB article.)

    So, unless the OS on the ISO itself is bad, this has to be a Parallels problem somehow, no? (Especially since I had an OS that worked just fine under Parallels v6, v7, and v8 under OS X Mavericks, and stopped working with the exact same Parallel 8 under OS X El Capitan.)
  3. DustinHullett

    DustinHullett Product Expert

    Just to start with the basics,
    have you reinstalled parallels tools?
    What are you configuration settings?
    Is the VM isolated from the mac?
    Please post back and i will try my best to help. Thanks

Share This Page