MS-DOS 6.22 Printing Questions

Discussion in 'Other Virtual machines' started by StevenB2, Aug 31, 2015.

  1. StevenB2

    StevenB2 Bit poster

    I have MS-DOS 6.22 installed in a VM under OS X Yosemite and Parallels 11. In the hardware setup, it lets me add a printer, but that's all the guidance I have. I set up "Printer 1" with a source of "Default Printer", but the Port is grayed out and unselectable, and when I try to print from WordPerfect DOS to LPT1, nothing happens.

    I assume that I need to set up a postscript driver in WordPerfect regardless of what printer I'm using. Other than that, I don't know where to go from here.

    Attached Files:

  2. raneil01

    raneil01 Bit poster

    I'm having a similar problem since upgrading to Parallels Desktop 11 (I'm still evaluating the trial version). It worked fine under version 7. If the host printer is set to any physical printer connected to the Mac (host), no output is produced at all when attempting to print from MS-DOS.

    If the host printer is set to a file, the output is sent to the file as expected, but it contains garbage characters at the beginning of the file, and is missing characters at the end of the output.

    As a test, I created a new virtual machine with MS-DOS 6.22. In the Source popup menu for Printer 1, I selected a file (~/Documents/Parallels/lpt1.txt).

    From the DOS prompt, I sent a directory listing to PRN:

    The resulting output file (as seen in TextWrangler) shows garbage characters at the beginning of the file, and the last line of the output is missing:

    And it gets worse. Subsequent attempts to print from DOS result in duplicate output of all previous output prepended to the current output, making a complete mess of the output file.
  3. cepheid

    cepheid Junior Member

    v8 printing from DOS worked OK to a text file. v9 and higher broke DOS printing. When using PDFWriter as the printer, v9 will print a blank page; v10 and v11 will not print anything at all. When using a text file output, v9 through v11 will cause one of my DOS programs to print hundreds of the same page (into the text file). What should have been about 1 KB of output becomes 5 MB...

    Parallels Support, is there anything that I can do to help you resolve this printing issue from DOS? Printing to a real printer, to PDF, or to a text file is now COMPLETELY unusable -- printing to PDF or a printer doesn't work at all, and printing to a text file generates hundreds of copies of the same output all appended to one another.

    There HAS to be a solution... it worked fine in v8. Is there any way to restore the printing functionality of v8?


Share This Page