My experience upgrading to 3.0 Vista Bootcamp

Discussion in 'Parallels Desktop for Mac' started by Zenara25, Jun 9, 2007.

  1. Zenara25

    Zenara25

    Messages:
    27
    ACPI Problem in Parallels 3.0 Vista Bootcamp

    Yes there are a few issues I had to resolove myself (and 1 minor annoyance still unresolved) but overall I'm very happy with Parallels 3 especially that I now only need 1 copy of Vista Ultimate installed. :)

    I'm running on a Macbook Core Duo. I have 2 Vista Ultimates. One is RC2 that I've been using with parallels 2 (3188). The 2nd is the retail version of Vista Ultimate in bootcamp 1.2. (Notice that I didn't upgrade bootcamp to 1.3)

    On my RC2 in parallels the issues I've encountered and resolved.

    I had problems with the network sharing. On the Mac I had to go to system preferences, networking, and click on apply now for new ethernet 2 and 3. On Vista had to go to network and sharing center, view status, diagnose, then reset network adapter. Now internet is working. So this issue is now fixed.

    Also display is not working correctly. When I click on alt/option and enter. Mac display goes to 800x600. When I go back to vista it goes back to 640x480.

    For some reason now it only happens on the return to Vista. This issue is fixed as stated below.

    Now for Parallels Bootcamp. Mouse is not working, Trackpad not working on 1st boot. Had to figure out how to use keyboard to reboot vista. Trackpad working on 2nd boot. Still no mouse in parallels.

    Before 3rd boot i tested bootcamp. It worked fine. It did install an acpi driver.

    Just before 3rd boot into parallels bootcamp I went into edit, virtual machine. Increased memory for video ram to 64mb, and under Usb controller I chose 'connect to guest os'. Then I booted up. Now the mouse is working. For some reason now parallels tools is now installing. Clicked on allow. The computer rebooted. The only issue now is after i click on alt/option enter to use the mac and then click again on alt/option enter to return to vista the screen resolution changes to 800x600.

    Figured out how to fix it. I went to parallels desktop, then preferences, then appearance, then unchecked change mac os x resolution. Now it works in parallels bootcamp vista and my rc2 vista.

    Now the only issue I have is the parallels logo that shows up on booting parallels bootcamp.

    Booted into bootcamp again and it installed the acpi x86-based pc driver again and wanted a restart so i did. No isuues in bootcamp. So i started parallels bootcamp. It installed an advanced configuration and power interface (ACPI) PC. Then wanted a restart. So i did. Now there's no parallels tools logo on bootup. Back to bootcamp again. 3rd time it installed the acpi x86-based pc driver again. Restarted.
    Parallels bootcamp has the parallels tools logo again during boot and again installed advanced configuration and power interface (ACPI) PC. It's just going back and forth.

    This is the only problem that I can't figure out yet.
     
    Last edited: Jun 11, 2007
  2. Inferior Minion

    Inferior Minion

    Messages:
    4

    I am having a very similar problem with my Macbook Pro. I can load up my Vista Business partition via Bootcamp and then switch over to Mac OS X and load it in Parallels. During the initial Parallels launch, Windows reconfigures the Advanced Configuration and Power Interface (ACPI) drivers then asks for a reboot. If I reboot, Windows states my Vista installation is not activated and an attempt to activate fails. However, if I reboot into Vista via Bootcamp, Windows will reactivate successfully and will reconfigure the ACPI x86-based PC Driver (note, the name of the driver differs between Bootcamp and Parallels) and again will ask to reboot. This reboot will allow Bootcamp to load without any problems, but as soon as I load Parallels, I cannot reboot it without first reactivating in Bootcamp. Luckily, there doesn't seem to be any drawback to not rebooting after the ACPI reconfiguration. It simply makes Parallels a one-time use until I reboot into Bootcamp. Any help with this issue would be greatly appreciated.
     
  3. Zenara25

    Zenara25

    Messages:
    27
    I tried upgrading parallels to 4128. Still same acpi problem stated above. So I decided to upgrade my bootcamp from 1.2 to 1.3. Still same problem. This isn't a horrible problem. Just pretty annoying after awhile (many reboots later, hoping it was going to be fixed in 4128)

    Now I haven't yet activated my Vista Ultimate (thankfully). So that's probably why I haven't gotten the activation screen like Inferior Minion above.

    Again, I'm on a Macbook Core Duo (not Pro & not the newer Core 2 Duo)

    Parallels team I hope you read this!
     
    Last edited: Jun 10, 2007
  4. Ankou

    Ankou Guest

    Hello folks
    Please follow the steps below:
    1. Download build 4128
    2. Install build 4128
    3. Reboot MacOS X (seems you need to do this because of services from build 4124 is still running after build 4128 is installed).
    4. Create your Vista VM using custom from Boot Camp partition
    5. Install Parallel Tools, and allow the various drivers to install

    build 4128: http://download.parallels.com/v3/en/GA/Parallels Desktop 4128 Mac en.dmg
     
  5. Inferior Minion

    Inferior Minion

    Messages:
    4
    Is there anything we need to do to the current VM, such as removing Parallel Tools, etc. prior to creating a "new" VM? I am currently using 4128 to get around the Boot Camp 1.3 crash on start-up issue. However, I did not create a new VM configuration when upgrading and simply re-installed Parallel Tools.
     
  6. Zenara25

    Zenara25

    Messages:
    27
    Well I tried what Ankou said above. Didn't work. I already have 4128. So I deleted the Parallels Vista VM. Rebooted Macbook. Created a new VM (custom, vista, bootcamp). Parallels did not install parallels tools because they were still installed in Vista from before. So I uninstalled Parallel Tools. Restarted. Then shut down Vista VM. Deleted VM. estarted Macbook. Recreated VM. Started it up again. Parallels Tools did not install on it's own (thought it was supposed to). I waited 5 minutes. Nothing. So I manually installed it (actions, install Parallels Tools). Restarted the VM. Shutdown VM. Restarted the computer into bootcamp. Again (as it has done since 4124 and bootcamp 1.2 and now 4128 and bootcamp 1.3) it installed an ACPI driver. Requested reboot. So I did. Then I started up Paralles VM. Like always found an ACPI driver to install. So nothing has worked so far.

    Also I sent an email to Parallels this morning about this issue. I couldn't autoselect that I was using version 4128. The latest one I could choose was 4124. The first sentence I wrote in regards to my problem was that I am using 4128. What is the response from Parallels. Please download version 4128. Now wasn't that helpful? (Only good thing was it was within a few hours response)

    Just a little bit frustrated right now. The only thing left to try is a reinstall of parallels. (Maybe I'll do that now) Or something I will not do. (reinstalling Vista OS)

    Can anyone who doesn't have this problem answer this question? In Device Manager under Computer what is it supposed to say under Parallels and also under bootcamp?
     
  7. Zenara25

    Zenara25

    Messages:
    27
    Hoping someone will read this and have fix.
     
  8. Zenara25

    Zenara25

    Messages:
    27
    I sent an email to support this morning. Hoping for a response.
     

Share This Page