My PD 4 experience after 10 days

Discussion in 'Installation and Configuration of Parallels Desktop' started by rderimay, Nov 25, 2008.

  1. pap

    pap Junior Member

    Nailed it is right!

    I was having the same slow issues as well. I upgraded from P3 to P4 and the VM just dragged. I followed the steps as described by wcf3 and all is good again. Thank you wcf3!

  2. Birdman

    Birdman Member

    Hi! Max,

    Nice to have Parallels working on status for the PD4 issues.

    Please give us what is going to fix and when will be the next major upgrade, say, before X'mas holidays as gift for us?!

  3. estrelnikov

    estrelnikov Parallels Team

    Try this KB article:, if it hangs during the VM uprgade try pressing Ctrl+Cmd+Option+R to interrupt the process, then follow the steps from KB article
  4. synner

    synner Bit poster


    v4 running XP under 10.5.5, MBPro 2G RAM

    Also having speed issues here. Both booting the VM and in speed during operation. This is much slower than v3 not a percentage reduction. 5-10 minutes to boot completely into the VM! Then once running, appalling speed overall.

    Submitted a ticket for this #17724

    Further, the VM will now not shutdown on its own. I'm not sure if this is just another part of the overall speed issue and it's taking forever to shutdown or it has just hung.

    Submitted a ticket for this #17734
  5. John@Parallels

    John@Parallels Forum Maven

    I suppose you submitted report for it
    Is it possible we investigate virtual machine?
    I mean if possible we provide you ftp to upload virtual machine to our site, or you can put in in one of public shares, we can download it.
    Please reply me in private message if you agree
  6. veloso77

    veloso77 Bit poster

    Thanks for figuring out the problem. Unfortunately I am not an advanced user so I can do this. When Parallel will release an update to fix this CPU bug. This is pretty annoying. My Macbook's performance decrease drastically when running parallels...
  7. Parallels Developers

    Please try to check this KB
    This is not an excuse, but this is not a PD4 problem rather a dynamic behavior of Windows.
  8. SergioG

    SergioG Junior Member


    To answer your questions:
    Windows Start up takes up to 10 minutes.
    Applications start up are very slow
    CPU usage in VM jumps up to 100% with no applications running (most of the memory being used by explorer and SVC host
    Host system slows down as well. prl_vm_app uses 310 mb (Rsize) and 1.61 gb Vsize

    Using macbook pro 15' 2.33 gh
    2 gb ram
    os x 10.5.5

    I have already tried optimizing the vm by letting it run for at least 30 minutes idle and then running the command prompt: start /wait Rundll32.exe advapi32.dll,ProcessIdleTasks but this doesn't seem to solve the performance problem.

    I normally run 2 applications on VM: a) MS word (2003) and Trados (translation memory software) 8.3
    Applications running on the host OS: entourage and safari

    Memory allocated to Parallels: automatic (on version 3.x I used something like 450 mb and it worked just fine)

    Any suggestions?


  9. alexg

    alexg Parallels Developers

    Dear Sirs/Madams,

    Some people experienced the problem with Parallels Desktop slow performance. The problem is incorrect upgrade procedure. In some cases it works incorrect. The clean Windows installation solves the problem in 99% cases. I know it is incorrect way to sole the problem, but if you have time and resources you can solve the problem in such a way. I'm sorry for giving you troubles but I promise we will found the solution to recover incorrect upgrade procedure.

    Thank you,
  10. MaximS

    MaximS Forum Maven

    SergioG, please check your Private Messages at right-top corner.
  11. MaximS

    MaximS Forum Maven

    SergioG, please, add "kernel.real_mode_vtx=0" in Configure->CPU, System Flags (Show Advanced Settings).
    Also send us report while the VM is running Help->Report a Problem and write here its ID.
  12. SergioG

    SergioG Junior Member

    I already did. Last start up after modifying the system flag took 18 slow minutes !!
  13. MaximS

    MaximS Forum Maven

    We need report ID.
  14. SergioG

    SergioG Junior Member

    I provided the report ID in one of the private messages sent to AA or Alex.
    please check with them
  15. aa.

    aa. Member

    SergioG, thank you for the report. I'll post a message when solution will be found.
    Last edited by a moderator: Dec 17, 2008
  16. etdale

    etdale Bit poster

    I gave up and downgraded to 3.0

    I was a happy Parallels 3.0 user. Parallels 4 really doesn't work well on my 6 month old Mac Book Pro. I had keyboard and mouse freezes that required restarts. The performance of my Mac OS deteriorated along with my XP. It was practically unusable and there was nothing I could find on this forum that fixed the issues. I had no problem downgrading to Parallels 3.0 and my computer runs well once again.
  17. SergioG

    SergioG Junior Member

    I think I am heading on the same direction. The tech support engineers from the forum are trying to solve the issues and I will wait a few more days.

    I am too experiencing problems on the Mac side, the computer seems unusually slow since the upgrade. On the Windows side is even worst, applications freeze very often, and now I am getting different error messages as I/O errors or Delayed Write Failed message: "windows was unable to save all the data for the file /nnn. The data has been lost. This error may be caused by a failure of your computer hardware or network connections. Please try to safe this file elsewhere".

    Hopefully they'll find a fix, if not I'll go back to version PD3 which was really working very well on my macbook pro, even better than my native windows computers.
  18. SergioG

    SergioG Junior Member

    Problem fix

    This is what two of the engineers from the Parallels team suggested and it worked fine for me (thanks Alexandr and AlexG)-

    1. Open c:\WINDOWS\System32\drivers and delete all files prl*.* but not
    prl_*.*, and delete prl_pv32.sys
    Then reboot.

    2. If step 1 will not help, then you can just uninstall Parallels Tools
    (Start->Settings->Control Panel->Add or remove programs -> Parallels
    Tools -> Remove)
    Without Parallels Tools installed guest Windows normally should start in
    2-3 minutes maximum. Then you can install Parallels Tools again (in
    MacOS top menu: Virtual Machine -> Install Parallels Tools)

    After doing this Start up time went back to normal (before was up to 18 minutes) and CPU usage when down to 2% (instead of 95%) when no applications running.
  19. GrahamR

    GrahamR Bit poster

    Build 3810 does not fix the problem, but Chucks method seems to

    Thanks, Chuck for your fix. I applied it today after struggling with various options, including installing build 3810. I was also getting 100% CPU usage with one or two apps open and 50% or so with just Win XP. Now I thought I had fixed the problem earlier, so maybe the problem will return, but for now all is good, so THANKS! ;-)

  20. Debbie Schultheis

    Debbie Schultheis Bit poster

    Please help me. I tried to uninstall Parallels and now my Bootcamp Vista partition is fried. It says it is unable to start because it cannot locate prl_pv32.sys. I have reinstalled Parallels, but am getting the same result. Can someone please send me a copy of prl_pv32.sys and tell me where in my Windows system folder to put it so I can access Vista again? My email is:

    Thanks for any help anyone can provide!

Share This Page