Network Issues with RC / Start Up Issues / Lack of Tech Support from Parallels

Discussion in 'Parallels Desktop for Mac' started by Jason, May 24, 2006.

  1. simon


    Weird. I have no trouble with DHCP via the wireless interface, I both wired and wireless networks depending on whether I'm at work or at home. I always get my lease renewed without issue using windows. Linux is a different story all together, dhcp has never worked there for me, but I'm ok with that.

    I'm very happy with the level of communication from Parallels, I'd say they are one of the most responsive software companies I know of. Imagine guys, they could be like the Skype mac team !
  2. peterwor


    If its help you really want then supply some more information in your post. Its a known issue that DHCP isn't working for bridged networking. have you tried assigning static IP, subnet and gateway addresses?
    Are you using a router as your DHCP server or is the connection coming straight from your DSL/CABLE modem? If you're using a router can you ping it from teh comand line by IP address?
    WinXP, if left alone will always try and use DHCP to auto connect to the internet.
    When you open a command line in XP and type ipconfig /all what do you see?
    If you see an IP address starting with 169.x.x.x then WinXP has defaulted to trying to use DHCP, most likely, and can't get an IP address.
    If you run, from the command line ipconfig /release then ipconfig /renew does your IP address change?
    Give us some more information to go on and I think you'll find people in here quite helpful.
    Just posting that you acn't connect to the internet is too vague, what's your network setup, what have you tried, have you tried manually configuring your network etc?

  3. nhand42


    To complement (but not dispute) your experience I have Linux as a guest OS and DHCP works there too even with RC1. I'm using a WRT54G that has been flashed with the DD-WRT firmware. DHCP lease is obtained over wireless just fine. However I recently took my Macbook Pro to a site using a Netgear AP and although OS X obtained a lease the guest OS (Linux) could not. So I've seen first hand the problem in RC1 and a manual assignment of an address inside the guest OS did get networking working again.

    However this is not exactly a mystery. Parallels Team has already explained that this is a known issue, it's caused by the AP assigning the same lease to both host and guest OS, it's fixed in RC2, it slipped past their QA because it only happens with some brands of access points (obviously not the ones that Parallels uses), and there is a sticky thread explaining what the problem is and the workaround (manual assignment of IP address). I can't imagine they could do much more unless they sent a tech guy around to beta tester's houses and clicked the buttons for them. I was particularly annoyed with that Jason guy who was complaining about this problem when he obviously hadn't even done the bare minimum of research (ie, using the search feature on the forum).

    I agree. This is a good level of support for an open beta.
  4. nhand42


    A representative from Parallels (that Andrew guy) has given the answer several times in several threads. They've even posted a FAQ in a sticky thread; it's one of the first threads in the forum.

    USB printer works fine here. The right-click was intentionally changed from Ctrl-Click to Ctrl-Shift-Click by request of the beta testers. Because so many people complained when Ctrl-Click stopped working (and obviously they didn't read the RC1 release notes that explained the change) the Parallels team put up a poll and asked what the default behaviour should be. Last time I checked, the majority of beta testers wanted the Ctrl-Shift-Click behaviour.
  5. chrisp


    Search for how to setup host-only networking with connection sharing. I use this when I'm at Starbuck's and it seems to work well. It took me awhile to get it working properly, but once you do I think it will solve your problem. And I have everything setup using DHCP.
  6. dkp


    I'm happy, too. But my DHCP is one that does not work (Netgear wireless) though I really don't care. The stuff I actually use works great. The DHCP problem is not universal, apparently, but is there and they're working on it. I also think the support has been great but apparently not everyone does and sometimes it's not a bad thing to remind everyone this is not yet a consumer-ready vendor supported tool, and that as beta testers we have some responsibilities, too. One of them is to not whine. I yield the soapbox :)


Share This Page