Networking on Windows 7 guest VM has stopped working after Mojave security updates (and on Catalina)

Discussion in 'Windows Guest OS Discussion' started by JaeW2, Dec 16, 2019.

  1. JaeW2

    JaeW2 Bit Poster

    Messages:
    5
    Hi there,

    I applied security updates for my MacOS Mojave several days ago and the networking on my Windows 7 guest VM (running on Parallels Version 13) stopped working. My Intel PRO/1000 MT network adapter on the guest VM is simply not connected to the Internet. I have tried all the procedures at the following links including reinstalling Parallels Tools, trying both shared and bridge networking, etc., but in vain:

    Link 1::https://kb.parallels.com/8978
    Link 2: https://www.parallels.com/blogs/network-troubleshooting-parallels/
    Link 3: https://kb.parallels.com/en/120845 (stopped at Step 6 as there was no file integrity problem)

    To fix the problems I have also upgraded (i) my Parallels to Version 15 and (ii) my host MacOS to Catalina, but it didn't work, either. Can anyone give me a clue??

    Thanks in advance!
     
  2. SpencerP

    SpencerP Bit Poster

    Messages:
    3
  3. JaeW2

    JaeW2 Bit Poster

    Messages:
    5
    I have made a bit of progress. I selected bridge networking (with default adapter) and statically set the IP address (plus subnet mask and router address) on Windows VM (i.e., not using DHCP) ) as shown in the following link to make the network work again.

    Link: https://www.wikihow.com/Fix-the-Network-in-Parallel-Desktops

    However, this is only a half solution as I will probably have to manually set the IP address again for a different network. The problem is that DHCP service does NOT work for either shared or bridge mode. Perhaps there is a problem with Parallels Networking Service or Shared Networking Adapter? I will appreciate any direction to fix this problem.

    INFO: shared vs. bridge mode - https://www.parallels.com/blogs/eve...now-about-network-modes-in-parallels-desktop/
     
  4. greggk

    greggk Bit Poster

    Messages:
    4
    i am having similar issues but with a much older set up I had about 10 vms set up on parallels 13 on a mac pro 2.1 using el capitan all using seperate static ips configured through a virtual server and virtual router all working fine for last 10 months or so, a week or so ago i had some ram issues (still have those as well, system withholding over half my 32gb for no reason I can see) so I removed the vms from the control centre to see if the ram came back it didn't, but then when i added them back on they are now randomly connecting/not connecting, I've had a little joy disabling the network adapters then enabling them but even that is very hit and miss sometimes it works sometimes it doesn't, sometimes turn off whilst its working and then return to see it sometimes working or sometimes not, I've tried a main router reboot that didn't go any anything either running out of ideas fast
     

Share This Page