Never a successful upgrade

Discussion in 'Parallels Desktop for Mac' started by athos, Feb 27, 2007.

  1. athos

    athos

    Messages:
    31
    I must be very unlucky. Tonight I downloaded the latest build, I applied it, then I launched it. I run my bootcamp parititon inside of parallels. After freezing the first time, I rebooted and this is what greeted me on the next login:

    Windows could not start because the following file is missing or corrupt:
    \WINDOWS\SYSTEM32\CONFIG\SYSTEM

    with a message telling me how to repair it, which is going to complicate my evening.

    This is the third time this has happened to me, and it forces a full rebuild each time.

    Not really cool, and it makes me not want to use the bootcamp thing inside because now I have nuked myself in two places and can't do anything.

    *sigh*
     
  2. PubGuy

    PubGuy

    Messages:
    119
    Early on, I used to have problems with the upgrades, but I've solved that by rebooting the Mac immediately after upgrading. Seems that any changes to Parallels networking components impact items on the Mac side that require a reboot of the Mac in order for the updated networking components to load.

    My upgrade sequence is as follows:
    1) Load into the VM's and shut down all Windows instances.
    2) Quit Parallels
    3) Perform the upgrade
    4) Reboot the Mac
    5) Load Parallels
    6) Load the VM's and install the updated tools
    7) Reboot the VM's
    8) Good to go

    This has worked flawlessly for all the beta upgrades above 1170. No problems whatsoever.

    Now, I'm not running Boot Camp and there are additional steps required for the boot camp installation. However, the steps above are still required to ensure that all the components of the Parallels upgrade are installed and loaded.
     

Share This Page