New Mac Pro EFI Firmware / VTI-x fixed?

Discussion in 'Parallels Desktop for Mac' started by demenas, Nov 13, 2006.

  1. Pleiades

    Pleiades Member

    Shutting down seems to have fixed my problem, too. But then again build 1970 had appeared to fix it temporarily as well for a short while and then it came back. Like most people's experience, rebooting after the firmware upgrade did nothing, but shutting down did seem to work.

    Can Parallels somehow confirm with Apple whether they did include a fix for the VT-X problem in this latest EFI change? I'd hate to think this is just a temporary coincidence.
  2. Knaledge

    Knaledge Bit poster

    I got the VT-x warning to go away but now every time I start Parallels it shows as "Software Mode 0" under More Info when the VM is started up. If I do not have a VM started, it says "Off".

    I installed the EFI update via Automatic Updates, shut down as it instructed, held down the power button until the white LED strobed/flashed, released the power button, a progress bar appeared at the bottom of the screen, the system rebooted, launched back into OSX, a pop up confirmed I am now up-to-date with 1.1, and I clicked "OK" or whatever.

    I then went to Apple > Shut Down and shut down the Mac.

    Power button was pressed, got back into OSX, confirmed the EFI ROM number was correct as per the 1.1 patch notes.

    Launched Parallels build 1970 (installed prior to the EFI update for nearly a week).

    About Parallels Desktop > More Info > Virtualization Mode: Off

    Started VM (Windows XP Pro w/ SP2)

    About Parallels Desktop > More Info > Virtualization Mode: Software Mode: 0

    Stopped VM

    Apple > Restart

    Got back into OSX after reboot

    Launched Parallels

    About Parallels > More Info > Virtualization Mode: Off

    Started VM

    About Parallels > More Info > Virtualization Mode: Software Mode 0

    Any amount of Shutdowns, reboots, sleeps, etc. now result in no VT-x AT ALL. I run a very plain jane vanilla install of OSX, no use of reFIT or whatever, nothing.

    Mac Pro 2.66, 1GB of RAM, default video, etc. etc. etc. etc. etc.

    I don't know who it is now, but someone needs to get their shit together as NOW I am definitely not getting what I paid for.

    Fix it. Someone.
  3. palter

    palter Hunter

    Did you check the configuration settings of your VM?
  4. Knaledge

    Knaledge Bit poster

    Although I thought it obvious from my ranting above, I've made sure VT-x support was requested to be enabled via configuration of the VM itself.

    And as I mentioned above, putting the Mac into sleep mode and then returning it worked, as it did for many others.

    Now, VT-x is all but gone. I want it back and I think it's unfair I paid $80 for this, so far, lackluster package (half-assed networking that constantly reports network conflicts yet, it's the only machine on the network aside from the host, and both are set to DHCP and happens when using any one of three different routers, poor USB support, no hardware rendering, etc. etc.) and $2500+ for a Mac.

    I am finding myself less and less enthused about owning a Mac and more and more coming to grips with the reality behind why only less than 2% of the entire computing segment use a Mac.

    It seems like a lot to get worked up over but I just want to get what I paid for and so far, whether it be Apple and their lack of feeling the obligation to keep their consumer informed or Parallels being so vague about their time line and always posting "This this and this were remedied for now and a bunch of other fixes too" it's just turning out to be not worth it any more. I want to know what those fixes are/were.

    If you want to use Parallels to write a Word doc, go for it. But at this point, Boot Camp is the way to go - I'd rather spend the extra 10 seconds rebooting my Mac and getting entire (or close to it) support from my hardware via software than to just swallow Parallels running in a window... ooo boy. A window with Windows in it. And let's not forget every other OS you can run within Parallels that must suffer slightly on a Mac Pro without the VT-x support, which I suppose is at this point the only other major selling point I imagine for other people.

    I just want a straight answer from someone - who dropped the ball and when will it be fixed?

    Parallels runs less than stunningly without the hardware virtualization support designed by Intel and I seriously feel ripped off when I could have just saved the money, got a PC, and been done with it. It just is less of a hassle to have both as that was my plan - I have a use for software I own which was designed for Mac and I have a use for software designed strictly for a PC running Windows. I figured I'd spend $2500 on a machine that could do both thanks to Parallels but now I find that decision seriously mis-informed, thanks largely in part by what I feel a misrepresentation of their product. And by the looks of previous threads on this forum, I'm not alone.

    And Apple isn't off the hook in that regard either. Why has there not been ANY confirmation of such a problem by Apple? How coincidental it is that Apple just got ragged on for having sub-par support services in comparison to other OEMs?

    Looks to me like both companies (Parallels and Apple) need to find more people to put on the front line and keep their consumers informed and their problems resolved.

    So really - how do I get VT-x support back?
  5. dhjdhj

    dhjdhj Hunter

    I disagree with your position. I have been involved with the Parallels product since the early beta and I have had nothing but success with it.

    I certainly don't consider Parallels to be a replacement for Windows. If you want everything that Windows has to offer, then use a cheap Windows box!

    As far as I'm concerned, Parallels is a way to allow you to move to the Mac and benefit from what really is a superior environment (mostly because of its Unix roots IMHO) and yet still have emergency access to programs that are simply not available on the Mac for whatever reason. For example, Outlook in a corporate Exchange environment or some other proprietary corporate apps.

    But why use Word under Parallels? If you're REALLY moving to a Mac, then Office 2004 is the way to go - or use OpenOffice if you don't want to spend any money.

    Although I'm hoping that the firmware update will fix the problem on my machine too, I'm not ready to stand up and shout that Apple and/or Parallels is useless because of this issue - in all other respects, the environment has been flawless except for directX games support which I believe it doesn't support, nor do I care.

  6. darkwing

    darkwing Bit poster

    I can also conform it is now working .. Mac Pro 2.66, 4g ram ... I think the key is a complete shutdown.
  7. jbmelby

    jbmelby Member

    Works for me, too.
  8. dhjdhj

    dhjdhj Hunter

    The firmware update fixed the problem for my MacPro as well.
  9. larryr3455

    larryr3455 Bit poster

    VTI-x fixed

    MacPro 2.66Ghz - firmware update fixed VTI-x for this machine. :)
  10. bhorta1

    bhorta1 Member

    I got another Mac Pro 2.66 and they seem to be shipping now with the latest EFI firmware. I was able to start Parallels 1970 without any sleep tricks at all. I will upgrade the first Mac Pro and see what happens.

    I downloaded the EFI upgrade utility and it warned me that no updates were required.
  11. athos

    athos Member

    Not me

    3 Ghz Mac Pro. I just get Software Mode 0 now, never VT-x.

    WTF? IT would be nice if someone from parallels would comment.
  12. DarylF2

    DarylF2 Member

    My system (Mac Pro 3.0GHz Quad Xeon with 4.0GB RAM) is also now only ever getting Software Mode 0 after the firmware update (which was applied successfully; I'm now at Boot ROM Version: MP11.005C.B04).
  13. webdeck

    webdeck Member

    After installing the update, I was still getting software mode. Then, based on advice from this thread, I shut my Mac Pro down completely, let it sit for 30 seconds, then powered it up. Since doing that, VT-x is now working for me for the first time ever.


Share This Page