New Mac Pro version of Parallels Desktop causing kernel panics

Discussion in 'Parallels Desktop for Mac' started by iPalindrome, Sep 7, 2006.

  1. Pleiades

    Pleiades Member

    It does seem like they rushed this release out the door with problems that were fairly major and were easily reproducible, what with the numerous people suffering the VT-X problem, the kernel panic problem, and the networking issue with MTU or a combination of all three. I'll excuse the Vista issue since I doubt they had their hands on RC1 longer than a few days.

    I guess with all the griping in this forum about how they were taking so long with a fix, they decided to go ahead and release a really buggy product. This is considered a Release Candidate, which should be close to being free of major bugs (the stop ship variety in programmer lingo), but it does seem like it's got a long way to go.

    To Parallels, please take your time to get it right. Tell us how long it'll take (for real) and we'll deal with it, but clearly what was released today is no where near to being ready.
  2. Frungy

    Frungy Junior Member

    success story...


    I have been perusing the threads and haven't seen anyone post a non-KP success story, so I thought I'd jump in. I only have 2GB RAM currently, othewise it's a stock 2.66 GHz machine. I have successfully installed XPsp2 along with Interactive Data Language 6.3. Numerous reboots with no problem. Successful cut-and-paste of commands between OS X IDL and windows.

    I'm only using the hosted networking (if the term isn't exactly correct, sorry, very very tired and in mourning) but will attempt more software and hardware configurations tomorrow. Very impressed so far. Hopefully I can scrape together enough to double the RAM so I can run certain packages of interest (not IDL since I'll use the native darwin-x86 version).

    I'll be buying this Real Soon Now, and look forward to seeing how things develop.

  3. awilliamsny

    awilliamsny Bit poster

    I'm guessing like, uh, zero?

    Sheesh. Hello Parallels give us some love here, willya?
  4. boulie

    boulie Bit poster


    thanks mcqueary for clearing that up for me :) i mistook the long code printouts like those from iPalindrome to be any case...looks like we are all in the same boat again!
  5. David Watson

    David Watson Junior Member

    That's great to hear! I'm going to be using my Mac Pro for IDL 6.3 and Java development, so it sounds like it should be possible to get it working. :)
  6. mcs_service

    mcs_service Bit poster

    Did you remember to ...

    ... remove the workaround that Parallels provided?

    I have just downloaded the release candidate, and have no problems.
    I did, of course, remove the legacy settings to run OS X in 32bit mode.

    Remember this???
    sudo nvram boot-args="-legacy"

    You have to do this
    sudo nvram boot-args=""
    to remove the legacy options again, followed by a reboot.

    I remove the legacy option, rebooted and thus far, besides the old Garmin GPS issue, the new version gave me one (1!) error ( please email Parallels, bla bla bla ) when I started the old WinXP SP2 VM (created by the crashing version of Desktop) for the very first time, then no more errors at all. No Kernel Panics, nothing. Everything seems to work. I have restarted the VM ( for testing purposes ) about 10 times thus far.

    I have a MacPro 2.66, 1 GB ( for now... ):D

    Hope this helps,

    Last edited: Sep 7, 2006
  7. verden

    verden Bit poster

    Tired of debugging

    I too got kernel panics. I have tried many different combinations and have given up. I have been able to get the VM to get a little farther along, but it still crashes. Every time. So far, fsck and mount have fixed everything, but I am tired of debugging this code.

    I really just need to run Outlook/CRM so maybe it is time to give Crossover a try. :mad:
  8. ctebo

    ctebo Bit poster

    Another user experiencing kernel panics

    I too am experiencing kernel panics when attempting to start a vm with the new RC :( ...

    panic(cpu 1 caller 0x003A2287): getPhysicalSegment() out of 32b range 0x1342d4000, len 0x1000, class IOGeneralMemoryDescriptor
    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x3702b428 : 0x128cdb (0x3c99c4 0x3702b44c 0x131cdf 0x0)
    0x3702b468 : 0x3a2287 (0x3edad8 0x342d4000 0x1 0x1000)
    0x3702b538 : 0x3a41e5 (0x7449080 0x0 0x0 0x0)
    0x3702b558 : 0x3a3372 (0x7ac6640 0x0 0x0 0x0)
    0x3702b578 : 0x64cae58f (0x7ac6640 0x1 0x3 0x57d2e18)
    0x3702b5a8 : 0x64cae646 (0x4e058000 0x0 0x1000 0x0)
    0x3702b5e8 : 0x64cadf50 (0x80b3680 0x1000 0x0 0x13bcbc)
    0x3702b628 : 0x64caf0a6 (0x1 0x780 0x0 0x0)
    0x3702b6a8 : 0x64caf296 (0x0 0x297 0x3702b6d8 0x1d1654)
    0x3702b6c8 : 0x64cae72e (0x5d10b90 0x297 0x3702b708 0x64cad3db)
    0x3702b6e8 : 0x64cae834 (0x5d10b90 0x3702b724 0x3702b718 0x7914dac)
    0x3702b708 : 0x64cad44e (0x0 0x2 0x3702ba90 0x3702bab8)
    0x3702b728 : 0x1efece (0xb000000 0x1 0x2000 0x7914dac)
    0x3702b798 : 0x1e3def (0x3702b7c8 0x7061738 0x3702b7f8 0x1cf7f8)
    0x3702b7f8 : 0x1de40a (0x7061738 0x1 0x3702bab8 0x3702bab8)
    0x3702b848 : 0x1df365 (0x3702b964 0x3702b954 0x3702b864 0x1f7469) Backtrace continues...
    Kernel loadable modules in backtrace (with dependencies):

    Kernel version:
    Darwin Kernel Version 8.7.2: Tue Jul 25 23:09:54 PDT 2006; root:xnu-792.10.96.obj~3/RELEASE_I386
  9. jlucia

    jlucia Bit poster

    Sounds to me like a bunch of us have a formatted RAID 0 and that may be causing the problem. Who posted here that doesn't have the RAID 0 running, just curious.
  10. iPalindrome

    iPalindrome Bit poster

    I never messed around with that. Once I discovered Desktop wouldn't run on the Mac Pro, I just waited for a working version. Looks like I'm still waiting... :(

    Also, no RAID here.
  11. firebird2k

    firebird2k Bit poster

    I installed the latest version.. rebooted and it came up saying it couldnt' communicate with the hypervisor.. Reinstalled/upgraded again.. rebooted and it worked :) ..

    I had the same issue as others with it running in software mode 2 or something like that. Put the system to sleep woke it up and started up parallels and VOILLA had VTX Enabled.. however after reboot, it lost it again.. not sure why that keeps happening....

    Network access.. as someone had noted.. go into the ethernet settings and set to jumbo and set it back to standard and it'll fix the networking issue.. have to do it each time you restart the VM..

    Let's see.. Get yelled at for not releasing anything.. Get yelled at for releasing something..hmm.. sounds like a no win situation. .have to give the programmers at Parallels some kudos... very short amount of time to get something working. Keep up the great work!

    Yes.. there will be issues.. but then again. we're on the BLEEDING EDGE.. if you can't live with it go back to the G5 ;).
  12. verden

    verden Bit poster

    No RAID 0, plenty of panics.
  13. Ben @ Parallels

    Ben @ Parallels Member

    Guys -

    Please keep in mind that this is still a BETA build! This release is there to be tested, evaluated, critiqued, etc. so we can hammer out all of the issues and release a really great final build.

    The engineers and the QA team know about the issues (and this thread) and are working on fixes now. I'll keep you posted on my blog and here on the forum.
  14. controller

    controller Member

    Add me to the list of Kernel Panics. I get an instant KP when the VM starts up and goes into the XP desktop (past the "welcome" screen).

    I tried maxmem of 3000 and 4000. I have a Mac Pro 3.0 with 4GB of RAM (8 512's). No RAID here, but I do have 3 500GB individual drives.

    Ben, thanks for continuing to work on this. I think this release, for Mac Pro users, isn't even at Beta. It's more like an alpha.

    Can you elaborate at all as to what is causing the problem? I am seeing identical KPs using one other piece of software: Second Life. If I go down to 2GB by forcing maxmem down, the game will run, but very slowly. If I go to 4GB, forget it.. I KP with the exact same error as Parallels does.

    Also, trying to run XCode OpenGL Shader Builder or Driver Profiler causes instant crashes (though not KPs). I suspect there may be a bug in the -OS- that is only showing itself with Parallels and Second Life. Is there something special Parallels (and maybe SL and the Xcode apps) are doing to cause these crashes that seem directly related to how much RAM someone has installed?
  15. controller

    controller Member

    Frungy, the 2GB is the issue. Things break going past it. Do you have the X1900 card? I think that may make a difference, because I am seeing identical KPs and behavior as related to 2GB or more RAM being installed in a game called Second Life. I don't play the game much, but it has become a testbed for me as to how to KP a machine. That game runs, albeit with issues, in 2GB mode, and acts just like Parallels in anything more than that.

    The KPs are identical between machines, both caused by only going past 2GB of RAM. I wonder if there is a connection? I surmised it was the NVidia card and/or drivers. I am surprised more people don't have over 2GB in their new Mac Pros, as it seemed pretty sluggish to me without at least 3. But I digress.
  16. Frungy

    Frungy Junior Member

    BTW, when I earlier mentioned success at cut-and-paste between OS X and windows IDL, I meant from OS X apps like Terminal, SubEthaEdit, or Firefox, not the X-windows IDLDE of course. Direct graphics plots, and surface and isovolume components of the Demo worked well. I was able to install the windows version because shared folders did allow me to copy the downloaded install file across from my Boot Camp partition. I have yet to actually get the license file over to do that bit, though...

    I would also like to note that this was a clean install of Parallels as I couldn't justify fiddling with the original work-around when immediate needs were met with Boot Camp. Crossover beta was Right Out; I did somehow justify fiddling with that but the apps I really needed blew up.

    Offish-topic addendum: IDL time_test3 under parallels on the 2.66 GHz machine came in at around 0.8 s, vs. 0.7 s for native OS X on the 3 GHz machine ( Under Boot Camp, the windows IDL time_test3 came in at 0.55 s, with the darwin-x86 version at about 0.89 s (comp.lang.idl-pvwave, "mac intel benchmarks").

  17. Frungy

    Frungy Junior Member

    I have the stock 7300 GT video (At the time I thought I needed it NOW to prove I could run things at least under Boot Camp, with the option to upgrade bits later, but of course the project got hung up a bit). I guess for once it's good to be relatively poor, only able to afford 2GB*. Looks like they don't quite have things settled for >32 bit addressing, but at least it's a start. During my next active period I'm going to hit it with CorelDraw X3; if that doesn't expose features for this configuration I don't know what will short of full octane ArcGIS, which is currently only a mad dream for me.


    * for master debators, stock machine ordered along with a 1 GB separately shipped upgrade.
    N.B.: 7 September Crucial pricing was in line with Apple where a week ago I swear it was $100 cheaper for a 2x512 compliant upgrade.
  18. SiskoKid

    SiskoKid Member

    I have 2GB and the ATI x1900 card, and I'm not having kernel panics (I don't go to a white screen and restart) but it chokes when installing or opening the Windows XP OS and I have to restart. I did get it to install once, and while it was functioning fine it choked again, couldn't move my mouse it just went into that color spinning ball, so I restarted again and coudn't get back into the OS. I get that VTx message so I can't install or get back into the OS, so I always have to do a fresh install of Parallels.

    I just wanted to make it clear that I don't have more than 2GB and I have an ATI card, and I still have issues.
  19. Frungy

    Frungy Junior Member

    Before I wander off and collapse, I'll also add that I installed a couple of 320 GB Seagates, one of which is used for the Boot Camp install, but no RAID has been configured. Also, apologies for using "stock" instead of "default" or the like, since there are apparently a googol "stock" configurations. To summarize, my so far successful configuration is:
    * 2.66 GHz Mac Pro
    * 4x512 MB Apple-supplied memory
    * Default 7300 GT video
    * no RAID
    * OS 10.4.7 freshly installed from the distribution disc prior to Boot Camp and, later, Parallels (not the original factory install if it matters)
    * clean install of Parallels build 1884; earlier workaround was never applied
    * hosted(?) networking (cf above; very tired and mourning... OS X environment makes grieving easier, or at least doesn't as quickly remind one of Satan, the Devil, but I can't currently live solely in the Candy-Colored Unix They Call OS X)
    * shared folders worked
    * successful use of 1024x768 video resolution in Parallels

    Hopefully by the time I can buy some more memory, she'll be right. Good luck!

  20. mvk

    mvk Member

    Mac Pro and Parralles RC

    On my Mac Pro Quad 3.0 with 6 GB RAM, had the usual kernal panic when Windows XP SP2 tries to reboot while installing when running Parrallels straight. However, when I changed the maxmem to 2000 using the prior instructions, would only get the VTi error but Parallels runs fine, including networking and sound. Display up to 2560 X 1600. Of course, my whole Mac runs slower with so little memory. Will be testing it over the next few days. Of course, if I have to run terminal commands and reboot just to run Parralles, then reboot to get back all of my memory, might as well use Bootcamp with less hassle. Hopefully, they will figure out the memory issue and VTi errors sooner rather than later.:cool:

Share This Page