New Mac Pro version of Parallels Desktop causing kernel panics

Discussion in 'Parallels Desktop for Mac' started by iPalindrome, Sep 7, 2006.

  1. Pleiades

    Pleiades Member

    My Mac Pro was a stock dual 2.66GHz model with 1GB RAM. I upgraded it to 3GB with OWC's chips. I also added three 500GB hard drives to the other three bays with two of them set up as a RAID 0 and the third set up as a Windows Vista Build 5536 (pre-RC1) under Boot Camp 1.1.

    When I start my WinXP VM, it'll give me the VT-X error as seen by many here. If I sleep my Mac Pro and then wake it up and start Parallels and the VM, it will kernel panic reliably. So I'm running my VM SLOWLY with VT-X off. At least it works.
  2. controller

    controller Member

    Oh I'm not saying that Parallels works like a charm with 2GB... it seems horribly messed up even for most 2GB users from what I have seen. But at least it isn't an instant reproducable Kernel Panic every time.

    I'm not sure I call that progress though. :)
  3. controller

    controller Member

    Exactly. BootCamp requires a reboot anyway, and is faster and reliable with the SATA fix. (And automagically limits your ram to 2GB! haha)

    Parallels is a great program and works great on my MacBook Pro. I look forward to the day they can sort out this mess on the Mac Pro.

    I suspect they will see similar or identical problems on the new Core 2 Duo iMacs if those machines are loaded with 3GB of RAM as they can be now.
  4. boulie

    boulie Bit poster

    finally works!

    MacPro 2.6/3 gig ram - maxmem'd down to 2 gig (via ben's comments in parallels blog)
    Latest version of Parallels re-installed
    Installed xp
    works like a champ!

    1280x1024 resolution
    parallels tools installed - all functioning fine
    everything solid so far, about an hour of time. Shutdown/re-started xp several times thru vm and natively
    unable to get internet access as of yet but working on it

    if I can get this working...anyone
  5. jbmelby

    jbmelby Member

    I have 3 GB RAM, and Parallels with XP Home works for me without problems—no need to set maxmem to 2 GB.
  6. awilliamsny

    awilliamsny Bit poster

    Can't get it to work here, at all.

    Mac Pro, 4gb -- set boot args to 3500. Set the sleep thing.
    Install Parallels - install windows xp. KP when Win XP finishes loading and tries to reboot itself. I have tried to remove the disk immediately, it makes no difference.

    This isn't beta software, it's unworkable.
  7. IkMarvel

    IkMarvel Bit poster

    Me Too

    I have a pretty standard setup - 2.66 Mac Pro. I can't even start parallels without it killing my mac. I have 2 gigs of memory, 3 hard drives, and the rest is stock. Good to see that I am not alone in this matter. I don't feel like goofing around trying to get this to work. I'm a realtor, and it would be nice to use IE 6 and a few other apps, and not have to boot into boot camp, but I don't want to jump through hoops to use this software. I wondered how it was going to work, now I know. It doesn't. Even at beta stage it should do what it says. This should not have been released. Crossover is fine but you cannot update any of the softs you install, and it's very limited. Runnin windows in boot camp is still slower than running native on a PC. Kind of a drag.
  8. Harley

    Harley Bit poster

    I guess I must be lucky.
    My installation is running just fine with zero errors, problems or Kernal Panics.

    I am running a MacPRO, 2.66ghz, 2 GB memory, 2 each 500GB drives.
    OSX 10.4.7

    However my installation proceedure was different than any that I have seen mentioned.

    Following was my proceedure.

    I had the original RELEASED version of Parallels running just fine on my MacBook with 2gb memory and Windows XP home.

    I used the Apple Migration Utility to move EVERYTHING from my MacBook to my MacPRO.
    And of course when I tried to start parallels, I had problems similar to others.
    So I waited for the latest MacPRO beta release.

    I simply installed it OVER the exisiting ORIGINAL release version.
    And VOILA! it came up running just fine. No kernal Panics, no errors.
    Running numerous apps..

    The only problems that I am having are all releated to variious USB problems, most of which existed prior to this MacPRO Beta. But I do have Internet connection, networking (via Airport Extreme) , MS Office, and a half dozen rather obscure programs that I need for my own projects. All seem to be working fine.

    I was even able to print to my network connected HP Laserjet AND my old HP Inkhjet 960 USB printer. I am NOT able to talk to my older Epson 1650 Scanner due to USB problems.

    Note that I never did install the intermediate Update that Parallels posted. '
    I went straight from the Original RELEASED version to the latest MacPRO beta.
    That, and the fact that I am only running 2 megs of memory, may be part of my accidental success story here.

    It does seem that they have LOT of work to do in getting USB to work correctly but I am hoping that comes shortly..

    And lastly, boot up and Disk Intensive operations under Parallels are much faster than Boot Camp, due to the very slow PATA disk I/O under Boot Camp. I sure hope Apple can get that fixed as well.

  9. bbaines

    bbaines Bit poster

    I've had no success in getting Parallels working with WINXP SP2. Along with the kernal panics and VT-x issues using the new Beta version released yesterday, I also have an issue where I uninstall Parallels using the uninstall application and then try to reinstall Parallels in order to have a fresh start. However, the new Parallels installation then attempts to find a prior installed Virtual Machine and doesn't ask for a serial number upon initial startup after the new install. This leads me to believe that there are some files lurking somewhere that weren't removed with 'uninstall.' Anyone know which files must be removed in order to TOTALLY remove Parallels?

    I am running a MacPro with 3GB RAM.
  10. flyboy

    flyboy Bit poster

    This Mac Pro Issue

    I have read all the posts guys, I am just wondering through all the technical talk which
    I don't understand, is this issue resolved in the latest release or is buying this for my new mac pro just a waste of time? In two weeks I have to go onsite to a customers place of business and set up a room full of mac pro's and they all are needing a windows solutions and are not interested in dual booting. Any ideas answers would be greatly appreciated.

  11. verden

    verden Bit poster

    It might work, it might not, you definately don't want more that 3GB of memory on them. But, IMO, PD is not ready for production now, and I doubt it will be in 2 weeks.

    It flat doesn't work in my machine:
    2.6 GHz
    3 GB memory
    3 320GB Drives
    1 300GB Drive
  12. artpease

    artpease Bit poster

    1884 flat does not work...(well, I'll take that back, a little progress. See edit.)

    Nor mine...
    2.66 ghz
    3 gb memory
    1-250gb 2-320gb 1-750gb
    I just received the RC email and I thought, oh good, they fixed yesterdays 1884, but no same thing.
    Windows XP SP2 crashes on first install boot. After rebooting the Mac Pro when I start the VM, I get the same black Windows boot screen and then it returns to the Parallels properties screen. This forum is full of similar accounts or kernal panics when starting the VM.
    I can not believe Parallels sent out the general RC announcement when it flat does not work.

    Edit: After removing 1gb of physical RAM I was able to get completely through the WinXP SP2 Install. I have no idea if 3gb of RAM was the problem. I will reinstall it after I work through the rest of the bugs like networking etc...
    I'm sorry, but I still do not understand how they can call this a Release Candidate.
    If part of the problem is Apple and the VT-x, then it is not a Release Candidate until that gets fixed.
    I will say that I am glad they released this beta, it just should have been left at that.
    Last edited: Sep 9, 2006
  13. jbmelby

    jbmelby Member

    However, there are also many reports in this forum to the effect that (sometimes after a few initial glitches are worked out) it does work—it works for me—and anyhow, remember that those who are not having problems don't usually post! Since Parallels has been taking it on the chin for issues that many believe are essentially an Apple problem (viz., the VT-x issue), the folks at Parallels can hardly be blamed for wanting to get something out as soon as possible—and after all, they clearly state that the RC is a beta.

    This is not to say that those who can't get Parallels Desktop to run should not be upset; it's just to say that Parallels is trying to resolve the issues, and at least they've got a program that's currently available to use, which is more than can be said for VMware. I'd be very surprised if they didn't post a bug fix within the next week or two.

    My $.02.
  14. pjmann

    pjmann Bit poster

    Hypervisor Error !

    I have a standard Mac Pro (1 GB ram (2*512), 250 GB HDD).

    I have installed parallels (from the install disc), upgraded it with Parallels-Desktop-1884-Mac.dmg, rebooted, and still get the "Unable to communicate with hypervisor!" error.

    I have put the Mac Pro to sleep...same error, rebooted...same error.
    Re-installed the original version, upgraded again, rebooted...and still the hypervisor error.

    Then I completely uninstalled this mess (including deleting all the VM files from the Library), and repeated the rebooting process...same error. What is going on? Can someone please give me a step-by-step proceedure to get this working....could I have a MacLemon :confused: ???

    Thank you in advance. ...;)
  15. foulgernz

    foulgernz Bit poster

    Me Too!

    After installing the terminal script to get over the 4Gb RAM problem and rebooting, I can get as far as the NTFS format request and it KP's there. Tried complete strip out and reinstall but same problem 3 times. I've given up for the while and will wait for the next incarnation.:mad:
  16. BlueSkyISdotCOM

    BlueSkyISdotCOM Member

    I started out okay, but now I get KP about 2 out of every 3 Windows bootups. After the usual KP, I start Parallels before I start anything else and then it seems less likely to KP, but still KPs more often than not. I too will have to wait for the next release to hopefully run Parallels on my Mac Pro.

    Mac Pro 2.66 Ghz
    3 GB RAM
    150 GB stock HD
    130 GB additional internal HD

    A thought: It seems there are a number of KP'ers with more than one hard drive in the Mac Pro. Any chance having more than one drive installed could cause problems? Anyone with KPs and multiple drives want to try going to 1 drive and running Parallels?
  17. stormj

    stormj Member

    An RC is *not* supposed to be a beta. A RC is supposed to be a feature complete ware that's passed a beta stage, which is where it's supposed to be checked out on many different configurations. Now Apple's marketing has suggested there are several million possible Mac Pro variations, but that's largely crap. There are fewer meaningful permutations of Mac Pros than there are of something like, say, Vista...

    And, not that I love, MS, but even Vista's *beta* runs on my box.

    They should have called this an early beta, or, what it really is, an alpha.
  18. stormj

    stormj Member

    OK, folks. That's it.

    I'm reverting to the release version and the -legacy option.

    Too many KPs. I can't take it anymore

    MacPro 3ghz/4G RAM
  19. stormj

    stormj Member

    I have two hard drives as well, but I can't really see that that would be the problem. I'm pretty sure it's just lame at allocating memory correctly.

    My advice: download the "stable" old 1848 build and use the -legacy workaround. It did much, much better for me.

    I'll take a few hypervisor errors over a KP anyday.
  20. stormj

    stormj Member


    Ignore my advice. It doesn't work, at least for me.

    I was unable to revert to 1848. All of a sudden, the VM I was using for almost a month won't work on the old build, after a few days of playing with 1884.

    What a mess.

Share This Page