"No Boot Device Available" error with Boot Camp

Discussion in 'Installation and Configuration of Parallels Desktop' started by Brian Korblick, Aug 16, 2009.

  1. Brian Korblick

    Brian Korblick Bit poster


    I just bought v4 and am excited to use it, but can't get it to work with my current hard disk configuration. I've scoured the forums and knowledge base but the tips I've seen there haven't helped me.

    I have a new iMac with three partitions, the first is OS X, the second is a data partition, and the third is my Bootcamp partition with Windows XP:

    0: GUID_partition_scheme *931.5 Gi disk0
    1: EFI 200.0 Mi disk0s1
    2: Apple_HFS Macintosh HD 201.6 Gi disk0s2
    3: Apple_HFS BJK DATA 603.0 Gi disk0s3
    4: Microsoft Basic Data BOOTCAMP 126.3 Gi disk0s4

    I can boot into the Windows partition without any problems, I have rEFIt on here to select which OS to boot.

    I setup a Parallels custom virtual machine to use the Boot Camp partition, and when I start it for the first time, it starts the Configuration Process but then says "Unable to Connect to Hard Drive 1" and the virtual machine looks like this:

    I can't get past this screen. The various config files I've looked at seem OK, they properly mention the Boot Camp partition as being disk0s4.

    This article doesn't seem to apply and these instructions don't exactly match what I see on my screen. I've tried all possible options for "Position" but none seem to help:


    Any assistance would be appreciated!

  2. Brian Korblick

    Brian Korblick Bit poster

    now it works

    No kidding, after I made that post I went though all my attempts to create the VM and realized that I had missed one of the "IDE Positions". I tried to setup the VM one more time, and selected "IDE 1:0"....this time it found the hard drive and booted just fine!



Share This Page