No Coherence in 5 - not tools or Mouse

Discussion in 'Installation and Configuration' started by CharlesA, Nov 5, 2009.

  1. AlistairG

    AlistairG

    Messages:
    1
    I have the same issue.

    I've got three displays on my Mac, all from inbuilt graphics cards (no USB graphics).
    I can't switch to coherence mode (or any mode other than "normal")

    My problem ID is 889082.
     
  2. CharlesA

    CharlesA

    Messages:
    11
    Ready to pull the plug

    Nothing is working, the work around, the switching of main monitors and Parallels Support seems to be stumped. I really need the coherence for a trading program that is my livelihood. Guess I'll have to go back to 4, wish I could get my money back.
     
  3. CharlesA

    CharlesA

    Messages:
    11
    Ps

    I just noticed coherence works when I mirror monitors. Guess it's the same as unhooking my second monitor.
     
  4. sergk

    sergk Parallels Developers

    Messages:
    386
    Charles, problem is that USB-to-DVI display device drivers are installed inside your virtual machine (cause of it is BootCamp virtual machine). We are currently investigating this problem.

    The recommended workaround will be the next:
    - Turn off display mirroring
    - Boot into your virtual machine, open Device Manager (right click on 'My Computer', then Properties > Hardware > DeviceManager)
    - Open 'Display Adapters' tree and disable all display devices EXCLUDING 'Parallels Video Adapter'. Parallels Video Adapter must be enabled.
    - Shutdown virtual machine
    - Right-click on the VM and choose Show Package Contents.
    Right-click on config.pvs and choose Open With > Other...
    Choose TextEdit application to open XML based VM configuration
    Cmd-F to find "MaxDisplays" tag:
    <MaxDisplays>0</MaxDisplays>
    Replace value 0 with count of you displays
    Save changes
    - Run virtual machine. You must be able to go to Coherence with multiple displays

    But before booting in Boot Camp you will need to enable all disabled display devices backward.
     

    Attached Files:

  5. CharlesA

    CharlesA

    Messages:
    11
    Disabling Display Devices works.....

    BUT I didn't have to alter the VM package. Go figure. Thanks this helps a lot.
     
  6. SJR

    SJR

    Messages:
    31
    I too had this problem today - MacBook Pro 17" with 23" Apple Cinema Display attached via mini-DVI.

    Reinstalling Parallels Tools worked for me...
     
  7. Sebastian Korbei

    Sebastian Korbei

    Messages:
    1
    Hi Serge

    I have the same problem with a 17" Mac Book Pro and a 30" Cinema display:

    Unable to switch to Coherence.

    The virtual machine display configuration could not be applied. Please try again or contact the Parallels Support team for assistance.

    I have done the edit in config.pvs as described. I do not have a "Display Adapters" Section in the Device Manager Tab. I have 1 Error in the System Devices Tab: Intel(R) 82815 Processor to AGP Controller - 1131

    I have also tried all the other things (unplugging display, changing display for Parallels screen etc...)

    My configuration is:
    17" MacBook Pro
    30" Cinema Display with Mini DVI
    Windows XP under Parallels 5

    Many Thanks

    Seb
     
  8. cdrcsu

    cdrcsu Bit Poster

    Messages:
    6
    Coherence Task Bar Appears, then Disappears

    Serge and others:

    I applied the latest 5. release (9310, I believe) just last week to my XP VM. Coherence and Modality (and everything else) had been working fine with the previous 5. release.

    After the update and Tools installed, I rebooted the VM, logged into XP, the screen flipped into coherence and the XP taskbar appeared as usual at the bottom of my display - I have the Mac DOCK on the left side of my display. This is all what I expected.

    Momentarily, the taskbar began to fill out with the usual icons and the Start Menu Icon. Then it flashed and disappeared. ??? I have the taskbar viewed as default always, it remains so in the parallel preferences. Interesting enough, the Parallels preferences for coherence, modality and some of the other advanced display features are GREYed out !

    I've uninstalled and reinstalled the tools. Twice. No change.

    Advice? Otherwise, the program appears to work fine, the start menu is available from the DOCK and I have the top menu bar icons available for parallels, too.

    MacBook Pro, 17", summer 2009, 4GB, blah blah. I DO have a second monitor attached via the mini DVI port, the clamshell is closed (only viewing the one external monitor). I haven't tried or tested spanning.

    Interesting notes about spanning and I suspect, but do not know yet, related to this new feature.

    cdr
     
  9. sergk

    sergk Parallels Developers

    Messages:
    386
    Hi, cdrcsu!

    Please send Problem Report and post Problem Report ID here (you can send Problem Report from Help menu).
    We'll investigate your problem.

    P.S. Can you change guest TaskBar visibility through the View menu (Show/Hide Windows Taskbar menu item) or this menu item is disabled for you?
     
  10. cdrcsu

    cdrcsu Bit Poster

    Messages:
    6
    Hi Serge,

    I will do as you ask (problem report and ID). Unfortunately, my Macbook Pro is in the shop on an unrelated Apple warranty problem so may be a couple days.

    My recollection is that I could NOT see the Show/Hide Taskbar from View, greyed out. However, I'll check when the Macbook comes back.

    cdr
     
  11. cdrcsu

    cdrcsu Bit Poster

    Messages:
    6
    Serge,

    I was able to solve the problem. First - I had a host of issues related to a failing hardrive on my new Mac. Those have been resolved (new drive). The problems with Parallels occurred when I made the upgrade to the .9310 release for version 5. I suspect that the tool upgrade did not go well, could not be easily repaired so the result was what I reported, greyed out advanced features including Crystal, Coherence and Modality.

    I ended up uninstalling Parallels Tools but that made things even worse. I was unable to get Tools to reinstall. The problem was a failure to write to a log file when Setup Tools would start and that would then necessitate reboot and the problem would happen over and over again.

    I tried doing the prl_fs_drv.iso fix reported elsewhere in the forum. This did not solve the problem directly but it likely helped pave the way for making the fix I did find work out.

    This turns out to probably be a MS-XP-SP3 problem. The fix was to change the %TEMP% environment variable, clear out the %root%/System/TEMP directories of everything and then try again. Microsoft documents this for other MS software (but not specifially for Parallels). What happens is that Parallels AUTORUN (or by manually double clicking to start) unzips itself off the DVD image and loads the installation files into the systems TEMP where it then runs for the installation. The default SETUP uses default log files and locations for this and they got all twisted up during my various system crashes and failures. Once I did this, cleared the TEMP directories and altered the ENV variables (temporarily, I put them back to default) then Parallel Tools started, installed and finished perfectly.

    In any case, I now have a perfectly working Parallels, coherence (and other modes) are back.

    Thanks for your help.

    cdr
     
  12. Gerald C

    Gerald C

    Messages:
    3
    Sergk,

    When I try to use Coherence, I get the error: "Unable to switch to Coherence. The virtual machine display configuration could not be applied. Please try again or contact the Parallels Support team for assistance." I have reinstalled Parallels and Parallels Tools. Neither has corrected the issue. I checked the Device Manager in the Windows 7 VM. Under "Display Adapters," only "Video Controller (VGA Compatible)" is listed. My problem report ID is 8156336.
     
  13. sergk

    sergk Parallels Developers

    Messages:
    386
    Hi, Gerald.

    It seems that Parallels Video driver have not been installed in your guest OS.
    Please try to do next things:
    - ununstall Parallels Tools from guest OS (via Control Panel -> Programs and Features)
    - reboot guest OS
    - install Parallels Tools again using View->Install Parallels Tools menu item
     
  14. Kathleen R

    Kathleen R

    Messages:
    68
    Among other issues, I get that message that it can't do Coherence. This is in Parallels 5. I don't think I installed Tools. By mistake when I tried to use Parallels the 1st time I hit the wrong button & it created a 2nd virtual machine. Both of them use Bootcamp with Windows 7 as the virtual machine. My Windows 7 & Outlook were installed in Bootcamp by the Microsoft store. I installed a few other things such as Open Office, Adobe Reader & our co software.

    With mine, I sometimes get that error message, but then later after it is open I can go back in & get it into Coherence.

    But now I'm having problems with Mac programs crashing & it even got so I couldn't boot on the mac side. Did an archive & install. Then later reset Safari & emptied the Safari cache & then all of the other caches. Then Parallels was messed up & wouldn't work. Then booted into bootcamp & it woudln't work. Shut down & left for about a half hr or so. Came back & booted into bootcamp & then opened each program. Then shut down. Booted into Mac & opened Parallels & it worked. But its still not working right all the time.

    Safari is crashing a lot so I gave up & am in Parallels using IE.

    MacbookPro 13.3" 4 gb memory, Bootcamp partition set up by Microsoft with Windows 7 & Outlook installed & other windows software. Using bootcamp partition as virtual machine (actually 2nd VM set up by mistake that I want to get rid of)
     
  15. Gerald C

    Gerald C

    Messages:
    3
    Hi sergk,
    Your fix worked. I'm not sure why reinstalling Parallels Tools again fixed it, but it did. Thanks!
     
  16. joe.bruce

    joe.bruce

    Messages:
    5
    No Coherence - none of these solutions resolved the problem

    I tried reinstalling tools to no effect. I have 3 monitors plugged in via DVI and can't switch to coherence. I generated a problem report (#9592546). What other solutions can I try?
     
  17. TB_TX_

    TB_TX_

    Messages:
    1
    Coherance and mouse not working either

    I originally had a problem with my mouse. I had tried reinstalling Parallel tools as well as loading a new device driver for the mouse. Nothing worked.

    On further inspection, I also could not get Coherence to work. I was poking around in the display drivers and noticed I had "Air Display" activated as a display device. I disabled this display and now the mouse works and I can get into Coherence mode.

    Thanks for the help with this issue....

    TB
     
  18. Tony Farson

    Tony Farson

    Messages:
    1
    Try this.

    I have three monitors and have tried every trick on this post all to no avail. What finally fixed it for me was to put the the VM into full screen mode with the "user all monitor in full screen mode" option enabled. Then I detected and enabled all displays in Windows and BAM! Coherence started working like a charm. I find that I have to do this from time to time to keep it working.

    Cheers!
     

Share This Page