"No device drivers were found...." Can't finish Windows 7 install in 2010 MacBook Air

Discussion in 'Installation and Configuration' started by ChristinaA2, Nov 19, 2010.

  1. YanaYana

    YanaYana

    Messages:
    1,666
    You need to open Virtual Machine configuration (in virtual machine' s list right click, choose Configure) go to Hardware -> CD/DVD
     
  2. shishirc

    shishirc

    Messages:
    3
    @yana yana

    thnks yana but my pc has a windows 7 home premium instlled n virtual machine doesnt run on it ..can u suggest something else ?
     
  3. YanaYana

    YanaYana

    Messages:
    1,666
    well what we are talking here about is the situation when you have Mac and ou have Parallels desktop installed on it and there is a virtual machine based on Parallels Desktop running on Mac. So you are probably on a wrong forum.
     
  4. Pai-HungC

    Pai-HungC

    Messages:
    1
    I am encountering the same issue. After trying all possible venues, I've 99.99% concluded it's caused by the corrupted ISO image I downloaded.
     
  5. Sri Vamsi

    Sri Vamsi

    Messages:
    1
    I got it

    All it needs is to set the path for the drive/drivers to the ISO image, do it through the CD/DVD drive or try doing the install with UNIVERSAL USB INSTALLER which shall work for any OS(Ubuntu,fedora,solaris,windows vista,windows7...etc)
    Thanks to all the folks who helped me alot with this!! :)
     
  6. carlinchi

    carlinchi

    Messages:
    2
    Hey man! I was actually trying to do what you wrote but i don't how to work it out. I downloaded the ISO Image and saved it on my Penn Drive. You said something about changing from DVD to the ISO file on my penn. How do you do that? Please help, this has been really frustrating!
     
  7. carlinchi

    carlinchi

    Messages:
    2
    How do you change the CD-rom interface on a mac????
     
  8. YanaYana

    YanaYana

    Messages:
    1,666
    Open Virtual machine list > right click the machine you need > choose Configure > Go to hardware > CD/dvd > cinnect image file > locate your iso image file and connect it to Windows
     
  9. PaulNo

    PaulNo

    Messages:
    1
    I had this when I installed windows on Boot Camp. If you're installing from a Disc which you made yourself... just try burning the Windows 7 ISO to a new disc and DO NOT move the laptop/computer when it is doing so. On the first two tries I moved my laptop and I heard a funny scratching noise, probably the burn messing up. So yeah do the burn and leave the computer alone and it should be okay. I also installed with a DVD-RW not a DVD-R.
     
  10. JoBlue

    JoBlue

    Messages:
    1
    wow 3 year later still works... i had been frustrated that i could not install windows with iso image to dvd... it could not find drivers right after install screen... i changed sata ports to ide and worked! thanks AigarsJ! ... for the rest ... just dont forget to set ide back to sata and boot priority back to hdd...
     
  11. n8saffle

    n8saffle

    Messages:
    2
    I've tried all the solutions above to no avail. Downloaded ISO multiple times directly from Microsoft, used a known good install DVD, still not working. Tried installing from an ISO and a DVD in an external SuperDrive. I've even tried installing Windows XP and then upgrading and that doesn't work either.

    I'm on a MacBook Air Mid-2012. Parallels 8. Any help would be appreciated.
     
  12. n8saffle

    n8saffle

    Messages:
    2
    OK, so finally after a day of trying everything under the sun, I resolved my issue.

    I created an XP VM from ISO, Used Free ISO burner in XP VM to burn the Windows 7 ISO to DVD, then booted from that DVD in a New VM. It seems to be installing correctly now. Wow that is ridiculous to install an OS.
     
  13. UpfrontSolutionC

    UpfrontSolutionC Bit Poster

    Messages:
    1
    in my case, tried to install win7 or win xp to my lenovo e1030 using bootable usb, with default bios settings failed.
    solution for my case (inside bios), is to :
    1. disable usb xhci controller
    2. SATA Controller Mode set to Compatible
    3. Boot mode set to Legacy Support
    4. Boot Priority set to Legacy First, and of course
    5. Enable USB Boot and set Boot priority to designated device (in my case is the bootable usb)

    hope this helps
     

Share This Page