No help from Support: Router question

Discussion in 'Parallels Desktop for Mac' started by greg1075, Jul 1, 2006.

  1. greg1075

    greg1075

    Messages:
    50
    Hi all,

    I have contacted support 4 times over 2 weeks about this (both from the website's support page and directly to the tech support email address) and even though I own a registered copy of the programme, I haven't heard anything back.

    Here is my problem.

    First off technical my setup: I run Parallels Deskop on an iMac Duo Core 2Ghz with 1GB or RAM and a 250GB HD. I of course have Tiger 10.4.7. The guest OS I am running is XP home.

    I have found out that I need to use a router in order to get internet connectivity within the guest OS. When I plug my cable modem right into the iMac without going through the router, the guest OS shows "little or no connectivity". Is that normal? If not, how to fix it? I basically want to take the router out of the equation (if possible of course) because it slows down my connection.

    Any help appreciated.

    Thanks,

    Gregory
     
  2. greg1075

    greg1075

    Messages:
    50
    20 hits...no replies.

    Come on, people. :(

    Does anyone know if one NEEDS a router to use the internet in the guess OS or is there a way to do without? Does anyone of you use the internet in their guest OS and does NOT have/use a router?

    Thanks.
     
  3. joem

    joem

    Messages:
    1,247
    You need a router unless your cable modem has a built in DHCP server. A router will NOT slow down your connection if it's set up properly. My network wouldn't run at all without a router, and it's plenty fast.
     
  4. bartho

    bartho

    Messages:
    24
    As an alternative you can configure Mac OS X to forward the guest's Internet traffic: System Preferences --> Sharing --> Internet in Mac OS X.

    Then you won't need an external router, but as joem says: a router shouldn't slow down your Internet connection if it's configured properly (or rather, unless it's configured very improperly).
     
  5. greg1075

    greg1075

    Messages:
    50

    Thanks from the input from both you above. My router is a linksys. A couple of years old. It does slow down my connection a bit. When I go directly from the modem to the iMac I do notice a difference. I am not a specialist wbut I think it is setup correctly. I have opened a couple of ports needed by some of my programmes but apart from that haven't changed anything. At what level could it be badly setup?

    Bartho: I tried your solution above to no avail. I still get no internet in the guest OS. Could you specify the setting to make sure I selected the right items? Thanks!
     
  6. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    All I did was use the default Parallel settings that I showed on my install: Bridged Ethernet, Default Adapter.

    It just all started working, as soon as my XP booted up. I didn't have to configure anything. Am using a D-Link 624 router with my DSL Modem.
     
  7. greg1075

    greg1075

    Messages:
    50
    I think that may be the problem. I don't see the "Bridged Ethernet, Default Adapter" in the list.

    Stop me if I'm wrong, but the setting would be:

    Share your connection from: Built-in Ethernet
    To computers using: Bridged Ethernet, Default Adapter

    Is that right? Like I said the Bridged Ethernet, Default Adapter is not listed there.

    There IS a "Parallels Host-Guest Adapter" listed in the "Share your connection from" drop-down, but it doesn't make sense. At any rate I tried to select just in case and that still didn't make forward the internet connection to my guest OS.

    :(
     
  8. KaiserX

    KaiserX

    Messages:
    11
    Check your ISP

    Many ISPs will not allow you to pull more than one IP address. Therefore, when your router is connected, it is pulling the IP from the provider and then issuing requested IPs to the connected computers. When you bypass the router your Mac is taking the IP. Then when Parallels comes online, it's trying to grab an IP and your ISP is not issuing another. That's what sounds like is happening.
     
  9. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    I ***think*** I have it figured out. I created a new VM to experiment with just now, to try to duplicate your problem. You are fishing in the wrong configuration areas.

    Click on the bottom EDIT buttom. It will display an EDIT VIRTUAL MACHINE popup balloon. A new CONFIGURATION EDITOR window will show up, with all the main editable features. Among these will be "NETWORK ADAPTER | BRIDGED ETHERNET"

    You'll see radio buttons on the right. I think your ENABLED button is deselected. Select it.

    I have three of four buttons enabled by default:

    Enable
    Connect Cable at Startup
    _____
    Bridged Ethernet

    Host-only networking is NOT selected.

    DEFAULT ADAPTER is selected from the drop-down choicer.

    On my computer, these are the default values.

    Works for me. I didn't change a thing.
     
  10. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    [​IMG]

    ---------

    [​IMG]
     
  11. dkp

    dkp

    Messages:
    1,367
    You've provided little to work with. Are you using NAT or DHCP or neither? What is the IP of the host OS? What is the IP of the guest OS? Does your cable modem support both of these IP's at the same time? This is particularly important if your ISP has given you but one IP. What is your default route? Have you configured both the host and guest OS's to use it? How about the netmask? Is this configured correctly in the host and guest OS's? Using TCP/IP tools such as telnet or ftp, can you connect to the host OS from the guest OS? Can you ping it?

    dp
     
  12. greg1075

    greg1075

    Messages:
    50
    thanks for the help, Larry. Unfortunately the bridged ethernet adapater IS enabled in he VM.
     
  13. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    Well, durn. Enabling that is the only way I can get "NETWORK ADAPTER | BRIDGED ETHERNET" to show up.
     
  14. greg1075

    greg1075

    Messages:
    50
    That I haven't provided because I don't know the answers. I am not that tech savvy and quite frankly don't know where to look.

    To clarify. The internet works in BOTH OSX and the my guest OS (XP) AS LONG AS I go through the router. This is NOT a case of the internet not working at all in the guest OS. I am just trying to find a way to NOT have to use the router. If you tell me to look I will provide the answers the questions above.
     
  15. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    Let me try another stab... Are you on DSL? If so, you are using PPPoE to get in. The Mac will use that when you are NOT using a router. You'll have to provide a login name and password to the Mac PPPoE setup.

    Otherwise, the router will provide the PPPoE access and you don't have to worry about all of that. The router takes care of it, and if your computers are wireless, the router will take you in without your having to use network cable. And somewhere, during your setup, you had to provide a login name and password.

    Parallels would then crawl into the internet via the bridged ethernet. Parallels would use the Mac as a router or gateway.

    At least that is how I think it works... Wish we were there. I just can't help but think we could get this to work. I'm not kidding when I say it just popped in and started working for me.
     
  16. greg1075

    greg1075

    Messages:
    50
    That's it - I'm lost. :(
     
  17. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    Ok, this isn't a Parallels thing. Ummm. What if you went to the Apple desktop, select HELP, then in the search field, type PPPOE, and also DSL.

    There are a LOT of articles on network / internet connectivity in the Apple help menu. Keywords you need are DSL, PPPOE. Go slowly as this is all "greek" in the beginning, but it is more automatic than you think.
     
  18. joem

    joem

    Messages:
    1,247
    You say it works with the router. Why on earth don't you just use the router, and get on with life?

    Many cable and DSL modems will support only one machine hooked up to them. The Mac with a VM counts as two and probably won't work without a router.

    2+2=4, never 5, even for large values of two.
     

Share This Page