No input devices in Windows 11 after recent update

Discussion in 'Windows Guest OS Discussion' started by KristofferM, Jul 18, 2021.

  1. KristofferM

    KristofferM Bit Poster

    Messages:
    1
    I have not used my virtual machine for a week or two (when Windows 10 was automatically updated to Windows 11) but yesterday (Saturday 17th of July) I tried to play some games but there was an update that prevented me from gaming. After the update was installed and the machine had restarted, I am no longer able to use any input device (wireless mouse/wireless keyboard) in the virtual machine.

    Furthermore, I cannot connect any wired mouse/keyboard directly to the virtual machine, nor can I use any wired mouse/keyboard that is connected to macOS in the virtual machine. Obviously, this prevents me from using Windows to reset the system or to find out any build information, etc.

    Sharing/un-sharing Bluetooth devices with the virtual machine from the virtual machine settings does not work, either.

    I tried to connect a previously installed Bluetooth dongle directly to the virtual machine but since I cannot set up any new devices, I am not sure if this would be a workaround. The dongle is detected by Windows, though.

    Also, I have connected a wireless Windows keyboard to the virtual machine with a dedicated dongle, but Windows seemingly will not install any additional drivers/use any default drivers for the dongle, so the keyboard cannot be used. This is in line with not being able to use a wired keyboard connected to either macOS or the virtual machine directly, though.

    There was an update for Windows installed just a few moments ago but it seems it was small and there was no change in terms of input devices.

    Does anyone know how to fix this, please?
     

Share This Page