No keyboard/mouse after VPC conversion

Discussion in 'Parallels Transporter' started by hobiewahn, Jan 24, 2007.

  1. hobiewahn

    hobiewahn

    Messages:
    3
    Hello-
    I just converted my old Virtual PC hard drive (VPC mac 7.02), and everything appears to have gone smooth. It boots, but when I get to the login screen, I am unable to use the keyboard or mouse. I can click in the parallels window, and use ctrl-alt to release it, but the mouse does not move and they keyboard does not respond. I even tried plugging in a USB keyboard and mouse, assigning those devices to the VM, but still no go.

    Transporter version 1068 and Parallels version 3120. No problems with any of my other VM's .

    Thanks,
    Ryan
     
  2. DrSynth

    DrSynth

    Messages:
    1
    ... same for me

    I have the exact same issue, with the same versions of Transporter, Parallels and VPC you noted. The regular vm's are fine, the VPC converted vm is borked. BTW, all my vm's are WinXP SP2; Core2Duo iMac with 10.4.8

    My guess is the keyboard & mouse drivers VPC installed in Windows for their version of keyboard & mouse sharing are conflicting w/ those for Parallels

    I have a PIA workaround. First, I have a trackball in addition to the regular Mac keyboard and mouse. What works for me is to select the hard capture of the keyboard from the USB icon in the lower right frame of the OS window. However, the mouse won't work to select the login box. The trackball does. So I can type in my password and finish the login to Windows.

    Then I reset the virtual machine, and when it reboots, both usually work. Unfortunately, the keyboard won't be working in OSX, as it's hard captured. Oddly, after it resets sometimes just the regular mouse will work, sometimes just the trackball, sometimes both. And sometimes you have to reset it more than once.

    Don't hard capture the mouse, or else it & the trackball will disappear from being able to select the OS window to login ! Sometimes the ctl-alt keys will release it, sometime it won't. Then I have to invoke then exit Front Row via the remote to get the keyboard and mouse & trackball working in OSX.

    Manny
     
  3. zan

    zan

    Messages:
    1
    Same problem with Win2000 disk from VPC7

    Everything's converted and appears to be working... except I can't get any keyboard or mouse input to register. Kinda a dealbreaker!

    Tried first without removing the VPC additions and was unable to use mouse and keyboard.

    Then I went back to the source, uninstalled the VPC additions, restarted the VM, then shut it down again.

    After Transporting again, I have the same problem: still no mouse and keyboard.
     
  4. gmac

    gmac Bit Poster

    Messages:
    2
    me too

    I get identical results.

    No keyboard entry at login for W2K VM transported from VPC.

    I followed same procedure. At first I didn't uninstall VPC Additions prior to transport, then did uninstall VPC Additions, with same result.

    XP VPC VM works fine with or without uninstalling VPC Additions.

    Must be a flaw in Parallels Transporter.
     
  5. Upton O'Good

    Upton O'Good

    Messages:
    55
    Same here, BUT...

    The same thing happened to me, but after about five minutes, I was able to log in. See if this works for you. You may have to wait even longer if you have a slower computer. I'm working on a brand spankin' new 17" MacBook Pro.

    This seems like an absurdly long time to have to wait, and I thought it was completely broken at first too.
     
  6. nomadichermit

    nomadichermit

    Messages:
    10
    I was having some weird mouse issues too. Uninstalling the Microsoft Virtual PC additions cleared up all the issues, however.
     
  7. driver bob

    driver bob

    Messages:
    1
    I had these issues yesterday when I tried to install XP Pro and Vista Ultimate. Nothing I tried would get keyboard functionality (though the touchpad did work).

    When I restarted the macbook this morning everything is functioning fine.

    Maybe it's working becuase I emailed technical support ;)
     

Share This Page