"no operating system installed" and partitioning problems

Discussion in 'Installation and Configuration of Parallels Desktop' started by petkusj, Apr 1, 2008.

  1. petkusj

    petkusj Bit poster

    Hi! Like several other people, I'm having trouble getting Parallels to recognize the Boot Camp partition on which I successfully installed Vista. Neither editing existing configurations or making new ones and using the Boot Camp partition have worked. Of course, during the Boot Camp/Vista install, I ran into problems and had to delete the partition created by the Boot Camp Assistant and create one with the Windows installer. So that partition is no longer called Boot Camp (although in Windows, I did rename it).

    The partition is also on the drive in bay 2, alongside a Mac partition.

    So I don't know if the problem is that the partition was renamed, or if it's because the partition is on a secondary drive.

    I would appreciate any help.


    PS Mac Pro quad core/4GB/10.5.2 and Parallels build 5584.
  2. petkusj

    petkusj Bit poster

    Just thought I'd post this further attempt to get the Boot Camp partition to work. Like a lot of other people, I've edited the pvs file to show

    Disk 0:0 image = Boot Camp;disk0s3

    After obtaining the drive identifier from the diskutil list command (it's actually a lot easier to find this by looking at Disk Utility).

    But still no joy. I thought this would work, but I still get the same message, although I notice that the Parallels startup screen also says "No boot device available." Even though I can boot from this partition.

    However, I also noticed that I failed to mention that my Boot Camp partition won't show up on the Mac desktop nor can I select it as a Startup disk. I'm beginning to think that I should reformat/repartition my second drive and start the whole thing over again.

  3. petkusj

    petkusj Bit poster

    I just talked to an Apple rep who said the reason my Boot Camp partition is not showing up is because Vista repartitioned it as NTFS, which 10.5 completely ignores. I knew I shouldn't have gotten Vista and stuck with XP!

    I think I will have to give up and simply have two installations: a Boot Camp partition and a Parallels virtual machine. I don't think it will help to reformat and start over.
  4. FyKnight

    FyKnight Bit poster

    Hi petkusj,

    I recently spent a whole day getting Parallels to work with the BootCamp partition on my triple-boot MacBook Pro. I'll post a thread detailing what I discovered in a bit; it does some funny things. In the meantime can you describe the error you're seeing in more detail? Maybe attach a screenshot of the boot screen when it hangs. Oh and maybe include the output of 'diskutil list'...

    As far as I understand, it should be possible to at least get Parallels to boot an NTFS partition even if it's unable to install its software tools.
  5. petkusj

    petkusj Bit poster

    Thanks for the reply, FyKnight. Because of slightly misleading advice from Apple support (concerning another unrelated issue), I reformatted and reinstalled 10.5 and also gave up on the Boot Camp partition and just let Parallels create its virtual machine.

    I did create two partitions on my extra drive and let Parallels exclusively use one of those partitions.

    In other words, I gave up ... for now. Maybe if I have a killer game that I want to play, I'll revisit this and use that other partition.


    PS I'd still like to hear your solution.
  6. scootz

    scootz Bit poster

    Hi Guys

    I'm have exactly the same problem as petkusj - i have a multi partitioned drive, Vista on bootcamp with NTFS file system. Vista on bootcamp has been working no problem. Parallels first says there is a problem with multi partition drive, then I changed .pvs file to read Boot Camp;disk0s3 and now it says "no operating system installed".

    If FyKnight can help, i would be, lets say, happy!

    Here is paste from my diskutil list:

    Last login: Sat Apr 5 16:32:50 on ttys000
    ppp-58-8-88-233:~ scotttayler$ diskutil list
    0: GUID_partition_scheme *149.1 Gi disk0
    1: EFI 200.0 Mi disk0s1
    2: Apple_HFS Macintosh HD 102.9 Gi disk0s2
    3: Microsoft Basic Data 45.9 Gi disk0s3
    ppp-58-8-88-233:~ scotttayler$

    When I start parallels it just goes to a "command line" type screen and says no boot drive is available and that hard drive, CD, and floppy drives have failed to boot, then message that there is no operating system installed and to insert OS CD etc.

    I really don't want to repartition and / or reinstall Vista - so please, help!


  7. petkusj

    petkusj Bit poster


    Hey scootz, I did finally get my Boot Camp partition recognized by the Mac desktop and by Parallels, although I haven't taken the final step to get Parallels to use the BC partition.

    Here's what happened: I finally gave up and created a standard Mac partition and let Parallels handle the Windows Vista install and create a virtual machine. It works as well as any Parallels Vista virtual machine: audio stutters on playback and there are some display issues, but I can run Internet Explorer well enough to check out the pages I'm designing.

    But I thought I'd like to install Boot Camp as well because the NetFlix streaming video sounds horrible. So, I used Disk Utility to split the Mac partition into two, so instead of a 150 GB partition, I have two 75GB partitions, one Mac and the other FAT 32.

    Then I rebooted with the Windows installer and let the installer reformat the FAT 32 as NTFS. After that, it was relatively easy (ignoring all the purely Windows issues) and I was able to install the Boot Camp software on the Vista partition.

    Of course, all this happened (4/3/08) shortly after a round of 10.5.2 updates and the firmware update for my Mac Pro.

    And now, despite what an Apple support tech said, the NTFS Boot Camp partition shows up on my Mac desktop and I can see it as a startup device. And Parallels asks whether I want to select My Boot Camp as a virtual machine, something it never did before.

    So, I don't know if not using Boot Camp Assistant was the key or the firmware updates did the trick, but I'm just going to live with a separate Parallels virtual machine on one partition and a dedicated Vista install on another.

  8. merlik

    merlik Bit poster

    I am having the same problem. I can't get Vista to boot no matter what I do. Anyone able to explain how to make it work yet? Even when I boot from the Vista DVD and try to repair, the repair doesn't detect Windows. But when I boot into Vista on the Boot Camp Partition itself, it works just fine. Why can't Parallels see it?

Share This Page