No sound at Catalina 10.15.2! (Parallels Desktop 15.1.2 for Mac)

Discussion in 'General Questions' started by NikolayA2, Jan 31, 2020.

  1. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,694
    Hi, thank you for the provided information and for your private message.
    This issue is under investigation with Parallels Engineering Team. They are continually working on issue that are escalated from our Support Team; however do not share an ETA for fix until one is available.
    Once we get any updates we will contact you.
     
  2. ChrisR20

    ChrisR20

    Messages:
    2
    Hi, I found a fix for my setup (macOS 10.15.7, Parallels Desktop 16.5.0 for Mac, VM: Win10, 20H2, 19042.928):
    • giving the Parallels desktop App full disk access under macOS security settings (not sure if that is really needed)
    • in the advanced Sound & Camera settings of the VM I chose "AC'97" and then the "Parallels Audio Controller" did show up under the windows devices
    Hope this is useful for you -- oh and I use a thunderbolt 3 hardware audio device with the VM.
    .C
     
    AmirK2 likes this.
  3. AmirK2

    AmirK2 Bit Poster

    Messages:
    5
    Where can I "the "Parallels Audio Controller" did show up under the windows devices".... in Parallels?
     
  4. ErnestoR1

    ErnestoR1

    Messages:
    1
    I have the same problem with Mac audio and video with Ubuntu VM (latest Big Sur 1.4). I had this issue for a long time already. It is really annoying. Audio and video stop working after a while when I open a VM. I work constantly in my ubuntu VM thus anytime I have a meeting I need to close my VM and do a
    sudo killall coreaudiod. I hope parallels fixes this issue soon. I have been considering moving to other VM tool.
     
  5. brandonf2

    brandonf2 Bit Poster

    Messages:
    8
    I completely removed the sound hardware from the VM and it still did it. I found a workaround though: lower the RAM and CPU to 4GB and 2 cores respectively.

    somehow this stopped it from stealing my audio and it made Mac faster AND the windows VM faster. Seems like there is a bug when assigning more than 4GB of RAM.
     
  6. StevenT10

    StevenT10 Bit Poster

    Messages:
    7
    After updating to Catalina 10.15.2, Airpods stopped working with my Macbook. Apple mentioned these steps and I tried but not working. I followed this article https://geniusgeeks.com/airpods-sound-microphone-muffled/ and also followed Apple guide which is this "Make sure the speakers are connected to the audio out port on your Mac or display, as well as a power supply if necessary. On your external speakers, look for a power switch and a volume control. Turn on the speakers and adjust the volume if necessary."

    Still facing the issue.
     
  7. MattG12

    MattG12 Bit Poster

    Messages:
    2
    So I also have a similar problem with sound. Whenever I run Parallels it kills my system sound. Can't make Teams calls from my Mac, my mic and speakers don't work. I plug in headphones but still no joy. It also kills YouTube. The videos stop playing sound and then, eventually, they stop loading altogether. If I shut down parallels all the problems go away.

    Please fix this issue! It's making my day almost impossible!

    MacBook Pro (16 inch, 2019) running macOS Big Sur v11.4 and Parallels Desktop 16 for Mac Pro Edition v16.5.1 running a windows 10 VM.
     
  8. WomackDev

    WomackDev Bit Poster

    Messages:
    1
    I just encounter the same exact issue with version 17 on Big Sur 11.5.1 on a MacBook Pro 15 in - 2017. The only workaround was to suspend the vm and reactivate. I resolved the issue by reverting to the last version of 16 and it hasn't occurred again.
     
    ChristophD4 likes this.
  9. LeifM1

    LeifM1

    Messages:
    1
    I'm using 17 with 11.5.2 on a 15" 2017 Macbook Pro and have had this issue for some time but it *appears* that sound/mic works when I am not in coherence mode.
     
  10. ChristophD4

    ChristophD4 Bit Poster

    Messages:
    1
    I'm using also 17 with 11.5.2 on a 15" 2018 Macbook Pro. I tried a lot and couldn't find the "trigger" inside my VM Windows 10 64bit. Today, when I changed to Hypervisor "Apple", my sound works the whole workday, so this seems to be the workaround. My Support ticket three days ago is still waiting to be answered.
    Thanks to parallels for "quick" help :/
     
  11. ZhenT1

    ZhenT1 Bit Poster

    Messages:
    20
    Got same issue with macOS 11.6 and Parallels Desktop 17.0.1
     
  12. ZhenT1

    ZhenT1 Bit Poster

    Messages:
    20
    It seems fine for me: use Apple hypervisor and killall coreaudiod, don't know how long can I use it.
     
  13. JerryM6

    JerryM6 Bit Poster

    Messages:
    2
    I was encouraged by the last release note "Resolves an issue with sound sometimes disappearing on a Mac after running a virtual machine" in the 17.1.0.51516 patch but this still does not resolve the issue.
     
  14. ZhenT1

    ZhenT1 Bit Poster

    Messages:
    20
    Thanks! I tried it, it doesn't fix this issue.
     
    NathanC6 likes this.
  15. NathanC6

    NathanC6 Bit Poster

    Messages:
    4
    same - Big Sur 11.6 / Windows 10 vm
    The patch seemed to work for a few days and then it was back to 'normal' - so maddening to be on a call w/ work and then *poo* no audio.
     
  16. McallenT@Parallels

    McallenT@Parallels Staff Member

    Messages:
    107
    Hello @NathanC6, Please refer to this KB article to: https://kb.parallels.com/115835 to reinstall Parallels tools and check. If the issue persists please refer to this KB articl: https://kb.parallels.com/6571 to create a support ticket and reply to this message with the ticket number, so we can assist you further. Thanks, McAllen.
     
  17. klauserd

    klauserd Bit Poster

    Messages:
    1
    I've got the same issue with a MacBook Pro 16 and running Big Sur.
    Downgraded to Version 16 (from 17) and now it works again.
     

Share This Page